LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Xfce terminal shows "bash-3.11" instead of the path (http://www.linuxquestions.org/questions/slackware-14/xfce-terminal-shows-bash-3-11-instead-of-the-path-613293/)

jsmith6 01-13-2008 11:19 AM

Xfce terminal shows "bash-3.11" instead of the path
 
I can see a bash-3.11 instead of user@darkstar~$ that I see on pure console (Ctrl-Alt-F1). I also see bash-3.11 on xterm and I see a sh-3.11 rxvt.

I have the aliases from ~/.bashrc but not the ones from /etc/profile.d/coreutils-dircolors.sh. This means I can solve the problem by adjusting my .bashrc but this seems like a "hack". It's not a problem to do this for all the user accounts but I like solutions that work at once for everything.

Why doesn't Terminal has the same settings like standard console does? And how I can change its default behavior?

gnashley 01-13-2008 11:58 AM

Different strokes... Not all programs will use the same method or info for setting what you want. Short of a small patch for each program or choosing programs which display the way you want, I don't see a way around this.

marciobarbalho 01-13-2008 12:58 PM

edit "terminal" command by right-clicking on that icon, by the way, try out some like this:

user@darkstar~$ terminal -ls &

try "pwd" command, it shows the path

user@darkstar~$ pwd

that's it! You have to replace it, "terminal -ls" instead of "terminal"

tobyl 01-13-2008 01:20 PM

Or, Open a Terminal session. Go Edit > Preferences

You will see a sub heading "Command"

Check the box that says "Run Command as login shell"

Restart Terminal.


tobyl

rg3 01-13-2008 01:24 PM

There is an entry on this here: http://slackwiki.org/Login_Shell

jsmith6 01-13-2008 02:30 PM

Quote:

Originally Posted by marciobarbalho
user@darkstar~$ terminal -ls &

that's it! You have to replace it, "terminal -ls" instead of "terminal"

xterm and rxvt both support the -ls switch which produces exactly what I wanted. The Xfce terminal doesn't. But I managed to get it with this:

Quote:

Originally Posted by tobyl
Or, Open a Terminal session. Go Edit > Preferences

You will see a sub heading "Command"

Check the box that says "Run Command as login shell"

Restart Terminal.

=====

Quote:

Originally Posted by rg3
There is an entry on this here: http://slackwiki.org/Login_Shell

This website will come very handy :D By the way, the author dislikes the .bashrc solution as much as I do :-P

Quote:

Originally Posted by marciobarbalho
try "pwd" command, it shows the path

This works but it's tiresome to type pwd all the time.

Thank you all for your quick replies.


All times are GMT -5. The time now is 08:52 AM.