LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 07-26-2005, 01:17 PM   #1
brokenflea
Member
 
Registered: Nov 2003
Distribution: Slackware 11.0, FreeBSD
Posts: 284

Rep: Reputation: 30
WPA Supplicant Question


i'm using the netgear wg511 v2 (made in taiwan) pc card. i have it configured fine with ndiswrapper accessing my wireless router. the encryption, though, its using is wep and i wanted to go with WPA.
so i installed wpa_supplicant and whenever i run

wpa_supplicant -Dndiswrapper -iwlan0 -c/etc/wpa_supplicant.conf -dd

this is the error i'm getting :

Initializing interface 'wlan0' conf '/etc/wpa_supplicant.conf' driver 'ndiswrapper'
Unsupported driver 'ndiswrapper'.


is anyone out there been able to use WPA successfully on this card and if there's a way to get this up and running i would really appreciate it. i'm also using a 2.6.10 kernel with the prism54 driver compiled in the kernel.

any help would be gladly appreciated.

TIA
 
Old 07-27-2005, 05:58 AM   #2
chess
Member
 
Registered: Mar 2002
Location: 127.0.0.1
Distribution: Slackware, OpenBSD, FreeBSD
Posts: 728

Rep: Reputation: 168Reputation: 168
Why are you using ndiswrapper if your card uses prism54 driver? If your wifi card uses the native prism54 driver then doesn't that mean you don't need ndiswrapper?

I use ndiswrapper and wpa_supplicant on my dell 700m. How did you build wpa_supplicant? Did you include ndiswrapper or madwifi in your config file?
 
Old 07-27-2005, 07:54 PM   #3
brokenflea
Member
 
Registered: Nov 2003
Distribution: Slackware 11.0, FreeBSD
Posts: 284

Original Poster
Rep: Reputation: 30
yeah, that's true. i have no clue why i'm using ndiswrapper. when i dmesg it tells me that the prism54 driver has been loaded but when i type in lspci as root, what it brings up is this:

Code:
01:00.0 Ethernet controller: Marvell: Unknown device 1faa (rev 03)
so i'm assuming netgear support lied to me and told me that my card uses the prism chipset.
 
Old 07-27-2005, 08:11 PM   #4
chess
Member
 
Registered: Mar 2002
Location: 127.0.0.1
Distribution: Slackware, OpenBSD, FreeBSD
Posts: 728

Rep: Reputation: 168Reputation: 168
if you do need to use ndiswrapper, then you need to enable that when you build wpa_supplicant in your wpa_suppliant .config file. I think the "Unsupported driver 'ndiswrapper'" message means that you didn't include ndiswrapper when you built wpa_supplicant. Not positive, but I think that's what that means.
 
Old 07-28-2005, 06:42 PM   #5
brokenflea
Member
 
Registered: Nov 2003
Distribution: Slackware 11.0, FreeBSD
Posts: 284

Original Poster
Rep: Reputation: 30
thanks for your info. i recompiled wpa_supplicant again and it started working. the only other question i have is, initially my AP had broadcast ssid disabled and wpa_supplicant didn't work with it being disabled, but when i enabled it, it started working. is there anyway i can have the ssid broadcast disabled but still have wpa working on my network..

TIA
 
Old 07-28-2005, 07:33 PM   #6
chess
Member
 
Registered: Mar 2002
Location: 127.0.0.1
Distribution: Slackware, OpenBSD, FreeBSD
Posts: 728

Rep: Reputation: 168Reputation: 168
Yes, there is. I had this same problem, but Jouni, the wpa_supplicant developer, pointed me in the right direction. Turns out it was sort of buried in the commented wpa_supplicant.conf example that is found on the wpa_supplicant site.

What you need to do is specify the encryption algorithm and the group setting variables in the wpa_supplicant.conf file. You can get your encryption algorithm from your router. You also need to add ap_scan=2. So, for example, my wpa_supplicant.conf file looks like this:

ap_scan=2
network={
ssid="myessid"
scan_ssid=1
key_mgmt=WPA-PSK
pairwise=TKIP
group=TKIP
psk="myencryptionkey"
}

I had to use TKIP on my router instead of CCMP/AES since I also have an older Apple iBook with does not support CCMP, only TKIP. But, wpa now works great with my essid broadcast disabled.

HTH.
 
Old 07-28-2005, 07:38 PM   #7
chess
Member
 
Registered: Mar 2002
Location: 127.0.0.1
Distribution: Slackware, OpenBSD, FreeBSD
Posts: 728

Rep: Reputation: 168Reputation: 168
I should say that the encryption algorithm and the group setting have to be the same, so if you use CCMP, then both the pairwise and the group_id setting would both be "CCMP" instead of "TKIP".

here is the text from the sample wpa_supplicant.conf file that gives you the answer (this is near the top in the discussion on the ap_scan variable:

Code:
# AP scanning/selection
# By default, wpa_supplicant requests driver to perform AP scanning and then
# uses the scan results to select a suitable AP. Another alternative is to
# allow the driver to take care of AP scanning and selection and use
# wpa_supplicant just to process EAPOL frames based on IEEE 802.11 association
# information from the driver.
# 1: wpa_supplicant initiates scanning and AP selection
# 0: driver takes care of scanning, AP selection, and IEEE 802.11 association
#    parameters (e.g., WPA IE generation); this mode can also be used with
#    non-WPA drivers when using IEEE 802.1X mode; do not try to associate with
#    APs (i.e., external program needs to control association). This mode must
#    also be used when using wired Ethernet drivers.
# 2: like 0, but associate with APs using security policy and SSID (but not
#    BSSID); this can be used, e.g., with ndiswrapper and NDIS drivers to
#    enable operation with hidden SSIDs and optimized roaming; in this mode,
#    the network blocks in the configuration file are tried one by one until
#    the driver reports successful association; each network block should have
#    explicit security policy (i.e., only one option in the lists) for
#    key_mgmt, pairwise, group, proto variables
ap_scan=1
 
Old 07-28-2005, 09:18 PM   #8
brokenflea
Member
 
Registered: Nov 2003
Distribution: Slackware 11.0, FreeBSD
Posts: 284

Original Poster
Rep: Reputation: 30
thanks again for your info, it seems to be working fine. i hate to bombard you with problems, but every once in a while like 8-9 seconds the network card seems to drop the connection and picks it up again. any idea what this might be.

Thanks again for all your help, i really apprecaite it.

--EDIT----

The router just needed a firmware upgrade. Its fixed!!! and works great. Thanks again for all your help! I really appreciate it

Last edited by brokenflea; 07-29-2005 at 12:22 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
**wpa supplicant authentication issues patkalolo Linux - Wireless Networking 5 12-28-2005 01:59 PM
WPA Supplicant Question mikeCanada Suse/Novell 5 12-21-2005 09:43 PM
2.6.13 and WPA supplicant not playing with each other andy_lee Linux - Wireless Networking 3 09-23-2005 02:35 PM
Wpa Help shinny Linux - Wireless Networking 2 08-28-2005 09:53 AM
How do i set up WPA PSK with wpa supplicant and linuxant? Eleavings Linux - Wireless Networking 4 12-27-2004 11:24 AM


All times are GMT -5. The time now is 01:06 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration