LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 11-12-2004, 05:47 PM   #1
lagartoflojo
Member
 
Registered: Sep 2004
Location: Santiago de Chile
Distribution: Slackware 10.2
Posts: 46

Rep: Reputation: 15
USB Printer problem: usb 1-2: device not accepting address 3, error -71


I have a problem with my Epson Stylus Photo R300M: it apparently chooses to work only randomly. I have been able to install it and print with no problems, but sometimes i boot and it is not detected by the system, ie CUPS does not show it as a device and it says "Unable to open USB device "usb://EPSON/Stylus%20Photo%20R300": No such device". Running a dmesg i get the following:
Code:
hernan@hernan:~$ dmesg | grep -i usb
usbcore: registered new driver usbfs
usbcore: registered new driver hub
ehci_hcd 0000:00:10.3: VIA Technologies, Inc. USB 2.0
ehci_hcd 0000:00:10.3: new USB bus registered, assigned bus number 1
ehci_hcd 0000:00:10.3: USB 2.0 enabled, EHCI 1.00, driver 2004-May-10
hub 1-0:1.0: USB hub found
ohci_hcd: 2004 Feb 02 USB 1.1 'Open' Host Controller (OHCI) Driver (PCI)
USB Universal Host Controller Interface driver v2.2
uhci_hcd 0000:00:10.0: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller
uhci_hcd 0000:00:10.0: new USB bus registered, assigned bus number 2
hub 2-0:1.0: USB hub found
uhci_hcd 0000:00:10.1: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (#2)
uhci_hcd 0000:00:10.1: new USB bus registered, assigned bus number 3
hub 3-0:1.0: USB hub found
uhci_hcd 0000:00:10.2: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (#3)
uhci_hcd 0000:00:10.2: new USB bus registered, assigned bus number 4
hub 4-0:1.0: USB hub found
usbcore: registered new driver usblp
drivers/usb/class/usblp.c: v0.13: USB Printer Device Class driver
PCI0 UAR1 USB1 USB2 USB3 EHCI PS2M PS2K  AC9  MC9 ILAN
usb 1-2: new high speed USB device using address 3
usb 1-2: device not accepting address 3, error -71
usb 2-1: new full speed USB device using address 2
usb 2-1: config 1 has an invalid descriptor of length 24, skipping remainder of the config
usb 2-1: string descriptor 0 read error: -22
usb 2-1: string descriptor 0 read error: -22
usb 2-1: string descriptor 0 read error: -22
usb 2-1: string descriptor 0 read error: -22
usb 2-1: string descriptor 0 read error: -22
usb 2-1: string descriptor 0 read error: -22
usb 2-1: string descriptor 0 read error: -22
usb 2-1: string descriptor 0 read error: -22
usb 2-1: string descriptor 0 read error: -22
usb 2-1: string descriptor 0 read error: -22
usb 2-1: string descriptor 0 read error: -22
usb 2-1: string descriptor 0 read error: -22
usb 2-1: string descriptor 0 read error: -22
usb 2-1: string descriptor 0 read error: -22
usb 2-1: string descriptor 0 read error: -22
usb 2-1: string descriptor 0 read error: -22
usb 2-1: string descriptor 0 read error: -22
usb 2-1: USB disconnect, address 2
usb 2-1: new full speed USB device using address 3
usb 2-1: USB disconnect, address 3
usb 1-1: new high speed USB device using address 6
usb 1-1: device not accepting address 6, error -71
So USB is working, in fact my Mustek scanner works no problem-- so the problem is that "device not accepting address #, error -71", which appears twice: when i booted the PC and when I disconnected and reconnected the printer. Searching for "has an invalid descriptor of length" on google returned a patch
(cannot display URL because too few posts...)
but I have no idea if it will work, or even _how to apply it_. Apparently this is a kernel patch... I have no problem recompiling the kernel.
Any help appreciated!!!

Hernan

Last edited by lagartoflojo; 11-15-2004 at 04:14 PM.
 
Old 11-13-2004, 04:26 PM   #2
lagartoflojo
Member
 
Registered: Sep 2004
Location: Santiago de Chile
Distribution: Slackware 10.2
Posts: 46

Original Poster
Rep: Reputation: 15
Can someone at least tell me if it is necessary to apply the patch and how to do it ?..... please?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
USB camera - device not accepting address .., error -110 ndegrace Linux - Hardware 4 05-28-2005 11:34 AM
"usb device not accepting address" caused by IFP-driver (IRiver) interrupt? Mitchua Linux - Hardware 0 09-24-2004 09:14 PM
USB Device not accepting new address LOUDSilence Linux - Hardware 15 09-21-2004 05:53 PM
USB Device not accepting address systemparadox Linux - Hardware 2 08-24-2004 10:00 AM
USB Printer Problem "device not accepting new address" deckmoney Linux - General 1 04-16-2003 04:33 PM


All times are GMT -5. The time now is 02:44 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration