LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 01-28-2010, 08:26 AM   #1
troj3n
LQ Newbie
 
Registered: Apr 2009
Posts: 21

Rep: Reputation: 15
Unable to build from Slackbuild in slackware 13


Hi Guys

I installed slackware 13 i386 reacently

i was trying to build wvstreams and wvdial

when i give the ./wvdial.Slackbild it runs for quite some time and at the end while creating the package it gives me an error cannot find gzip compression utility in $PATH. and there is no tgz or txz package in /tmp folder

then i ran pkgtool and found that gzip isnt installed. the i installed it from the slackware dvd. but still i am getting the same error

Please help me at the earlies

Thank you all in advance

Best Regards
TrOJ3n
 
Old 01-28-2010, 08:49 AM   #2
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 2,457

Rep: Reputation: 886Reputation: 886Reputation: 886Reputation: 886Reputation: 886Reputation: 886Reputation: 886
you can verify the PATH environment variable you are using in the shell from which you execute the slackbuild with this command
Code:
set | grep PATH | grep bin
blind guessing, maybe you have some ~/.bashrc ~/.bash_profile or /root/.bashrc /root/.bash_profile that set differently your PATH variable.
try also becoming root with the command
Code:
su -
so that the root user get his correct PATH env var.

Last edited by ponce; 01-28-2010 at 08:52 AM.
 
Old 01-28-2010, 08:59 AM   #3
MS3FGX
Guru
 
Registered: Jan 2004
Location: NJ, USA
Distribution: Slackware, Debian
Posts: 5,852

Rep: Reputation: 351Reputation: 351Reputation: 351Reputation: 351
If you were missing gzip, then that tells me either something went wrong with the install or otherwie somebody tried to go in and remove packages they though they wouldn't need.

In either event, SlackBuilds are designed to be used on full Slackware installs. It is assumed that you are starting from a full, stock, Slackware system. Anything else, and you are pretty much on your own.

I think your first step should be to go through your installed packages and see just what is missing, of if you would rather, reinstall and make sure you choose a full installation. You can always go back and remove things you are sure you don't need on your desktop (like Apache and sendmail) later, but at least this way you are sure all the core components are installed before doing anything else.
 
Old 01-28-2010, 09:37 AM   #4
troj3n
LQ Newbie
 
Registered: Apr 2009
Posts: 21

Original Poster
Rep: Reputation: 15
the path of the appliccation gzip is given there when i do the command u said

what else can be done
 
Old 01-28-2010, 09:42 AM   #5
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 2,457

Rep: Reputation: 886Reputation: 886Reputation: 886Reputation: 886Reputation: 886Reputation: 886Reputation: 886
can you please issue the command
Code:
file /bin/gzip
and post the output?
 
Old 01-28-2010, 10:38 AM   #6
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2014.08, Slack14.1 DebWheezy, +50+ other Linux OS, for test only.
Posts: 13,939

Rep: Reputation: 2601Reputation: 2601Reputation: 2601Reputation: 2601Reputation: 2601Reputation: 2601Reputation: 2601Reputation: 2601Reputation: 2601Reputation: 2601Reputation: 2601
No problems with either, wvstreams, wvdial on my Slackware 13, "i486".
So it isn't a bug in the wvdial files.

'gzip' is not used at compile time, but for the final
gzipping the package, wvdial-1.60-i486-1_SBo.tgz .

You can get the Slackware packages from http://www.slacky.eu/

wvdial - 1.60 > > http://www.slacky.eu/aadm/pkgs/index.php?ver=13&pkg=987
> > http://repository.slacky.eu/slackwar...0-i686-5bj.txz
> wvdial-1.60-i686-5bj.txz
.....
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Unable to build from Slackbuild in slackware 13 troj3n Slackware 1 01-28-2010 03:50 PM
What changes must be made in a slackBuild from 11.x To build for Slackware64 current? Alexvader Slackware 5 12-30-2009 01:38 PM
[SOLVED] can't build texlive slackbuild portia Slackware 27 12-28-2009 07:41 AM
Unable to compile libphp5.so with 12.2 php.Slackbuild (trying to add mycrypt) brainycat Slackware 9 02-17-2009 10:46 PM
SlackBuild.org nvidia kernel build script bug Woodsman Slackware 3 04-06-2008 07:48 PM


All times are GMT -5. The time now is 04:51 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration