LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 02-04-2014, 12:22 PM   #1
Habitual
Senior Member
 
Registered: Jan 2011
Distribution: Undecided
Posts: 3,622
Blog Entries: 1

Rep: Reputation: Disabled
The dreaded libnss3.so "error" in libreoffice/pkg/14.0


I just spent like an hour messing with Google Chrome fighting the libnss3.so error running that package. Well, I fixed that issue, but now, when I install LOffice 4.1.4 package for x86_64, I have that error re-appearing.

libreoffice-3.5.6-i486-1alien runs fine and without issue.
libreoffice-4.1.4-i486-1alien spits out
Code:
/usr/lib/libreoffice/program/soffice.bin: error while loading shared libraries: libnss3.so: cannot open shared object file: No such file or directory
Packages installed at the moment:
Code:
ls -1 /var/log/packages/ | grep -iE "office|seamonkey|mozilla-nss"
libreoffice-4.1.4-i486-1alien
libreoffice-dict-en-4.1.4-i486-1alien
seamonkey-2.23-x86_64-1_slack14.0
seamonkey-solibs-2.23-x86_64-1_slack14.0
seamonkey-solibs-compat32-2.23-x86_64-1_slack14.0compat32
Am I forced to use 3.5.6 for the duration or Do I need to install mozilla-nss-3.15.4-x86_64-1
to have LOffice4.1.4?

Thanks.

Edit: Sorry, installing from http://www.slackware.com/~alien/slac...fice/pkg/14.0/

Stand by, I just realized a possible issue (486 vs 64)...

Last edited by Habitual; 02-04-2014 at 12:28 PM.
 
Old 02-04-2014, 12:30 PM   #2
gengisdave
Member
 
Registered: Dec 2013
Location: Turin, Italy
Distribution: slackware
Posts: 288

Rep: Reputation: 59
you need the i486 version of mozilla-nss
 
Old 02-04-2014, 12:32 PM   #3
Habitual
Senior Member
 
Registered: Jan 2011
Distribution: Undecided
Posts: 3,622
Blog Entries: 1

Original Poster
Rep: Reputation: Disabled
gengisdave:

Thanks. I am stepping through the install with libreoffice-4.1.4-x86_64 files this time.
Too much caffeine, I guess.
 
Old 02-04-2014, 12:40 PM   #4
Habitual
Senior Member
 
Registered: Jan 2011
Distribution: Undecided
Posts: 3,622
Blog Entries: 1

Original Poster
Rep: Reputation: Disabled
well, for a "Type A" personality, I sure do miss some details now and then.

Fixed!
Code:
ls -1 /var/log/packages/ | grep -iE "office|mozilla-nss"
libreoffice-4.1.4-x86_64-1alien
libreoffice-dict-en-4.1.4-x86_64-1alien
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Dreaded "oh no! something went wrong" Message. I cant find the source of the problem KroniK Fedora 3 11-29-2013 10:05 AM
"pkg-config not found" error when trying to build makedepend (needed for Xorg). Quon Linux From Scratch 1 11-14-2011 09:27 PM
[SOLVED] Dreaded "Out of Range" error on Viewsonic VG171b w/ATI RADEON 9100 ian.macky Linux - Hardware 5 11-04-2010 12:57 PM
OpenOffice installation: "cannot find shared libraries: libnss3.so" Compile this Slackware 4 09-14-2009 07:58 PM
DPKG & "files list file for package `pkg-config' contains empty filename" error :( Angelus Debian 2 04-02-2005 08:34 AM


All times are GMT -5. The time now is 07:41 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration