LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 08-26-2005, 08:25 AM   #1
[GOD]Anck
Member
 
Registered: Dec 2003
Location: The Netherlands
Distribution: Slackware
Posts: 171

Rep: Reputation: 33
Slackware sendmail authentication


I've done a reinstall of my Slackware 10.1 server, upgraded it to -current, and now I'm trying to figure out how to get e-mail working properly again. I used to have sendmail and the regular imapd working just fine, authenticating with my unix account and using stunnel to encrypt everything.. but for some reason I can't seem to get it working this time around.

The problem is with SMTP authentication. I can send through sendmail just fine unauthenticated, but I want it to take my username / password and it won't. I used to be able to just fill out "use smtp authentication" in whatever e-mail client and it worked without having to change anything in the sendmail configuration.. has anything changed in Slackware's e-mail functionality that would prevent this working now?

Another thing is, how do I set sendmail's base hostname again? The hostname for which it accepts e-mail as local? I remember having to change just one parameter in the sendmail.cf file but I can't remember for the life of me which one.

Thanks in advance.

[EDIT]

/var/log/mail says nothing but /var/log/messages says this:

Code:
Aug 26 15:46:26 P1000 sm-mta[5387]: Could not open /etc/sasldb2: gdbm_errno=3
Aug 26 15:46:26 P1000 sm-mta[5387]: Could not open /etc/sasldb2: gdbm_errno=3
Aug 26 15:46:26 P1000 sm-mta[5387]: no secret in database
That leads me to believe sendmail is trying to use sasl for authentication? That would obviously fail since sasl wouldn't be using /etc/passwd and /etc/shadow but rather it's own database.. I'd much like to just use regular unix accounts and skip sasl instead. How?

[/EDIT]

Last edited by [GOD]Anck; 08-26-2005 at 08:50 AM.
 
Old 08-26-2005, 11:20 AM   #2
kodon
Member
 
Registered: Jul 2004
Location: [jax][fl][usa]
Distribution: Slackware64-current
Posts: 796

Rep: Reputation: 31
http://www.linuxquestions.org/questi...icle&artid=269
 
Old 08-26-2005, 01:06 PM   #3
[GOD]Anck
Member
 
Registered: Dec 2003
Location: The Netherlands
Distribution: Slackware
Posts: 171

Original Poster
Rep: Reputation: 33
Thank you for your reply, however it doesn't quite answer my question. The sendmail howto you linked to describes how to make sendmail work with sasl (even with saslauthd using /etc/shadow for passwords), but I just want it to work like it used to, bypassing saslauthd completely. (In fact, it wasn't even there in the original Slackware 10.1 release)

So my question is, after upgrading to -current, how do I turn off sasl support for sendmail? Could I maybe just use the old config file or would that break things?

[EDIT]

Well I tried the following:

Code:
cd /usr/share/sendmail/cf/cf
cp sendmail-slackware.mc config.mc
sh Build config.mc
cp config.cf /etc/mail/sendmail.cf
/etc/rc.d/rc.sendmail restart
That replaces the current sendmail config file with the vanilla slackware one, which should make it work without having to use sasl. However when trying to send I still get the same entries in my /var/log/messages... in other words, the sendmail config file isn't to blame it seems. I'm at a loss as to why the mta is even trying to use sasl at all. Any ideas would be welcome.

[/EDIT]

[EDIT2]

Just as a sanity check, I rolled back to the version of sendmail that shipped with Slackware 10.1. I merely did removepkg / installpkg, didn't change anything else... and that stopped it complaining about sasl. Now the log shows it successfully authenticates me and sends my e-mail. However, it will also send without authenticating, which is bad obviously. So, how do I go and tell sendmail to not send unless I authenticate, but without using anything like sasl as most SMTP authentication documents suggest?

Last edited by [GOD]Anck; 08-26-2005 at 02:59 PM.
 
Old 03-09-2006, 09:47 AM   #4
cotton213
LQ Newbie
 
Registered: Dec 2004
Location: Michigan
Distribution: Slackware, Red Hat, Ubuntu
Posts: 23

Rep: Reputation: 1
My SASL solution

I have exactly the same problem. I don't need SASL in my particular installation, and I don't (for my own reasons) want to recompile sendmail without SASL support. I found this site:

www dot jonfullmer dot com/smtpauth

which gave me simple instructions for a simple setup that does authentication using the /etc/shadow file. I just have to add three lines to my .mc file and I'm done. No configuring SASL; no more "Could not open /etc/sasldb2: gdbm_errno=3" errors. This was a good workaround for me.

Hope this helps the next person.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Sendmail Authentication sachin0178 Linux - Newbie 0 10-15-2005 03:48 PM
Sendmail authentication dweeb Linux - Newbie 6 07-14-2005 05:24 AM
Sendmail Authentication KnightKrawlur Mandriva 0 08-13-2004 11:49 PM
Does the Slackware Sendmail support SASL authentication? gargamel Slackware 7 07-30-2004 06:06 AM
Authentication slow with Sendmail jgaraas Linux - Software 0 05-01-2003 11:09 AM


All times are GMT -5. The time now is 03:44 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration