LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 08-16-2012, 06:56 PM   #1
kingbeowulf
Member
 
Registered: Oct 2003
Location: WA
Distribution: Slackware64 14.1, Slackware 14.1
Posts: 526

Rep: Reputation: 140Reputation: 140
Question slackware current and slackpkg selects kdei packages series in error


This has been an issue with current beta, RC1 and now RC2 on both x86 archs. when using slackpkg to update, even though series kdei was NOT elected during the initial installation, executing

slackpkg install-new
slackpkg upgrade-all

all the calligra-l10n-* languages are selected. Nothing else from series kdei and nothing from emacs, which I also did not install.

I can blacklist this; however, isn't this supposed to be automagical? Why just calligra and not any other packages/series I skipped? This also occurs in the qemu VMs when I do a full install omitting just /kdei

Wrong tagfiles?

Thanks.
 
Old 08-16-2012, 07:11 PM   #2
mlangdn
Senior Member
 
Registered: Mar 2005
Location: Kentucky
Distribution: Slackware64-current
Posts: 1,380

Rep: Reputation: 180Reputation: 180
In x86_64, I was getting the calligra-|10n also, but not the kdei. This time, I got neither.
 
Old 08-16-2012, 09:12 PM   #3
kingbeowulf
Member
 
Registered: Oct 2003
Location: WA
Distribution: Slackware64 14.1, Slackware 14.1
Posts: 526

Original Poster
Rep: Reputation: 140Reputation: 140
Nope, did it again: this time slackware64-14-RC2 updated from beta pre-RC1. No matter what (short of blacklisting), slackpkg thinks the kdei/calligra-l10n-* files need to be added when given "slackpkg install-new" - Note that there are a bunch of otehr files kdei/ that slackpkg properly ignores.
 
Old 08-16-2012, 09:19 PM   #4
hitest
Senior Member
 
Registered: Mar 2004
Location: Prince Rupert, B.C., Canada
Distribution: Slackware, OpenBSD
Posts: 4,242

Rep: Reputation: 573Reputation: 573Reputation: 573Reputation: 573Reputation: 573Reputation: 573
Quote:
Originally Posted by kingbeowulf View Post
Nope, did it again: this time slackware64-14-RC2 updated from beta pre-RC1. No matter what (short of blacklisting), slackpkg thinks the kdei/calligra-l10n-* files need to be added when given "slackpkg install-new"
Yes. I see the same behaviour when I issue slackpkg install-new.
 
Old 08-16-2012, 09:35 PM   #5
kingbeowulf
Member
 
Registered: Oct 2003
Location: WA
Distribution: Slackware64 14.1, Slackware 14.1
Posts: 526

Original Poster
Rep: Reputation: 140Reputation: 140
Thanks. I was hoping the heat wasn't making me loopy!
 
Old 08-17-2012, 04:34 AM   #6
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,333

Rep: Reputation: Disabled
You may not realize how slackpkg determines if a package is new to Slackware.

The "slackpkg install-new" command acts on the word "Added" in the Slackware ChangeLog.txt. So, if you upgrade to a certain Slackware release, slackpkg will scan that release's ChangeLog.txt and add all packages to the pick-list for which it finds "Added."
That is why you get things like gptfdisk, but also all the calligra-l10n packages when you run "slackpkg install-new" for slackware-current.

Eric
 
1 members found this post helpful.
Old 08-17-2012, 05:14 AM   #7
wildwizard
Member
 
Registered: Apr 2009
Location: Oz
Distribution: slackware64-14.0
Posts: 755

Rep: Reputation: 227Reputation: 227Reputation: 227
I came up with these lines in /etc/slackpkg/blacklist

Code:
calligra-l10n-[^e][^n]_[^G][^B]
calligra-l10n-[a-z]*
This gives me the en_GB but none of the others.

If you want to block all of them then just use

Code:
calligra-l10n
 
Old 08-17-2012, 07:59 AM   #8
chrisretusn
Member
 
Registered: Dec 2005
Location: Philippines
Distribution: Slackware
Posts: 489

Rep: Reputation: Disabled
You can also block all of kdei with

kdei
 
Old 08-17-2012, 08:18 AM   #9
guanx
Senior Member
 
Registered: Dec 2008
Posts: 1,014

Rep: Reputation: 146Reputation: 146
Quote:
Originally Posted by chrisretusn View Post
You can also block all of kdei with

kdei
But this is not the solution. Years ago I've complained about the same thing here (on LQ) and it was announced to be fixed a while later.

Note that "announced". Actually nothing happened to the maketag files under kdei.
It should be quite easy to change the "on"s to "off"s.
 
Old 08-17-2012, 09:36 AM   #10
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,333

Rep: Reputation: Disabled
Quote:
Originally Posted by guanx View Post
But this is not the solution. Years ago I've complained about the same thing here (on LQ) and it was announced to be fixed a while later.

Note that "announced". Actually nothing happened to the maketag files under kdei.
It should be quite easy to change the "on"s to "off"s.
Slackpkg does not look at tagfiles at all. And inide the Slackware installer, you can simply de-select the KDEI series.

Eric
 
1 members found this post helpful.
Old 08-17-2012, 08:08 PM   #11
guanx
Senior Member
 
Registered: Dec 2008
Posts: 1,014

Rep: Reputation: 146Reputation: 146
Quote:
Originally Posted by Alien Bob View Post
Slackpkg does not look at tagfiles at all. And inide the Slackware installer, you can simply de-select the KDEI series.

Eric
Hi Eric, Thanks for the reply.

Do you have an idea why these few kdei packages should default to "on" while all others default to "off"? I Always remove them during menuconfig and got no system break down in any way.

This is a cross-major-release bug.

Last edited by guanx; 08-17-2012 at 08:13 PM.
 
Old 08-17-2012, 11:38 PM   #12
chrisretusn
Member
 
Registered: Dec 2005
Location: Philippines
Distribution: Slackware
Posts: 489

Rep: Reputation: Disabled
Quote:
Originally Posted by guanx View Post
But this is not the solution.
Why isn't it? Adding kdei to blacklist prevents all of the kdei series packages from being acted on. This takes care of the caligra-l10n packages.

you could also use:
Code:
./slackware/kdei
./slackware64/kdei
-or-
./slackware[0-9]+/kdei
It's already been explained (here) why the Caligra language packages (calligra-l10n) are included when running "slackpkg install-new"

An except from the Sat Apr 14 22:06:26 UTC 2012 entry in ChangeLog.txt in -current.
Code:
kdei/calligra-l10n-ca-2.4.0-noarch-1.txz:  Added.
kdei/calligra-l10n-ca@valencia-2.4.0-noarch-1.txz:  Added.
kdei/calligra-l10n-cs-2.4.0-noarch-1.txz:  Added.
kdei/calligra-l10n-da-2.4.0-noarch-1.txz:  Added.
kdei/calligra-l10n-de-2.4.0-noarch-1.txz:  Added.
kdei/calligra-l10n-el-2.4.0-noarch-1.txz:  Added.
kdei/calligra-l10n-en_GB-2.4.0-noarch-1.txz:  Added.
kdei/calligra-l10n-es-2.4.0-noarch-1.txz:  Added.
kdei/calligra-l10n-et-2.4.0-noarch-1.txz:  Added.
kdei/calligra-l10n-fi-2.4.0-noarch-1.txz:  Added.
kdei/calligra-l10n-fr-2.4.0-noarch-1.txz:  Added.
kdei/calligra-l10n-hu-2.4.0-noarch-1.txz:  Added.
kdei/calligra-l10n-it-2.4.0-noarch-1.txz:  Added.
kdei/calligra-l10n-kk-2.4.0-noarch-1.txz:  Added.
kdei/calligra-l10n-nb-2.4.0-noarch-1.txz:  Added.
kdei/calligra-l10n-nds-2.4.0-noarch-1.txz:  Added.
kdei/calligra-l10n-nl-2.4.0-noarch-1.txz:  Added.
kdei/calligra-l10n-pl-2.4.0-noarch-1.txz:  Added.
kdei/calligra-l10n-pt-2.4.0-noarch-1.txz:  Added.
kdei/calligra-l10n-pt_BR-2.4.0-noarch-1.txz:  Added.
kdei/calligra-l10n-ru-2.4.0-noarch-1.txz:  Added.
kdei/calligra-l10n-sk-2.4.0-noarch-1.txz:  Added.
kdei/calligra-l10n-sv-2.4.0-noarch-1.txz:  Added.
kdei/calligra-l10n-uk-2.4.0-noarch-1.txz:  Added.
kdei/calligra-l10n-zh_CN-2.4.0-noarch-1.txz:  Added.
kdei/calligra-l10n-zh_TW-2.4.0-noarch-1.txz:  Added.
I see slackpkg as a more or less default "on" with Slackware (official) packages when it comes to updating. If I want to turn something off, that is what blacklist is for. When I saw that calligra was added, I turned to blacklist. Originally I used "calligra-l10n", then decided since I don't use kdei at all, I when with "./slackwar64[0-9]+/kdei"

If I needed a particular language file I would have done this differently in my blacklist
Code:
calligra-l10n-zh_TW
calligra-l10n-zh_CN
calligra-l10n-uk
calligra-l10n-sv
calligra-l10n-sk
#calligra-l10n-ru
calligra-l10n-pt_BR
calligra-l10n-pt
calligra-l10n-pl
calligra-l10n-nl
calligra-l10n-nds
calligra-l10n-nb
calligra-l10n-kk
calligra-l10n-it
calligra-l10n-hu
calligra-l10n-fr
calligra-l10n-fi
calligra-l10n-et
calligra-l10n-es
calligra-l10n-en_GB
calligra-l10n-el
calligra-l10n-de
calligra-l10n-da
calligra-l10n-cs
calligra-l10n-ca@valencia
calligra-l10n-ca
When Slackware 14.0 is released, I would no longer need those entries.

Using slakcpkg search is a good way to test blacklist entries. Also looking at /var/lib/slackpkg/pkglist can give you ideas on what you can use in search and in blacklist.

Last edited by chrisretusn; 08-17-2012 at 11:45 PM. Reason: Add last sentence
 
Old 08-18-2012, 02:28 AM   #13
kingbeowulf
Member
 
Registered: Oct 2003
Location: WA
Distribution: Slackware64 14.1, Slackware 14.1
Posts: 526

Original Poster
Rep: Reputation: 140Reputation: 140
Quote:
Originally Posted by Alien Bob View Post
You may not realize how slackpkg determines if a package is new to Slackware.

The "slackpkg install-new" command acts on the word "Added" in the Slackware ChangeLog.txt. So, if you upgrade to a certain Slackware release, slackpkg will scan that release's ChangeLog.txt and add all packages to the pick-list for which it finds "Added."
That is why you get things like gptfdisk, but also all the calligra-l10n packages when you run "slackpkg install-new" for slackware-current.

Eric
Hmmm...that makes sense from one point, but not in another, as just searching for "added" is a bit of a short cut. Why, once 'install-new' is run and new packages added, why do just 'calligra-l10n' packages come back again after each update? Heck, the where added April 14, 2012. I kipped other packages and series while I'm playing around in a VM. Should not slackpkg skip a package series if it was not installed originally? Should not slackpkg skip scanning for the added packages if the user unchecks the box?

Well, my opinion. Guess I could patch it if it bothers my enough....
 
Old 08-18-2012, 03:48 AM   #14
wildwizard
Member
 
Registered: Apr 2009
Location: Oz
Distribution: slackware64-14.0
Posts: 755

Rep: Reputation: 227Reputation: 227Reputation: 227
kingbeowolf

I had thought about what you just posted and for most people it would work but not all.

If for instance you want to upgrade only part of the system first and then the rest later on the second run you might end up missing something.

What it probably needs is a bit more intelligence in it to detect which packages out of the entire system are missing and provide them via another option like "slackpkg install-missing"
 
Old 08-18-2012, 05:55 AM   #15
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Hanover, Germany
Distribution: Main: Gentoo Others: What fits the task
Posts: 15,616
Blog Entries: 2

Rep: Reputation: 4072Reputation: 4072Reputation: 4072Reputation: 4072Reputation: 4072Reputation: 4072Reputation: 4072Reputation: 4072Reputation: 4072Reputation: 4072Reputation: 4072
Quote:
Originally Posted by wildwizard View Post
What it probably needs is a bit more intelligence in it to detect which packages out of the entire system are missing and provide them via another option like "slackpkg install-missing"
Isn't that the same as
Code:
slackpkg install slackware
?
 
1 members found this post helpful.
  


Reply

Tags
slackpkg, tagfiles, upgrade


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] [Slackware 13.1 and upcoming 13.2] tagfiles wrong for kdei package series? titopoquito Slackware 4 01-13-2011 12:59 PM
slackpkg/blacklist for AlienBob's current multilib and kde 4.4.2 packages damgar Slackware 7 04-08-2010 10:33 PM
Slackware current slackpkg problem LordAnta Slackware 6 10-10-2009 07:15 AM
Slackpkg slackware current-64 bit todders Slackware 7 07-15-2009 07:00 PM
slackpkg update = slackware-current? trashbird1240 Slackware 2 04-24-2007 09:50 AM


All times are GMT -5. The time now is 06:43 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration