LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 09-11-2009, 10:41 AM   #1
Do7AN
LQ Newbie
 
Registered: Nov 2006
Location: philadelphia, PA
Distribution: Slackware current
Posts: 27

Rep: Reputation: 15
Slackware 13 - Wicd WPA PEAP TKIP MSCHAPV2 - Not Authenticating


For the last couple of months I have been using rc.inet1, rc.inet1.conf and wpa_supplicant to connect to wireless at work. I would like to which to wicd because I am using a laptop that I take to meetings. Wireless uses WPA PEAP TKIP MSCHAPV2 and authenticates against Radius using only username and password. The ssid is not broadcast. The following are my configs. I have been trying to get wicd working but have not been able to authenticate. I have set rc.inet1.conf to default settings and wpa_supplicant to default settings.

Is there something I'm missing?

iwlist scanning
Code:
ESSID:""                                             
                    Mode:Master                                                
                    Channel:48                                                 
                    Frequency:5.24 GHz (Channel 48)                            
                    Quality=62/100  Signal level:-70 dBm  Noise level=-127 dBm 
                    Encryption key:on                                          
                    IE: Unknown: 000100                                        
                    IE: Unknown: 01088C129824B048606C                          
                    IE: Unknown: 050400010000                                  
                    IE: Unknown: 0712555320240414340414640514840314950414      
                    IE: IEEE 802.11i/WPA2 Version 1                            
                        Group Cipher : TKIP                                    
                        Pairwise Ciphers (1) : CCMP                            
                        Authentication Suites (1) : 802.1x                     
                    IE: Unknown: 9606004096000B00                              
                    IE: WPA Version 1                                          
                        Group Cipher : TKIP                                    
                        Pairwise Ciphers (1) : TKIP                            
                        Authentication Suites (1) : 802.1x                     
                    IE: Unknown: DD06004096010104                              
                    IE: Unknown: DD050040960305                                
                    IE: Unknown: DD050040960B09                                
                    IE: Unknown: DD080040961301003401                          
                    IE: Unknown: DD050040961405                                
                    Bit Rates:6 Mb/s; 9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s        
                              36 Mb/s; 48 Mb/s; 54 Mb/s                        
                    Extra:tsf=000000f8cfe2e044                                 
                    Extra: Last beacon: 1049ms ago
wicd template
Code:
require identity *Identity password *Password
------
ctrl_interface=/var/run/wpa_supplicant
network={
        ssid="$_ESSID"
        scan_ssid=$_SCAN
        proto=WPA
        key_mgmt=WPA-EAP
        pairwise=TKIP
        group=TKIP
        eap=PEAP
        phase1="peaplabel=0"
        phase2="auth=MSCHAPV2"
        identity="$_IDENTITY"
        password="$_PASSWORD"
}
wpa_supplicant (I was using this and it worked)
Code:
#ctrl_interface=/var/run/wpa_supplicant
#ctrl_interface_group=wheel            
#eapol_version=1                       
#ap_scan=1                             
#fast_reauth=1                         
#network={                             
#        ssid="hidden"               
#       scan_ssid=1                    
#       key_mgmt=WPA-EAP               
#        eap=PEAP                      
#        pairwise=TKIP                 
#       phase1="peaplabel=0"           
#        phase2="auth=MSCHAPV2"        
#        identity="my username"             
#        password="my password"       
#}
wicd.log
Code:
2009/09/11 10:18:44 :: Connecting to wireless network <hidden>
2009/09/11 10:18:44 :: Putting interface down
2009/09/11 10:18:44 :: Releasing DHCP leases...
2009/09/11 10:18:44 :: Setting false IP...
2009/09/11 10:18:45 :: Stopping wpa_supplicant
2009/09/11 10:18:45 :: Flushing the routing table...
2009/09/11 10:18:45 :: Putting interface up...
2009/09/11 10:18:45 :: Attempting to authenticate...
2009/09/11 10:19:20 :: wpa_supplicant authentication may have failed.
2009/09/11 10:19:20 :: Running DHCP
2009/09/11 10:19:40 :: err, wlan0: timed out
2009/09/11 10:19:40 ::
2009/09/11 10:19:40 :: DHCP connection failed
2009/09/11 10:19:40 :: exiting connection thread
 
Old 09-11-2009, 10:52 AM   #2
onebuck
Moderator
 
Registered: Jan 2005
Location: Midwest USA, Central Illinois
Distribution: SlackwareŽ
Posts: 11,446
Blog Entries: 4

Rep: Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505
Hi,

What about using 'wicd-curses' from the console to configure?
 
Old 09-11-2009, 11:07 AM   #3
Do7AN
LQ Newbie
 
Registered: Nov 2006
Location: philadelphia, PA
Distribution: Slackware current
Posts: 27

Original Poster
Rep: Reputation: 15
does wicd-curses give me any different configuration options than configuring it in using the gui?
 
Old 09-11-2009, 05:44 PM   #4
onebuck
Moderator
 
Registered: Jan 2005
Location: Midwest USA, Central Illinois
Distribution: SlackwareŽ
Posts: 11,446
Blog Entries: 4

Rep: Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505
Hi,

In the past I have found the KDE system configuration interfaces not reliable to initialize network or system configurations. I've found success with using console tools whenever configuring system devices. Try the 'wicd-curses' and see if it works to initially setup the network devices.

It's your system to do as you desire or need.
 
Old 09-23-2009, 02:05 AM   #5
black hole sun
Member
 
Registered: Jul 2004
Distribution: Slackware Current
Posts: 127

Rep: Reputation: 15
Except that wicd is not a kde program.


To the OP, I've been having the same problem. Did you ever solve this?
 
Old 09-23-2009, 03:20 AM   #6
H_TeXMeX_H
Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269
What wifi card do you have ? and what drivers are you using ? Maybe wpa_supplicant was not compiled with support for the driver.
 
Old 09-23-2009, 06:20 AM   #7
easuter
Member
 
Registered: Dec 2005
Location: Portugal
Distribution: Slackware64 13.0, Slackware64 13.1
Posts: 538

Rep: Reputation: 62
If the network has a hidden ESSID, then it is possible that Wicd is trying to associate with the AP using an ESSID called "<hidden>", which of course won't work.
I use a similar setup for accessing the Eduroam wireless network at college, and I have to add this command to be executed before connecting (under the Wicd "Scripts" section, in the pre-connection text area)

Code:
/sbin/iwconfig wlan0 essid eduroam
This way the correct ESSID is set and I can connect (most of the time anyway, sometimes is takes a few tries :P)

Last edited by easuter; 09-23-2009 at 06:22 AM.
 
Old 09-23-2009, 07:41 AM   #8
onebuck
Moderator
 
Registered: Jan 2005
Location: Midwest USA, Central Illinois
Distribution: SlackwareŽ
Posts: 11,446
Blog Entries: 4

Rep: Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505
Hi,

Quote:
Originally Posted by black hole sun View Post
Except that wicd is not a kde program.


To the OP, I've been having the same problem. Did you ever solve this?
'wicd' has a user interface that can be used for GNOME, KDE, Xfce, Fluxbox. Sure whenever using 'wicd' to make system changes the user must provide a username along with password when attempting configuration from the desktop.

The 'API' for system configuration via a 'GUI' adds another layer whenever the user needs to make changes. This layer is not always reliable. You will find the 'curses' based configuration tool closer to the 'cli' because of the control through scripting is solid. May not be as pretty or convenient as a desktop 'GUI' but you will have a reliable configuration thus less chance of error.
 
Old 09-23-2009, 08:29 AM   #9
cmiranda
LQ Newbie
 
Registered: Sep 2003
Location: Miami, FL
Distribution: Slackware Linux
Posts: 19

Rep: Reputation: 0
I just recently installed Slackware64 13 on my work laptop (Dell Latitude D630) which uses Intel PRO/Wireless 3945ABG and I am also experiencing this problem. I have a feeling that this is a problem with wicd because I used wpa_gui to connect to my wireless network which not only was hidden but also encrypted using WPA2-PSK.

I did notice that wicd did work when connecting to an unsecured network, but when connecting to a secure wireless network (regardless of whether the SSID is hidden or not) it can't seem to connect. It acts as though it associates fine, but then fails to grab an IP. And before anyone brings it up, I doubt it's dhcpcd/dhclient since it will grab an IP just fine with unsecured wifi networks. Wpa_gui gave me no problems whatsoever, which leads me to believe this version of wicd is the cause of the problem.
 
Old 09-23-2009, 08:52 AM   #10
rvdboom
Member
 
Registered: Jul 2007
Distribution: Slackware
Posts: 186

Rep: Reputation: 23
In the wicd graphic interface, when clicking on the Network button, you can have a Find a hidden network option.
When clicking it, you are asked the ESSID of the hidden network.
Have you tried using this?
 
Old 09-23-2009, 09:08 AM   #11
cmiranda
LQ Newbie
 
Registered: Sep 2003
Location: Miami, FL
Distribution: Slackware Linux
Posts: 19

Rep: Reputation: 0
Quote:
Originally Posted by rvdboom View Post
In the wicd graphic interface, when clicking on the Network button, you can have a Find a hidden network option.
When clicking it, you are asked the ESSID of the hidden network.
Have you tried using this?
Yes, I have. Still does not work. I have even shutdown the wicd daemon, edited the wireless-settings.conf file and manually inserted the SSID name, and restarted the wicd daemon to no avail.
 
Old 09-23-2009, 09:21 AM   #12
cmiranda
LQ Newbie
 
Registered: Sep 2003
Location: Miami, FL
Distribution: Slackware Linux
Posts: 19

Rep: Reputation: 0
Just to add to my situation, I disabled execution of the rc.wireless script in the event that it was conflicting with rc.wicd and rebooted my laptop. It still cannot connect through wicd-curses or through the GUI interface.
 
Old 09-23-2009, 10:04 AM   #13
quanta
Member
 
Registered: Aug 2007
Location: Vietnam
Distribution: RedHat based, Debian based, Slackware, Gentoo
Posts: 724

Rep: Reputation: 100Reputation: 100
Quote:
Originally Posted by cmiranda View Post
Just to add to my situation, I disabled execution of the rc.wireless script in the event that it was conflicting with rc.wicd and rebooted my laptop. It still cannot connect through wicd-curses or through the GUI interface.
Did you try connect from command line? iwconfig, iwpriv, dhclient (or dhcpcd)...
 
Old 09-23-2009, 10:13 AM   #14
cmiranda
LQ Newbie
 
Registered: Sep 2003
Location: Miami, FL
Distribution: Slackware Linux
Posts: 19

Rep: Reputation: 0
Quote:
Originally Posted by quanta View Post
Did you try connect from command line? iwconfig, iwpriv, dhclient (or dhcpcd)...
As mentioned, Wpa_gui worked for me. I can only assume that if wpa_gui (which is the GUI for wpa_supplicant) worked that the commands you mentioned would have worked as well since they work in tandem to get the connection going. The only time I had an issue connecting to secured wireless network (hidden or not) was with wicd.
 
Old 09-23-2009, 10:27 AM   #15
2Gnu
Senior Member
 
Registered: Jan 2002
Location: Southern California
Distribution: Slackware 14.0
Posts: 1,874

Rep: Reputation: 49
In this thread, an updated version of wicd fixed the problem:
http://www.linuxquestions.org/questi...sid...-752873/
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
WlanConnection - WPA2-EAP(PEAP;MSCHAPv2) How to configure? huberbauer Linux - Wireless Networking 5 10-02-2014 07:40 AM
LXer: Configuring WPA-PSK (TKIP) in Slackware LXer Syndicated Linux News 0 08-10-2008 10:00 PM
Setting up WPA-Supplicant and PEAP,MSCHAPV2 metallica1973 Linux - Wireless Networking 14 07-09-2008 06:36 PM
How to use xsupplicant, wpa_supplicant for wpa/tkip/peap-mschapv2 weeds84 Linux - Wireless Networking 2 03-13-2005 06:17 AM
802.1x, Radius, MSChapv2, PEAP Micah Linux - Wireless Networking 10 11-05-2004 02:10 PM


All times are GMT -5. The time now is 11:07 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration