LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 05-04-2008, 01:27 AM   #1
gegechris99
Member
 
Registered: Oct 2005
Location: France
Distribution: Slackware 14.1 64bit
Posts: 728
Blog Entries: 3

Rep: Reputation: 77
Slackware 12.1 - Korean input with SCIM does not work within QT applications


Hello,

I've upgraded to Slackware 12.1 and I'm using SCIM to enter Korean characters. I followed instructions in the CHANGES_AND_HINTS.TXT file to set up SCIM:

1) in ~/.profile, I added:
Code:
export LANG=fr_FR.UTF-8
2) then:
Code:
chmod +x /etc/profile.d/scim.sh
3) and in ~/.xprofile, I added:
Code:
/usr/bin/scim -d
It works well on my browser (Firefox) but I can not manage to use SCIM in QT applications (Kword, Kedit...).

On SCIM website (http://www.scim-im.org/projects/scim_qtimm), It is mentioned:

Quote:
Due to version policy, Trolltech won't incorporate immodule support in Qt 3.3.x. However, this would be a standard built-in feature for Qt 4. In fact, Qt 4-beta2 already includes it.
As for Qt 3.3, you can apply the immodule patch. Some distros (gentoo, SuSE) already do that for you.
I'd like to know if someone has managed to enter Asian characters in QT applications with Slackware 12.1. I find it strange that the CHANGES_AND_HINTS.TXT file does not say anything about some limitations for SCIM (or I didn't look at the right place).

FYI, I installed only the following SCIM packages:

libhangul
scim
scim-hangul
scim-bridge

Thank you for your feedback.

Last edited by gegechris99; 05-06-2008 at 01:49 AM. Reason: Title modified to more accurately describe the issue
 
Old 05-04-2008, 11:31 AM   #2
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: Tupelo, MS
Distribution: Gentoo
Posts: 6,926

Rep: Reputation: 124Reputation: 124
I can enter Simplified Chinese into KWord, Stardict, Firefox, Konsole, KEdit.

I had to go to SCIM setup (right-click the tray icon) and add another language,
so that there was more than just Chinese Simplified in the Global Setup.
 
Old 05-04-2008, 01:21 PM   #3
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,292

Rep: Reputation: Disabled
Quote:
Originally Posted by gegechris99 View Post
3) and in ~/.xprofile, I added:
Code:
/usr/bin/scim -d
Are you starting in runlevel 4 (graphical login)?

Eric
 
Old 05-04-2008, 01:35 PM   #4
gegechris99
Member
 
Registered: Oct 2005
Location: France
Distribution: Slackware 14.1 64bit
Posts: 728
Blog Entries: 3

Original Poster
Rep: Reputation: 77
Alien Bob,

Yes I'm running level 4
 
Old 05-04-2008, 02:16 PM   #5
gegechris99
Member
 
Registered: Oct 2005
Location: France
Distribution: Slackware 14.1 64bit
Posts: 728
Blog Entries: 3

Original Poster
Rep: Reputation: 77
I googled a bit and it seems that to be able to have SCIM working for QT applications, we need a QT plugin. Other distributions (Ubuntu, Mandriva, Fedora) offer a "scim-qtimm" package to make SCIM work with QT applications.

Is such a package necessary for Slackware? I haven't found one for now.
 
Old 05-05-2008, 04:03 PM   #6
gegechris99
Member
 
Registered: Oct 2005
Location: France
Distribution: Slackware 14.1 64bit
Posts: 728
Blog Entries: 3

Original Poster
Rep: Reputation: 77
OK, I guess I found the issue.

There's a recent interview of South Korean KDE developpers:

http://dot.kde.org/1209422140/

Look at krisna's interview about issue with Korean input method with KDE.

Things will look brighter in KDE4. I'll just have to wait.
 
Old 05-05-2008, 06:59 PM   #7
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: Tupelo, MS
Distribution: Gentoo
Posts: 6,926

Rep: Reputation: 124Reputation: 124
Quote:
Originally Posted by gegechris99 View Post
I googled a bit and it seems that to be able to have SCIM working for QT applications, we need a QT plugin. Other distributions (Ubuntu, Mandriva, Fedora) offer a "scim-qtimm" package to make SCIM work with QT applications.

Is such a package necessary for Slackware? I haven't found one for now.
I just want to clarify this for others who find and read this thread. It is not necessary
to have a QT plugin for SCIM to work with QT applications.

We put a lot of work into SCIM between Slackware-12.0 and 12.1.

Prior to Slackware-12.0, to use SCIM we had to rebuild many packages ... such as
fontconfig, freetype, libXft, and x11. Not to mention the fact that we also had to
build scim, scim-fcitx, scim-pinyin, and scim-tables to display and input Chinese.
We also had to use Microsoft fonts to have a decent Hanzi display. But ...

Along came Eric Hameleers (Alien Bob), who worked with us and started the SAS
Project ... Slackware Asian Support. My thanks to Eric for hours of tireless work
to get us to where we are today.

Just had to say this, and let those who search know that the problem in this thread
just might be Korean input only, for Chinese and Japanese input and display do not
require a plugin to work with QT apps.
 
Old 05-06-2008, 01:53 AM   #8
gegechris99
Member
 
Registered: Oct 2005
Location: France
Distribution: Slackware 14.1 64bit
Posts: 728
Blog Entries: 3

Original Poster
Rep: Reputation: 77
OK and agreed with Bruce Hill, issue is only for Korean.

I modified the title in my first post to reflect that point but the thread title is not modified. I don't know how to do it.

Thank you anyway for the good work on SCIM.
 
Old 07-21-2008, 06:54 AM   #9
Sun_Bin
LQ Newbie
 
Registered: Jul 2008
Distribution: fedora/slackware
Posts: 6

Rep: Reputation: 0
Hi:
“for Chinese and Japanese input and display do not
require a plugin to work with QT apps.”

But I still cannot use scim in kword, but able to use in firefox or KWrite, which file should I configure?
Have search for long, no aswer. Wish help!!
 
Old 07-21-2008, 11:06 AM   #10
gegechris99
Member
 
Registered: Oct 2005
Location: France
Distribution: Slackware 14.1 64bit
Posts: 728
Blog Entries: 3

Original Poster
Rep: Reputation: 77
Hello Sun_Bi,

To solve my issue with Korean input not working in QT applications, I installed SKIM (SCIM for KDE).

I've submitted a slackbuild at www.slackbuilds.org:

http://slackbuilds.org/repository/12.1/system/skim/

Hope it will work for you.
 
Old 07-22-2008, 07:11 AM   #11
Sun_Bin
LQ Newbie
 
Registered: Jul 2008
Distribution: fedora/slackware
Posts: 6

Rep: Reputation: 0
Thanks a lot,gegechris99, skim works well!!
By the way, my pinyin name is Sun_Bin
 
Old 08-25-2009, 12:54 AM   #12
hoanglong1712
Member
 
Registered: Nov 2008
Location: so 34, hem 75, ngach 12 ngo 624, Minh Khai, Ha Noi , Viet Nam
Distribution: Slackware, slax, opensuse
Posts: 33

Rep: Reputation: 15
Dear everyone
I had a problem
I had solved that I can type non-US-english in firefox, open office
but I can not make the skim panel show another input style like chinese or japanese except english/keyboard while I use kword or kate

I had install
scim1.4.7
skim1.4.5
m17n-lib
m17n-db
scim-m17n-0.2.2scim-bridge-agent_0.4.16-2_i386
scim-bridge-client-gtk_0.4.16-2_i386
scim-bridge-client-qt4_0.4.16-2_i386
scim-bridge-client-qt_0.4.16-2_i386

and this this my .bashprofile content

export XMODIFIERS="@im=SCIM"
export GTK_IM_MODULE="scim-bridge"
export QT_IM_MODULE="scim"
/usr/lib/scim-1.0/scim-panel-gtk -d
/usr/bin/scim -f x11 -s socket -c socket -d
/usr/bin/scim -f socket -c simple -ns socket -d


did I do something wrong
 
Old 08-25-2009, 03:35 AM   #13
gegechris99
Member
 
Registered: Oct 2005
Location: France
Distribution: Slackware 14.1 64bit
Posts: 728
Blog Entries: 3

Original Poster
Rep: Reputation: 77
Hello Hoanglong1712,

Which version of Slackware are you using?

Since Slackware 12.1, scim is included in slackware and the installation method is described in file CHANGES_AND_HINTS.TXT:

Quote:
Input methods for complex characters (CJK, which is shorthand for Chinese,
Japanese, Korean) and other non-latin character sets have been added. These
input methods use the SCIM (Smart Common Input Method) platform.
The environment variables for SCIM support are set in /etc/profile.d/scim.sh
The requirements for getting SCIM input methods to work in your X session
are as follows:
(1) Use a UTF-8 locale. Look in /etc/profile.d/lang.sh for setting your
language to (for instance) en_US.UTF-8. As a word of warning: maybe you
should leave root with a non-UTF-8 locale because you don't want root's
commands to be misinterpreted. You can add the following line to your
~/.profile file to enable UTF-8 just for yourself:
export LANG=en_US.UTF-8
(2) Make the scim profile scripts executable. These will setup your
environment correctly for the use of scim with X applications. Run:
chmod +x /etc/profile.d/scim.*
(3) Start the scim daemon as soon as your X session starts. The scim daemon
must be active before any of your X applications. In KDE, you can add a
shell script to the ~/.kde/Autostart folder that runs the command
"scim -d". In XFCE you can add "scim -d" to the Autostarted Applications.
If you boot your computer in runlevel 4 (the graphical XDM/KDM login)
you can simply add the line "scim -d" to your ~/.xprofile file.
This gives you a Desktop Environment independent way of starting scim.
When scim is running, you will see a small keyboard icon in your system tray.
Right-click it to enter SCIM Setup. In 'Global Setup' select your keyboard
layout, and you are ready to start entering just about any language
characters you wish! Press the magical key combo <Control><Space>
in order to activate or deactivate SCIM input. The SCIM taskbar in the
desktop's corner allows you to select a language. As you type, SCIM will show
an overview of applicable character glyphs (if you are inputting complex
characters like Japanese).
However in Slackware 12.1, I had to install skim to be able to enter Korean characters in QT-based applications (ex: Kword) although others reported that scim worked fine without skim. You can install skim using this SlackBuild(i.e. a shell script to create the package. See instructions on the site)

In Slackware 12.2, scim works natively with QT-based applications (as far as Korean input is concerned). So no need for Skim.
 
Old 08-25-2009, 08:34 AM   #14
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: Tupelo, MS
Distribution: Gentoo
Posts: 6,926

Rep: Reputation: 124Reputation: 124
Hello hoanglong1712,

I use SCIM that comes with Slackware.

I am using Slackware64 -current.

I do not use Kword or Kate, but I try to help you.

I open Kword and press 'ctrl+space' and input Hanzi. It works, no problem.

I open kate and press 'ctrll+space' and input Hanzi. It works, no problem.

I have QQ beta for Linux. Before I start QQ from a terminal, I must enter
"export LANG=zh_CN.UTF-8" for SCIM to work with QQ.
 
Old 08-25-2009, 11:52 PM   #15
hoanglong1712
Member
 
Registered: Nov 2008
Location: so 34, hem 75, ngach 12 ngo 624, Minh Khai, Ha Noi , Viet Nam
Distribution: Slackware, slax, opensuse
Posts: 33

Rep: Reputation: 15
Dear everyone
I am a vietnamase
I am using slackware 12
I still wait for Slackware 13, because, you known , upgrading os version is really a pain in ass, I am sorry because I do not known another phrase,

if I use firefox or whatever gnome-based application like pidgin or openoffice, the panel has all language
but when I use koffice or kde-app, it only show me keyboard and english/european
I had tried to download scim from slackware.it but the server do not let me download

what should I do?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
configuration problems of "scim" in Slackware 12 Harry Disney Slackware 17 06-06-2008 07:43 AM
SCIM doesn't work Mathsniper Debian 8 03-02-2006 09:50 PM
chinese input SCIM -d doesn't work xjchen001 Linux - Newbie 1 09-15-2005 09:14 PM
Scim + KDE (slackware/general) Dodecha Linux - General 5 03-21-2005 08:56 AM
How to make SCIM to work satimis Fedora 24 02-17-2005 09:41 AM


All times are GMT -5. The time now is 12:05 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration