LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 06-07-2005, 10:39 AM   #1
Mathsniper
Member
 
Registered: Aug 2004
Posts: 135

Rep: Reputation: 15
SCIM doesn't work


I have installed scim using command, apt-get install scim scim-tables-zh. and then i create and modify /etc/X11/Xsession.d/95input
Code:
/usr/bin/scim -d
export XMODIFIERS="@im=SCIM"
export GTK_IM_MODULE="scim"
export XIM_PROGRAM="scim -d"
export QT_IM_MODULE="scim"
The SCIM was loaded each starting KDE. But I can't press Ctrl+Space to type chinese. What's matter?(I didn't modify SCIM setting)
 
Old 06-08-2005, 02:23 AM   #2
damienduff
Member
 
Registered: Feb 2004
Distribution: Etch
Posts: 117

Rep: Reputation: 15
i am sure u can find a lot of information if u search for "SCIM"
 
Old 06-08-2005, 06:23 AM   #3
Mathsniper
Member
 
Registered: Aug 2004
Posts: 135

Original Poster
Rep: Reputation: 15
okay, but i can't see chinese on debian system. do i need to install package? (i wanna use english system, not chinese system)

Last edited by Mathsniper; 06-08-2005 at 06:30 AM.
 
Old 06-08-2005, 12:46 PM   #4
damienduff
Member
 
Registered: Feb 2004
Distribution: Etch
Posts: 117

Rep: Reputation: 15
yup, mine is english system too.

i try to make my explanation simple.

apt-get install ttf-arphic-* kde-i18n-zhcn kde-i18n-zhtw
u can oso install the firefly fonts from taiwan if u wish.

apt-get install scim scim-chinese scim-gtk2-immodule

now we need to install locales, so run command "dpkg-reconfigure locales"

select the chinese locales u want but at the next screen, choose en_US.utf8 as default.

(i did not modify /etc/X11/Xsession.d/95input as u did.)

put this in .bashrc
export LC_CTYPE="zh_CN.gb2312"

if possible, please install the simsun and simhei fonts too.
i believe simsun is 简体 and simhei is 繁体。You haf to use defoma for this, but tats a long and different story. scim should now work in some programs but not all.
 
Old 06-08-2005, 01:13 PM   #5
hkl8324
Member
 
Registered: Aug 2003
Location: Hong Kong, China
Distribution: Ubuntu 10.04
Posts: 234

Rep: Reputation: 30
Re: SCIM doesn't work

Quote:
Originally posted by Mathsniper
I have installed scim using command, apt-get install scim scim-tables-zh. and then i create and modify /etc/X11/Xsession.d/95input
Code:
/usr/bin/scim -d
export XMODIFIERS="@im=SCIM"
export GTK_IM_MODULE="scim"
export XIM_PROGRAM="scim -d"
export QT_IM_MODULE="scim"
The SCIM was loaded each starting KDE. But I can't press Ctrl+Space to type chinese. What's matter?(I didn't modify SCIM setting)
i can use scim even i didnt add the above lines.....

i just take "one the spot" and "always show XXX(cant remember what exactly is XXX)

using the Scim gconf utilities....
 
Old 06-09-2005, 11:40 AM   #6
liucougar
LQ Newbie
 
Registered: Mar 2005
Distribution: Gentoo
Posts: 21

Rep: Reputation: 0
simhei is 简体 as well
 
Old 03-02-2006, 06:43 AM   #7
realwhz
LQ Newbie
 
Registered: Mar 2006
Distribution: Debian
Posts: 10

Rep: Reputation: 0
Hi,

Setting QT_IM_MODULE=scim has no help in fact, since scim does not provide a qt_im_module at all. Another related project, skim, may be responsible for this target.

Anyway, the problem that scim cannot be actived in KDE may be solved as follow:

Run qtconfig, to verify the Input Method of QT application is not On The Spot. Instead, Over the spot may be the correct choice.

Setting XIM_PROGRAM=scim in your 95input configuration file if needed.

Hope these are useful :-)
 
Old 03-02-2006, 07:25 AM   #8
liucougar
LQ Newbie
 
Registered: Mar 2005
Distribution: Gentoo
Posts: 21

Rep: Reputation: 0
install scim-qtimm
 
Old 03-02-2006, 09:50 PM   #9
daihard
Member
 
Registered: Jul 2003
Location: Lynnwood, WA
Distribution: Kubuntu 10.10
Posts: 912

Rep: Reputation: 32
I am using Fedora, not Debian, but SCIM works fine with KDE. What I did was add the following lines to my own X script which starts up with X Window.
Code:
export LC_CTYPE=ja_JP.UTF-8
export XMODIFIERS="@im=SCIM"
/usr/bin/scim -d
(I know, it's Japanese, but I'd imagine the basics are the same.)

I also use the English system. I believe you need to set the two environment variables BEFORE you execute "scim -d".

I also installed scim-qtimm following liucougar's advice, but it does not have any effect for me. What is it supposed to do?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
scim does not show up yumener Linux - Software 2 10-12-2005 01:35 PM
chinese input SCIM -d doesn't work xjchen001 Linux - Newbie 1 09-15-2005 09:14 PM
How do I install the scim??? lewkh Linux - Newbie 1 03-15-2005 08:43 PM
How to make SCIM to work satimis Fedora 24 02-17-2005 09:41 AM
SCIM problem hkl8324 Linux - Software 0 09-29-2004 04:59 AM


All times are GMT -5. The time now is 01:04 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration