Visit Jeremy's Blog.
Go Back > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Slackware This Forum is for the discussion of Slackware Linux.


  Search this Thread
Old 08-25-2007, 08:21 PM   #1
LQ Newbie
Registered: Nov 2006
Location: Cleveland, Tx
Distribution: debian,freebsd,slackware, and ubuntu
Posts: 15

Rep: Reputation: 1
Slackware 12.0 on Acer 3680-2682 No Sound!!! :(

Have an acer 3680-2682 and Installed SW12.0 and have no sound.
What can I do to get it working?

I have read everything in these forums that pertain to an acer and
alsa and Intel 883 sound chip. But I still have no sound.
Also have read everything on google and altavista.

Please help me.

Old 08-25-2007, 08:24 PM   #2
Senior Member
Registered: Mar 2004
Location: Prince Rupert, B.C., Canada
Distribution: Slackware
Posts: 4,696

Rep: Reputation: 762Reputation: 762Reputation: 762Reputation: 762Reputation: 762Reputation: 762Reputation: 762
Did you run these three commands as root?



#alsactl store
Old 08-25-2007, 08:34 PM   #3
LQ Newbie
Registered: Aug 2007
Location: USA
Distribution: Slackware 12
Posts: 18

Rep: Reputation: 0
I have no idea if this will help, because I use v9.1 slackware.
This version is quite finicky about sound. I'm not the one who came up with this command, it was my Dad.
I have to go into root and type this command:
chmod 666 /dev/sound/*
The command makes it so all users can perform the read and write function for sound.
It only works as long as you keep the computer on. When you restart, it needs to be typed in again.

I hope this is useful to you. If not... It was worth a try.
Old 08-29-2007, 01:11 AM   #4
LQ Newbie
Registered: Nov 2006
Location: Cleveland, Tx
Distribution: debian,freebsd,slackware, and ubuntu
Posts: 15

Original Poster
Rep: Reputation: 1
Thanks for the reply....
did some more reading and recompiled alsa again...

Alsa quit giving errors on boot and after certain mixer configuration changes I now have sound...



Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
no sound on Acer Aspire with mepis Tuinis-Magnus Linux - Laptop and Netbook 0 02-10-2007 08:45 AM
no sound on acer aspire 1640 El Fluffo Linux - Laptop and Netbook 7 06-05-2006 12:57 PM
Slackware 10.2 and Acer Travelmate 4020 haysus Linux - Laptop and Netbook 1 12-31-2005 08:16 PM
Sound driver for Acer tm4101 petrik Linux - Laptop and Netbook 7 11-09-2005 04:52 AM
No sound on Mandrake 9.1, Acer Laptop Seajays Mandriva 3 10-25-2003 09:04 AM

All times are GMT -5. The time now is 08:12 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration