LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 01-02-2007, 03:15 PM   #1
pacman87
LQ Newbie
 
Registered: Jan 2007
Distribution: Slackware 11.0
Posts: 3

Rep: Reputation: 0
Question slackware 11, resolution/refresh rates problems with nVidia GeForce 6200


I'm running Slackware 11.0 with a Dell E773c monitor, which I run at 1280x960 @ 72Hz refresh in winXP. I've installed the nvidia driver and I am currently using it. I use KDE, and KRandRTray (screen resize and rotate) doesn't give me the 72 hz refresh option at 1280x960. It is showing my refresh rate as 51 hz, but pressing the "menu" button on my monitor says it's running at 59.9 Hz vertical and 59.9 kHz horizontal refresh. Also, using 1024x768, the same app gives the following refresh rates, which map to different refresh rates for my screen:

KRandRTray: ---> actual: (V, Hz / H, kHz)
53 ------------> 84.9 / 68.6
58 ------------> 74.9 / 60.0
60 ------------> 70.2 / 56.5
61 ------------> 59.8 / 48.1
62 ------------> 87.1 / 35.5


here's my xorg.conf file:
Code:
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 1.0  (buildmeister@builder3)  Fri Dec 15 10:12:14 PST 2006

#Section "Monitor"
#	Identifier   "Monitor1"
#	VendorName   "Monitor Vendor"
#	ModelName    "Monitor Model"
#EndSection
#Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
        ### [arg]: arg optional
        #Option     "NoAccel"            	# [<bool>]
        #Option     "SWcursor"           	# [<bool>]
        #Option     "ColorKey"           	# <i>
        #Option     "CacheLines"         	# <i>
        #Option     "Dac6Bit"            	# [<bool>]
        #Option     "DRI"                	# [<bool>]
        #Option     "NoDDC"              	# [<bool>]
        #Option     "ShowCache"          	# [<bool>]
        #Option     "XvMCSurfaces"       	# <i>
        #Option     "PageFlip"           	# [<bool>]
#	Identifier  "Card1"
#	Driver      "i810"
#	VendorName  "Intel Corporation"
#	BoardName   "82845G/GL[Brookdale-G]/GE Chipset Integrated Graphics Device"
#	BusID       "PCI:0:2:0"
#EndSection
#Section "Screen"
#	Identifier "Screen1"
#	Device     "Card1"
#	Monitor    "Monitor1"
#	DefaultDepth 24
#	SubSection "Display"
#		Viewport   0 0
#		Depth     1
#	EndSubSection
#	SubSection "Display"
#		Viewport   0 0
#		Depth     4
#	EndSubSection
#	SubSection "Display"
#		Viewport   0 0
#		Depth     8
#	EndSubSection
#	SubSection "Display"
#		Viewport   0 0
#		Depth     15
#	EndSubSection
#	SubSection "Display"
#		Viewport   0 0
#		Depth     16
#	EndSubSection
#	SubSection "Display"
#		Viewport   0 0
#		Depth     24
#	EndSubSection
#EndSection

Section "ServerLayout"

#	Screen      1  "Screen1" RightOf "Screen0"
    Identifier     "X.org Configured"
    Screen      0  "Screen0" 0 0
    InputDevice    "Mouse0" "CorePointer"
    InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
    RgbPath         "/usr/X11R6/lib/X11/rgb"
    ModulePath      "/usr/X11R6/lib/modules"
    FontPath        "/usr/X11R6/lib/X11/fonts/misc/"
    FontPath        "/usr/X11R6/lib/X11/fonts/TTF/"
    FontPath        "/usr/X11R6/lib/X11/fonts/Type1/"
    FontPath        "/usr/X11R6/lib/X11/fonts/CID/"
    FontPath        "/usr/X11R6/lib/X11/fonts/75dpi/"
    FontPath        "/usr/X11R6/lib/X11/fonts/100dpi/"
EndSection

Section "Module"
    Load           "glx"
    Load           "extmod"
    Load           "xtrap"
    Load           "record"
    Load           "dbe"
    Load           "freetype"
    Load           "type1"
EndSection

Section "InputDevice"
    Identifier     "Keyboard0"
    Driver         "kbd"
    Option         "XkbModel" "pc104"
    Option         "XkbLayout" "us"
EndSection

Section "InputDevice"
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/mouse"
    Option         "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"

	#DisplaySize	  320   240	# mm
 ### Comment all HorizSync and VertSync values to use DDC:
    Identifier     "Monitor0"
    VendorName     "DELL"
    ModelName      "DELL E773c"
    HorizSync       30.0 - 72.2
    VertRefresh     50.0 - 160.0
    Option         "DPMS"
EndSection

Section "Device"

        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
        ### [arg]: arg optional
        #Option     "SWcursor"           	# [<bool>]
        #Option     "HWcursor"           	# [<bool>]
        #Option     "NoAccel"            	# [<bool>]
        #Option     "ShadowFB"           	# [<bool>]
        #Option     "UseFBDev"           	# [<bool>]
        #Option     "Rotate"             	# [<str>]65
        #Option     "VideoKey"           	# <i>
        #Option     "FlatPanel"          	# [<bool>]
        #Option     "FPDither"           	# [<bool>]
        #Option     "CrtcNumber"         	# <i>
        #Option     "FPScale"            	# [<bool>]
        #Option     "FPTweak"            	# <i>
    Identifier     "Card0"
#    Driver         "nv"
    Driver         "nvidia"
    Option         "nologo" "1"
    Option         "UseEDIDFreq" "false"
    VendorName     "nVidia Corporation"
    BoardName      "GeForce 6200"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Card0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Viewport    0 0
        Depth       1
    EndSubSection
    SubSection     "Display"
        Viewport    0 0
        Depth       4
    EndSubSection
    SubSection     "Display"
        Viewport    0 0
        Depth       8
    EndSubSection
    SubSection     "Display"
        Viewport    0 0
        Depth       15
    EndSubSection
    SubSection     "Display"
        Viewport    0 0
        Depth       16
    EndSubSection
    SubSection     "Display"
        Viewport    0 0
        Depth       24
	Modes      "1280x1024" "1280x960_72" "1280x960_60" "1280x800" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
    EndSubSection
EndSection
I also have an integrated graphics processor as well, (intel i810) which is commented out of the file.

thanks for your help.
 
Old 01-02-2007, 03:33 PM   #2
Wynd
Member
 
Registered: Jul 2001
Distribution: Slackware 12
Posts: 511

Rep: Reputation: 32
Try running the command nvidia-settings and see if you can change it in there.
 
Old 01-02-2007, 05:27 PM   #3
pacman87
LQ Newbie
 
Registered: Jan 2007
Distribution: Slackware 11.0
Posts: 3

Original Poster
Rep: Reputation: 0
the nvidia-settings window shows the correct list of refresh rates for each resolution, but the refresh list for 1280x960 only has 'auto' and '60 Hz'

i'm not sure if this matters, but the specs for my monitor lists the horizontal range as 30-70 kHz, and in winXP, my monitor says it's running at 72.2 kHz horiz and 72.1 Hz vert to get 1280x960 @ 72 Hz. i did change my xorg.conf to include the 72.2 kHz rate. i also used the
Code:
Option         "UseEDIDFreq" "false"
to try to prevent the driver from accessing the default range, but i don't really know what i'm doing here. (although you probably already knew that )
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
FC5 nVidia GeForce 6200 TurboCache with a Dual Head, can anyone help? Tom "Techno" Earl Fedora 3 11-06-2006 12:30 PM
nVidia GeForce 6200 no longer works after reboot Penguin of Wonder Linux - Hardware 4 03-18-2006 11:11 PM
Mandriva 2005,cannot install nvidia driver with geforce 6200 idagon Mandriva 1 09-23-2005 11:43 PM
NVIDIA GeForce Go 6200 driver?? harlemno1 Linux - Hardware 5 03-25-2005 08:43 AM
need help with changing resolution/refresh rates on my monitor chiatello Linux - General 3 10-31-2003 11:43 PM


All times are GMT -5. The time now is 07:41 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration