LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 10-02-2012, 09:08 AM   #1
Iwantslack
Member
 
Registered: Dec 2008
Posts: 31

Rep: Reputation: 2
Several minor Issues with Slackware 14


First of all Sorry for being not Specific in the Thread title.

I installed Slackware 14 on an existing luks+LVM. no issues, everything is fine. But:

Slackware doesnt have have the KDE default Folders (like Pictures, Desktop, etc.) but that is easyly solved,
KDE have 2 Konqueror Symbols in the taskbar that come back every reboot and Klicking Log Out in KDE freezes my Machine.


Anyone else got that kind of Problems?

EDIT: Using the Powerbutton imidiately Shuts down my Machine Despite what i configure in KDE (Normally a Dialog with some Options should come up). That Issue is something i also had with 13.37 if i remember correctly.
Since there are Bugs that will never be solved (like my Problem with the Screenbrightness in 13.37 and now the Powerbutton stuff) i guess i will have to wait for the next release. Again. Seriously, Since 12.2 Minor Bugs are getting Pretty Annoying (and seemingly Unsolveable) in Slackware.

Last edited by Iwantslack; 10-03-2012 at 02:01 AM.
 
Old 10-02-2012, 09:10 AM   #2
yilez
Member
 
Registered: Apr 2004
Distribution: Slackware
Posts: 122

Rep: Reputation: Disabled
I have the two konqueror symbols. Tried removing them and they came back.

I haven't noticed any issues with logout, but I don't know if I have clicked it.

I have neither LUKS nor LVM.
 
Old 10-02-2012, 09:20 AM   #3
Bazzaah
Member
 
Registered: Mar 2007
Distribution: Slackware64-current, Slackware64 14
Posts: 327

Rep: Reputation: 49
Search on here or Google the two konqueror symbols - it's easily fixed (can't remember the solution off hand). You can also use the icons only task manager which I find much nicer to use.

Logout's fine here.
 
Old 10-02-2012, 09:31 AM   #4
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,393

Rep: Reputation: Disabled
Delete the task manager widget (aka plasmoid) from the panel and then re-add it (you can find it in the list of widgets). That solves the issue of the re-occurring two konqueror launchers.

You can also look for the section "[Containments][**][Applets][**][Configuration][Launchers]" in the config file "~/.kde4/share/config/plasma-desktop-appletsrc" and delete that.

The issue was fixed in KDE 4.9.1: https://bugs.kde.org/show_bug.cgi?id=278724

Eric
 
2 members found this post helpful.
Old 10-02-2012, 10:26 AM   #5
yilez
Member
 
Registered: Apr 2004
Distribution: Slackware
Posts: 122

Rep: Reputation: Disabled
I figured it would be a simple fix. I've just been accessing mostly from ssh, so it wasn't high on my list of priorities to fix.
 
Old 10-21-2012, 03:26 PM   #6
Iwantslack
Member
 
Registered: Dec 2008
Posts: 31

Original Poster
Rep: Reputation: 2
Well, thanks to me, i solved my Powerbutton Problem.

Its most curious that noone else got the Problem because the default acpi config in Slackware64 calls for init 0 when the Powerbutton is being pressed.

To get Slackware to work Properly (not immediatly Shutting down when the Powerbutton ist pressed) i changed "/sbin/init 0" to "/sbin/init 5" in /etc/acpi/acpi_handler.sh. That way the Shutdown/Logout/Reboot dialog is properly displayed when Pressing the Power Button.

Now i finally can use Slackware again!!!!

Last edited by Iwantslack; 10-21-2012 at 03:27 PM.
 
Old 10-22-2012, 11:28 PM   #7
irgunII
Member
 
Registered: Jan 2012
Location: Directly above the center of the earth
Distribution: Slackware. There's something else?
Posts: 383

Rep: Reputation: 71
@Iwantslack - Nice find and fix. It was the same in Slackware 14.0 32 bit, and I just now changed mine also. Thanks!
 
Old 10-23-2012, 08:56 AM   #8
GazL
Senior Member
 
Registered: May 2008
Posts: 3,503

Rep: Reputation: 1026Reputation: 1026Reputation: 1026Reputation: 1026Reputation: 1026Reputation: 1026Reputation: 1026Reputation: 1026
I can't speak for others, but as I don't use KDE the default behaviour of the power button is exactly the one I want.
 
1 members found this post helpful.
Old 10-23-2012, 10:39 AM   #9
qweasd
Member
 
Registered: May 2010
Posts: 486

Rep: Reputation: Disabled
power button

Quote:
Originally Posted by Iwantslack View Post
EDIT: Using the Powerbutton imidiately Shuts down my Machine Despite what i configure in KDE (Normally a Dialog with some Options should come up). That Issue is something i also had with 13.37 if i remember correctly.
That's not an issue. That's a (default?) ACPI behavior defined in /etc/acpi/acpi_handler.sh
Just comment out the init 0 line, and then KDE settings will take over.
 
Old 10-23-2012, 11:04 AM   #10
qweasd
Member
 
Registered: May 2010
Posts: 486

Rep: Reputation: Disabled
By the way, I really hate how KDE apps keep creating the default folders and ruining my highly organized home directory. The workaround I am using right now is renaming them all to /tmp, but that's just stupid. Like, dolphin, for example, still shows Desktop link, but it's really /tmp. Why can't KDE just STOP DOING THINGS?
 
Old 10-23-2012, 12:17 PM   #11
el chapulín
Member
 
Registered: Sep 2012
Posts: 75

Rep: Reputation: 19
I had the two konqueror icons and deleted them...
 
Old 10-24-2012, 02:01 AM   #12
PrinceCruise
Member
 
Registered: Aug 2009
Location: /Universe/Earth/India/Pune
Distribution: Slackware64 14.1/Current, CentOS 6.5/7.0
Posts: 795

Rep: Reputation: Disabled
I too had the two tiny Konqueror icons issue with the 32 bit fresh install. Deleted & re-added the task manager and it's perfectly fine now.
I wonder how KDE was shipped in Slackware with this little annoying feature?

Regards.
 
Old 11-27-2012, 08:20 AM   #13
GNU/Linux
Member
 
Registered: Sep 2012
Distribution: Slackware-14
Posts: 81

Rep: Reputation: Disabled
Regarding two Konqueror icons: KDE has set both default file manager and web browser to Konqueror. Go to System Settings > Default Applications and change then to what you want. Logout/login to see the desired icons.
 
Old 11-27-2012, 10:24 AM   #14
tuxbg
Member
 
Registered: Sep 2012
Location: Bulgaria,Varna
Distribution: Slackware64
Posts: 249

Rep: Reputation: Disabled
Quote:
Originally Posted by PrinceCruise View Post
I too had the two tiny Konqueror icons issue with the 32 bit fresh install. Deleted & re-added the task manager and it's perfectly fine now.
I wonder how KDE was shipped in Slackware with this little annoying feature?

Regards.
That is because konquerror is a default file manager and default web browser.
Its not a bug.
Kmenu > Configure Desktop > Advanced > File Assoc >default browser
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Various minor Mandriva issues ixhabbaba Linux - Software 3 08-10-2008 01:52 PM
Minor GNOME issues matte85 Linux - Software 0 11-29-2007 07:44 AM
Having minor issues with Xserver. hacker supreme Linux - Desktop 8 04-17-2007 11:48 AM
Minor Mozilla issues...... CaptainInsane Linux - Software 2 12-08-2003 08:58 PM
gnome2 - several minor issues timorei Linux - Software 0 03-11-2003 07:37 PM


All times are GMT -5. The time now is 09:40 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration