LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Several minor Issues with Slackware 14 (http://www.linuxquestions.org/questions/slackware-14/several-minor-issues-with-slackware-14-a-4175430046/)

Iwantslack 10-02-2012 09:08 AM

Several minor Issues with Slackware 14
 
First of all Sorry for being not Specific in the Thread title.

I installed Slackware 14 on an existing luks+LVM. no issues, everything is fine. But:

Slackware doesnt have have the KDE default Folders (like Pictures, Desktop, etc.) but that is easyly solved,
KDE have 2 Konqueror Symbols in the taskbar that come back every reboot and Klicking Log Out in KDE freezes my Machine.


Anyone else got that kind of Problems?

EDIT: Using the Powerbutton imidiately Shuts down my Machine Despite what i configure in KDE (Normally a Dialog with some Options should come up). That Issue is something i also had with 13.37 if i remember correctly.
Since there are Bugs that will never be solved (like my Problem with the Screenbrightness in 13.37 and now the Powerbutton stuff) i guess i will have to wait for the next release. Again. Seriously, Since 12.2 Minor Bugs are getting Pretty Annoying (and seemingly Unsolveable) in Slackware.

yilez 10-02-2012 09:10 AM

I have the two konqueror symbols. Tried removing them and they came back.

I haven't noticed any issues with logout, but I don't know if I have clicked it.

I have neither LUKS nor LVM.

Bazzaah 10-02-2012 09:20 AM

Search on here or Google the two konqueror symbols - it's easily fixed (can't remember the solution off hand). You can also use the icons only task manager which I find much nicer to use.

Logout's fine here.

Alien Bob 10-02-2012 09:31 AM

Delete the task manager widget (aka plasmoid) from the panel and then re-add it (you can find it in the list of widgets). That solves the issue of the re-occurring two konqueror launchers.

You can also look for the section "[Containments][**][Applets][**][Configuration][Launchers]" in the config file "~/.kde4/share/config/plasma-desktop-appletsrc" and delete that.

The issue was fixed in KDE 4.9.1: https://bugs.kde.org/show_bug.cgi?id=278724

Eric

yilez 10-02-2012 10:26 AM

I figured it would be a simple fix. I've just been accessing mostly from ssh, so it wasn't high on my list of priorities to fix.

Iwantslack 10-21-2012 03:26 PM

Well, thanks to me, i solved my Powerbutton Problem.

Its most curious that noone else got the Problem because the default acpi config in Slackware64 calls for init 0 when the Powerbutton is being pressed.

To get Slackware to work Properly (not immediatly Shutting down when the Powerbutton ist pressed) i changed "/sbin/init 0" to "/sbin/init 5" in /etc/acpi/acpi_handler.sh. That way the Shutdown/Logout/Reboot dialog is properly displayed when Pressing the Power Button.

Now i finally can use Slackware again!!!!

irgunII 10-22-2012 11:28 PM

@Iwantslack - Nice find and fix. It was the same in Slackware 14.0 32 bit, and I just now changed mine also. Thanks!

GazL 10-23-2012 08:56 AM

I can't speak for others, but as I don't use KDE the default behaviour of the power button is exactly the one I want.

qweasd 10-23-2012 10:39 AM

power button
 
Quote:

Originally Posted by Iwantslack (Post 4794880)
EDIT: Using the Powerbutton imidiately Shuts down my Machine Despite what i configure in KDE (Normally a Dialog with some Options should come up). That Issue is something i also had with 13.37 if i remember correctly.

That's not an issue. That's a (default?) ACPI behavior defined in /etc/acpi/acpi_handler.sh
Just comment out the init 0 line, and then KDE settings will take over.

qweasd 10-23-2012 11:04 AM

By the way, I really hate how KDE apps keep creating the default folders and ruining my highly organized home directory. The workaround I am using right now is renaming them all to /tmp, but that's just stupid. Like, dolphin, for example, still shows Desktop link, but it's really /tmp. Why can't KDE just STOP DOING THINGS?

el chapulín 10-23-2012 12:17 PM

I had the two konqueror icons and deleted them...

PrinceCruise 10-24-2012 02:01 AM

I too had the two tiny Konqueror icons issue with the 32 bit fresh install. Deleted & re-added the task manager and it's perfectly fine now.
I wonder how KDE was shipped in Slackware with this little annoying feature?

Regards.

GNU/Linux 11-27-2012 08:20 AM

Regarding two Konqueror icons: KDE has set both default file manager and web browser to Konqueror. Go to System Settings > Default Applications and change then to what you want. Logout/login to see the desired icons.

tuxbg 11-27-2012 10:24 AM

Quote:

Originally Posted by PrinceCruise (Post 4813569)
I too had the two tiny Konqueror icons issue with the 32 bit fresh install. Deleted & re-added the task manager and it's perfectly fine now.
I wonder how KDE was shipped in Slackware with this little annoying feature?

Regards.

That is because konquerror is a default file manager and default web browser.
Its not a bug.
Kmenu > Configure Desktop > Advanced > File Assoc >default browser :)


All times are GMT -5. The time now is 06:02 PM.