LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 03-12-2004, 05:35 AM   #1
kobs
Member
 
Registered: Mar 2004
Location: 127.0.0.1
Distribution: FreeBSD 5.3-STABLE, Slackware 10-CURRENT, Debian Sarge
Posts: 51

Rep: Reputation: 15
Setting up Sound with onboard AC'97 Audio


How do I set up sound? I tried reading the slackware book from slackware.com but can't find anything. Much thanks in advance.
 
Old 03-12-2004, 05:52 AM   #2
Mogwa_
Member
 
Registered: Aug 2003
Distribution: Slackware, Evil Entity
Posts: 63

Rep: Reputation: 15
at a terminal as root can you type "lspci"

this lists all pci decvices in your system and should tell you the exact chipset of the sound card.

i have one which is classed as a ac 97 but it is in face a sis7012

once you know this we can work ot the best way to get sound working.
 
Old 03-12-2004, 05:53 AM   #3
kobs
Member
 
Registered: Mar 2004
Location: 127.0.0.1
Distribution: FreeBSD 5.3-STABLE, Slackware 10-CURRENT, Debian Sarge
Posts: 51

Original Poster
Rep: Reputation: 15
Ok...I am about to boot back into slackware in a few minutes...I'll be back and post the chipset
 
Old 03-12-2004, 06:52 AM   #4
kobs
Member
 
Registered: Mar 2004
Location: 127.0.0.1
Distribution: FreeBSD 5.3-STABLE, Slackware 10-CURRENT, Debian Sarge
Posts: 51

Original Poster
Rep: Reputation: 15
This is what I got...

Intel Corp. 82801AA AC'97 Audio (rev 02)
 
Old 03-12-2004, 06:57 AM   #5
dopefish
Member
 
Registered: Nov 2003
Location: Northcliffe, WA
Distribution: Slackware 12.0
Posts: 481

Rep: Reputation: 30
check your soundchannels see if they are muted
$alsamixer
If the channels show an M at the top they are muted m key will unmute
If you havent got alsa installed go download the source and read the alsa howto
www.alsa-project.org
 
Old 03-12-2004, 07:13 AM   #6
krajzega
Member
 
Registered: Jan 2004
Location: Poland
Distribution: FreeBSD 5.1
Posts: 92

Rep: Reputation: 15
Well, try also to configure your AC97 by alsactl typing:
# alsactl #your_ac97_card_number
If you use SBLive with onboard card it can work not-properly, so try to disable it in bios.
 
Old 03-12-2004, 07:36 AM   #7
swarup.mohalik
LQ Newbie
 
Registered: Mar 2004
Location: Bangalore, India
Distribution: RH 8.0 linux 2.6
Posts: 1

Rep: Reputation: 0
sound with on-board AC'97

I have the Intel 82801DB on board sound card (with AC'97 codec).
RH 8.0 linux 2.6

I built the alsa modules. The driver for the card is snd-intel8x0. I modprobe this module and also modprobe the snd_pcm_oss and snd_mixer_oss modules.

I ran 'alsaconf' to do the configuration of the card (i don't know what
all things it does. But after that I am able to play various formats
.wav, .mpeg etc.

However, I can not listen to my CD.
I use some instruction and do 'arecord | aplay' after doing the capture
on CD in the alsamixer. But what I get is a continuous grating sound.
Q : Is there any other way of listening to CD?

I capture the Mic through the alsamixer. The .wav files are created. But
either they are quiet or create the same grating sound when I use aplay.

The microphone/headphone are fine as I tested them on another PC (windows).. This brings me to suspect that the sound card may have recording problems. This is also suggested by someone in the stanford CCRMA mail exchanges.

Q.: How do I pinpoint the source of the problem? Is it the driver or the card that is the culprit?

Thanks in advance
 
Old 03-12-2004, 09:40 AM   #8
Mogwa_
Member
 
Registered: Aug 2003
Distribution: Slackware, Evil Entity
Posts: 63

Rep: Reputation: 15
---Q : Is there any other way of listening to CD?

if you are using gnome it has its own cdplayer in the menu under multimedia.

---I capture the Mic through the alsamixer. The .wav files are created. But
---either they are quiet or create the same grating sound when I use aplay.

check you mic volume is turned right up and in alsamixer see if on mic it says mic 1 or mic 2. I had this problem and it was that the mic was set to mic 2 when it should be mic 1.

---Q.: How do I pinpoint the source of the problem? Is it the driver or the card that is the culprit?

normally if you get the wrong driver you rarther get no sound at all or the sound is very bad.
 
Old 03-12-2004, 10:42 AM   #9
xgreen
Member
 
Registered: Aug 2003
Distribution: Slackware,Ubuntu
Posts: 389

Rep: Reputation: 30
try rexima
 
Old 03-12-2004, 10:54 AM   #10
kobs
Member
 
Registered: Mar 2004
Location: 127.0.0.1
Distribution: FreeBSD 5.3-STABLE, Slackware 10-CURRENT, Debian Sarge
Posts: 51

Original Poster
Rep: Reputation: 15
thanks for the help guys -- im gonna try it later
 
Old 03-12-2004, 09:40 PM   #11
SML
Member
 
Registered: Dec 2002
Location: US
Distribution: ARCH
Posts: 376

Rep: Reputation: 30
Guess you've been to www.alsa-project.org and looked up the procedure for configuring your card, and ran through the procedure step by step for all 3 alsa files and modified your modules.conf?
 
Old 03-13-2004, 09:48 AM   #12
ProtoformX
Member
 
Registered: Feb 2004
Location: Canada
Distribution: LFS SVN
Posts: 334

Rep: Reputation: 34
Post

I have a similuar problem... everything works accept midi all though I don't really care about midi cause I don't think this card really supports midi, in Windows XP when I pull up the mixer it says SW Synth ... so my midi driver is being emulated like timidity does on linux...

Or thats what I think anyways.. can anyone tell me if I'm right about the Intel8x0 chipset not supporting midi? (even though there are ALSA midi drivers)
 
Old 10-17-2004, 07:45 PM   #13
meshsmooth
LQ Newbie
 
Registered: May 2004
Location: austraila
Distribution: Mandrake 10
Posts: 6

Rep: Reputation: 0
I had the problem of not being able to hear my mic under suse 9.1 .... well if I made a hell of a noise I could just here it. in Windows XP and my bootable mandrake 10 cd it worked, so I went a searching on google with the key words: quiet microphone Linux I read somewhere about switching from mic 1 to mic 2 but didn't know where to do it and I ran # alsamixer and saw the mic 1 / mic 2 toggle and my troubles were over. I am writing this post so a google bot may find this some day and save somebody the trouble I had.

And in case I forget
 
Old 10-17-2004, 08:37 PM   #14
mcd
Member
 
Registered: Aug 2003
Location: Boulder, CO
Distribution: Slackware, RHEL, CentOS
Posts: 825

Rep: Reputation: 33
i'm not sure if this is your problem, but i had to get a cable to connect the sound card to the cdrom drive. something about simple programs like kscd or the cdplayer applet not support digital audio compression...or something. anyway, i think an easy way to test this is try playing a cd in XMMS or another bloated media player (these support it). if that works, then this is most likely your problem.
 
Old 10-17-2004, 11:09 PM   #15
mago
Member
 
Registered: Apr 2004
Location: Costa Rica
Distribution: slack current with 2.6.16.18 (still off the hook)
Posts: 284

Rep: Reputation: 33
Code:
alsaconf
That should do it550 Relaying denied
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
no sound with onboard audio bosewicht Arch 4 06-03-2004 01:35 PM
Onboard AC'97 sound not working even with correct driver Lfsve82 Mandriva 4 02-07-2004 12:11 PM
Help!! How do I enable the audio driver for the 82801BA/BAM AC'97 Sound Card? htnthguyen Red Hat 3 01-26-2004 06:53 PM
Issues with onboard AC'97 Realtek audio Riley Linux - Hardware 2 02-16-2003 03:45 PM
Sound problems with RH8 + Intel 82801DB AC'97 Audio jaakjr Linux - Hardware 8 11-04-2002 11:28 PM


All times are GMT -5. The time now is 07:53 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration