LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 04-02-2013, 03:43 PM   #1
brobr
Member
 
Registered: Oct 2003
Location: uk
Distribution: Slackware
Posts: 53

Rep: Reputation: 17
SBo-Webkit does not compile on current; inkscape need gcc-4.8 patched source


Installing slackware64-current went very well on my new clevo W550eu.

Some hitches, though, when using SBo packages:

inkscape: needed to get the latest update (from their bazaar-repository) which is patched to compile with gcc-4.8.0

webkit: does not compile: The standard SBo-version, 1.8.3, as well as 1.9.2 stall with:

Code:
Source/WebCore/xml/XPathParser.cpp: In member function 'WebCore::XPath::Expression* WebCore::XPath::Parser::parseStatement(const WTF::String&, WTF::PassRefPtr<WebCore::XPathNSResolver>, WebCore::ExceptionCode&)':
Source/WebCore/xml/XPathParser.cpp:478:39: error: too many arguments to function 'int WebCore::XPath::xpathyyparse()'
     int parseError = xpathyyparse(this);
                                       ^
In file included from Source/WebCore/xml/XPathParser.cpp:49:0:
./DerivedSources/WebCore/XPathGrammar.hpp:106:5: note: declared here
make[1]: *** [Source/WebCore/xml/libWebCore_la-XPathParser.lo] Error 1
make[1]: Leaving directory `/home/sbo_64/tmp/sbopkg.SSrL9i/webkit-1.8.3'
make: *** [all] Error 2
Cleaning up...

webkitgtk
I tried other webkit-versions; the latest ones require upgrades of other packages, which I did not try, or asked for " --with-gtk=3.0" in the configuration, which, for 1.9.3 gave the same error as above.

Any ideas?

Thanks,

rob
 
Old 04-02-2013, 07:33 PM   #2
willysr
Senior Member
 
Registered: Jul 2004
Location: Jogja, Indonesia
Distribution: Slackware-Current
Posts: 2,576

Rep: Reputation: 430Reputation: 430Reputation: 430Reputation: 430Reputation: 430
Please note that SBo does not support -current installation
 
Old 04-02-2013, 11:46 PM   #3
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 2,460

Rep: Reputation: 888Reputation: 888Reputation: 888Reputation: 888Reputation: 888Reputation: 888Reputation: 888
http://cgit.ponce.cc/slackbuilds/commit/?h=inkscape
http://cgit.ponce.cc/slackbuilds/commit/?h=webkitgtk
 
1 members found this post helpful.
Old 04-03-2013, 06:06 AM   #4
brobr
Member
 
Registered: Oct 2003
Location: uk
Distribution: Slackware
Posts: 53

Original Poster
Rep: Reputation: 17
@willysr: Thanks, I am aware of that; but is this forum not an apt place to report that some builds no longer work after current-upgrades? Just in case such problems had not been spotted yet??

@ponce: Great, that is very helpful info. The inkscape problem was repaired by getting a daily built as source for building a SlackBuild package; I am now compiling webkit again, see where that ends now.........yip that worked
 
Old 04-03-2013, 08:38 AM   #5
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 2,460

Rep: Reputation: 888Reputation: 888Reputation: 888Reputation: 888Reputation: 888Reputation: 888Reputation: 888
Quote:
Originally Posted by brobr View Post
@willysr: Thanks, I am aware of that; but is this forum not an apt place to report that some builds no longer work after current-upgrades? Just in case such problems had not been spotted yet??
not really like that, as -current is officially unsupported by SBo, so these things are taken care when the new stable version of Slackware is out.

that said, as some people use SBo with -current, it *might* be that someone has encountered the error and/or can provide a solution, but don't take this for granted.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] kyotocabinet (1.2.76) Sbo and Slackware Current carlitoco Slackware 4 03-06-2013 05:23 AM
[SOLVED] Inkscape compile error at current Slack brodo Slackware 2 04-03-2012 07:21 PM
OSSv42-2004 released, fixes SBo compile error in -current linuxs64 Slackware 10 01-15-2011 02:19 AM
alien's vlc, -current and SBo's libva grissiom Slackware 2 10-28-2010 08:50 AM
[SOLVED] Digikam from SBo does not compile on 64-current of 2010-03-09 gargamel Slackware 10 03-21-2010 05:28 PM


All times are GMT -5. The time now is 06:43 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration