LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   SBo-Webkit does not compile on current; inkscape need gcc-4.8 patched source (http://www.linuxquestions.org/questions/slackware-14/sbo-webkit-does-not-compile-on-current%3B-inkscape-need-gcc-4-8-patched-source-4175456581/)

brobr 04-02-2013 03:43 PM

SBo-Webkit does not compile on current; inkscape need gcc-4.8 patched source
 
Installing slackware64-current went very well on my new clevo W550eu.

Some hitches, though, when using SBo packages:

inkscape: needed to get the latest update (from their bazaar-repository) which is patched to compile with gcc-4.8.0

webkit: does not compile: The standard SBo-version, 1.8.3, as well as 1.9.2 stall with:

Code:

Source/WebCore/xml/XPathParser.cpp: In member function 'WebCore::XPath::Expression* WebCore::XPath::Parser::parseStatement(const WTF::String&, WTF::PassRefPtr<WebCore::XPathNSResolver>, WebCore::ExceptionCode&)':
Source/WebCore/xml/XPathParser.cpp:478:39: error: too many arguments to function 'int WebCore::XPath::xpathyyparse()'
    int parseError = xpathyyparse(this);
                                      ^
In file included from Source/WebCore/xml/XPathParser.cpp:49:0:
./DerivedSources/WebCore/XPathGrammar.hpp:106:5: note: declared here
make[1]: *** [Source/WebCore/xml/libWebCore_la-XPathParser.lo] Error 1
make[1]: Leaving directory `/home/sbo_64/tmp/sbopkg.SSrL9i/webkit-1.8.3'
make: *** [all] Error 2
Cleaning up...

webkitgtk

I tried other webkit-versions; the latest ones require upgrades of other packages, which I did not try, or asked for " --with-gtk=3.0" in the configuration, which, for 1.9.3 gave the same error as above.

Any ideas?

Thanks,

rob

willysr 04-02-2013 07:33 PM

Please note that SBo does not support -current installation

ponce 04-02-2013 11:46 PM

http://cgit.ponce.cc/slackbuilds/commit/?h=inkscape
http://cgit.ponce.cc/slackbuilds/commit/?h=webkitgtk

brobr 04-03-2013 06:06 AM

@willysr: Thanks, I am aware of that; but is this forum not an apt place to report that some builds no longer work after current-upgrades? Just in case such problems had not been spotted yet??

@ponce: Great, that is very helpful info. The inkscape problem was repaired by getting a daily built as source for building a SlackBuild package; I am now compiling webkit again, see where that ends now.........yip that worked

ponce 04-03-2013 08:38 AM

Quote:

Originally Posted by brobr (Post 4924189)
@willysr: Thanks, I am aware of that; but is this forum not an apt place to report that some builds no longer work after current-upgrades? Just in case such problems had not been spotted yet??

not really like that, as -current is officially unsupported by SBo, so these things are taken care when the new stable version of Slackware is out.

that said, as some people use SBo with -current, it *might* be that someone has encountered the error and/or can provide a solution, but don't take this for granted. ;)


All times are GMT -5. The time now is 04:01 AM.