LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 07-01-2002, 08:55 PM   #1
JohnA
LQ Newbie
 
Registered: Dec 2000
Location: Ireland
Posts: 7

Rep: Reputation: 0
No power down after shutdown (Mandrake)


Hi,
I'm runing Linux Mandrake 8.2 on an Intel P4
ATX desktop machine. When I do a system shutdown,
the computer power does not switch itself off.
The system goes through all the correct motions of
doing a shutdown, but at the very end it just displays
the "Power Down" message, and sits there.
This is a dual boot machine with Win 98, which does
power down the system correctly after shutdown.

The 'halt' script (in /etc/init.d) contains:

# See how we were called.
case "$0" in
*halt)
message=`gprintf "Halting system..."`
command="halt -p"
;;
*reboot)
message=`gprintf "Please stand by while rebooting the system..."`
command="reboot"
;;
*)


and this also:


HALTARGS="-i -d -p"
if [ -f /halt ]; then
HALTARGS="-i -d"
fi

eval $command $HALTARGS

Doing ps -elf says that apmd is running.

040 S root 3 1 0 69 0 - 0 apm_ma Jul01 ? 00:00:00 [kapmd]

I would have thought this would be sufficient to power off
the machine.
One thing to note: 'killall' fails during the shutdown
(don't know why [how can I find out?], or whether this has anything to do with the machine not powering off).

Any idea what's wrong? It's a real head-scratcher for me.


Thanks,
John
johnashe_64@yahoo.com
 
Old 07-01-2002, 11:06 PM   #2
Aussie
Senior Member
 
Registered: Sep 2001
Location: Brisvegas, Antipodes
Distribution: Slackware
Posts: 4,590

Rep: Reputation: 56
Do "lsmod" as root and look for apm, if it's not there try doing "modprobe apm".
 
Old 07-02-2002, 03:10 PM   #3
mrGee
Member
 
Registered: Dec 2001
Location: Netherlands
Distribution: redhat suse mandrake freebsd
Posts: 344

Rep: Reputation: 30
on my mdk 8.2 the apm is not loaded still it shutdowns very fine

the different mdk versions 8.0 8.1 and 8.2 had all to do with
their own shutdown trouble (luckily never on my sytems though)
Some apm settings in the bios or even flashing the bios (beware)
was a solution for some.
in mdk 8.1 as mentioned in one of their errata it could have
to do with usb but i guess that should produce some error
when shutting down.
maybe deleting some services you dont need or for testing
does the trick
maybe using another kernel (some got rid of their problem
upgrading from 8.0 to higher version)
i know thats alot of 'maybe's' but havent encountered problems
myself this is what i have seen on the web/forum

And well maybe apm is the solution as Aussie says
 
Old 07-02-2002, 05:33 PM   #4
JohnA
LQ Newbie
 
Registered: Dec 2000
Location: Ireland
Posts: 7

Original Poster
Rep: Reputation: 0
Hmmmm... Aussie is right. I did an 'lsmod' as root and
'apm' is not is not listed. Doing 'modprobe apm' results
in: 'modprobe: Can't locate module apm'. So, that sounds
like my problem then. Now, where can I get this apm
module, and how do I install it? Thanks for all the
help here. I really appreciate this.

John.
 
Old 07-02-2002, 05:37 PM   #5
Phonics3k
Member
 
Registered: Jun 2002
Location: Wales, UK
Distribution: Gentoo 2005.1
Posts: 213

Rep: Reputation: 30
to get the apm module u will have to compile a new kernel

todo that

cd to /usr/src/linux
make clean
make menuconfig

look for the apm stuff and then select them untill u get an m
now do make modules && make modules_install
 
Old 07-02-2002, 08:38 PM   #6
Aussie
Senior Member
 
Registered: Sep 2001
Location: Brisvegas, Antipodes
Distribution: Slackware
Posts: 4,590

Rep: Reputation: 56
The next step before you dive into a new kernel is to have a look at the output of "ps -ax" for /usr/sbin/apmd, if that is there then apm has been conpiled directly into the kernel and the problem lies somewhere else.
 
Old 07-02-2002, 09:15 PM   #7
JohnA
LQ Newbie
 
Registered: Dec 2000
Location: Ireland
Posts: 7

Original Poster
Rep: Reputation: 0
OK Aussie, here is the output from ps:

[jos@localhost Info]$ ps -ax | grep apm
3 ? SW 0:00 [kapmd]
1011 ? S 0:00 /usr/sbin/apmd -p 10 -w 5 -W -P /etc/sysconfig/apm-sc
6885 pts/3 S 0:00 grep apm
[jos@localhost Info]$

So, yes, /usr/sbin/apmd is running OK, but it's just that
apm is not listed using lsmod. Here is the lsmod output:

[root@localhost jos]# lsmod
Module Size Used by Tainted: P
ppp_deflate 42240 0 (autoclean)
bsd_comp 4544 0 (autoclean)
ppp_async 6560 1 (autoclean)
ppp_generic 19880 3 (autoclean) [ppp_deflate bsd_comp ppp_async]
slhc 5056 1 (autoclean) [ppp_generic]
sr_mod 15160 0 (autoclean)
es1371 26656 0
soundcore 4068 4 [es1371]
ac97_codec 9568 0 [es1371]
gameport 1756 0 [es1371]
lp 6464 0
parport_pc 22088 1
parport 23968 1 [lp parport_pc]
af_packet 12488 0 (autoclean)
scanner 8992 0 (unused)
usb-uhci 21668 0 (unused)
usbcore 59072 1 [scanner usb-uhci]
nls_iso8859-1 2816 1 (autoclean)
nls_cp437 4352 1 (autoclean)
vfat 9788 1 (autoclean)
fat 31384 0 (autoclean) [vfat]
ide-scsi 8032 0
scsi_mod 92488 2 [sr_mod ide-scsi]
rtc 5912 0 (autoclean)
[root@localhost jos]#

So, if the apmd process is running, do I also need
to get apm to appear in the lsmod list?

John.
 
Old 07-02-2002, 09:24 PM   #8
Aussie
Senior Member
 
Registered: Sep 2001
Location: Brisvegas, Antipodes
Distribution: Slackware
Posts: 4,590

Rep: Reputation: 56
No, it means that apm was compiled into the kernel instead of as a module, the next thing to do is check your bios and make sure that apm is not disabled there.
 
Old 07-03-2002, 06:57 PM   #9
JohnA
LQ Newbie
 
Registered: Dec 2000
Location: Ireland
Posts: 7

Original Poster
Rep: Reputation: 0
I checked the BIOS Power settings, and it makes no mention
of APM at all ( just wakeup on LAN and Modem stuff).
But, as I mentioned, Win 98 turns off the power after
shutdown. So, presumably, it just works and there is no
disable option for it. The Motherboard is an Intel D845W
with an Intel P4 1.7GHz processor. Any other thoughts?
John.
 
Old 08-11-2003, 05:41 AM   #10
ughh
LQ Newbie
 
Registered: Aug 2003
Location: Poland
Distribution: Debian
Posts: 1

Rep: Reputation: 0
I had remarkably similar problem on my Debian system running on a machine with Asus motherboard. First I thought that it's bios' fault however, after some research , I've found that using acpi instead of apm is a better idea at least on some systems. I've reconfigured the kernel, threw out all the apm stuff, under 'general setup' I've added 'acpi support', 'acpi bus', 'acpi system', and 'acpi button'. Don't know if all of it is required, don't know if it will work for you, but it solved my case, simple 'halt -p' turns off the system AND the power. Good luck.
 
Old 08-11-2003, 06:23 PM   #11
JohnA
LQ Newbie
 
Registered: Dec 2000
Location: Ireland
Posts: 7

Original Poster
Rep: Reputation: 0
The powerdown issue has now been fixed as follows:
Upgrade to Mandrake 9.1
In the Bootloader config, check the Enable APCI checkbox
(it is un-checked by default).

Thanks,
JohnA
 
Old 08-12-2003, 10:33 AM   #12
fabre
Member
 
Registered: Aug 2003
Location: Vancouver
Distribution: Debian Sid Amd64
Posts: 87

Rep: Reputation: 15
I had to disable APCI in order to install mandrake 9.1 otherwise it wouldn't install.

How can I get it to shutdown then?
 
Old 08-12-2003, 07:23 PM   #13
JohnA
LQ Newbie
 
Registered: Dec 2000
Location: Ireland
Posts: 7

Original Poster
Rep: Reputation: 0
Fabre, read my previous post again.
Did you try this suggestion?
Did you locate the ACPI Checkbox (in Mandrake
Control Center -> Bootloader config)
What happened when you checked it?

JohnA
 
Old 02-23-2005, 11:46 AM   #14
Ishkabibble
Member
 
Registered: Aug 2003
Location: Worcester MA
Distribution: Ubuntu 8.04
Posts: 120

Rep: Reputation: 15
John, I'm having the same problem. On mine, (Mandrake 10.1) the ACPI box is checked. Do I have to be logged in as root to check the other thing you mentioned?
 
Old 02-24-2005, 02:47 AM   #15
Ishkabibble
Member
 
Registered: Aug 2003
Location: Worcester MA
Distribution: Ubuntu 8.04
Posts: 120

Rep: Reputation: 15
OK, I must've done something right... It's working OK now. The only thing I changed between then and now is that I checked "Clean /tmp at each boot."
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Power off after shutdown dukeem Slackware 15 11-30-2010 11:08 AM
Shutdown and power off bwtoh Linux - Newbie 4 11-02-2006 03:48 PM
Mandrake 9.2 does not turn off power at shutdown dancro Mandriva 12 03-19-2004 07:41 AM
Shutdown could not power off satimis Debian 13 02-14-2004 12:05 PM
Shutdown with power button hriosm Linux - Hardware 4 06-06-2003 03:43 PM


All times are GMT -5. The time now is 05:08 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration