LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 12-23-2006, 06:07 AM   #1
majro
LQ Newbie
 
Registered: Dec 2006
Location: Bratislava, Slovakia
Distribution: Slackware 11.0
Posts: 6

Rep: Reputation: 0
OpenTTD 0.4.8, "make install" fails [SOLVED]


Hi,

I am trying to compile stable OpenTTD 0.4.8.
./configure and make went fine, with no errors, but when I run "make install" as root, it fails with this:
Code:
root@slackware:/home/majro/openttd-0.4.8# make install
Makefile:872: *** make install is highly experimental at his state and not tested very much - use at your own risk - to use run \"make install INSTALL:=1\" - make sure Makefile.config is set correctly up - run \"make upgradeconf\".  Stop.
Google found only 1 record, and even that was some unanswered post.

Thanks a lot...

Last edited by majro; 12-24-2006 at 06:56 AM.
 
Old 12-23-2006, 06:27 AM   #2
tramni1980
Member
 
Registered: Jul 2006
Location: Tübingen, Germany
Distribution: Slackware64-13.37
Posts: 737

Rep: Reputation: 37
did you run make prior to make install? I do not recommend
you running make install after make. Run checkinstall instead.
In this way you will create a Slackware package and you will
be able to uninstall it later. After checkinstall run installpkg as root to install it.
make sure to read the README and INSTALL files, there may be some useful hints there.
 
Old 12-23-2006, 06:37 AM   #3
majro
LQ Newbie
 
Registered: Dec 2006
Location: Bratislava, Slovakia
Distribution: Slackware 11.0
Posts: 6

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by tramni1980
did you run make prior to make install? I do not recommend
you running make install after make. Run checkinstall instead.
In this way you will create a Slackware package and you will
be able to uninstall it later. After checkinstall run installpkg as root to install it.
make sure to read the README and INSTALL files, there may be some useful hints there.
Yes, I have run "make" before "make install". At first I tried also "checkinstall", it gave me this error, so to exclude possible error of checkinstall I tried "make install", no matter I am not able to uninstall it later.
This error is very strange, I have never seen something like this before. Should I try to compile some different application? Just to see if this "make install" error does not occur also here?

The funny aspect is, that I don't think that "make install" is so highly experimental.
 
Old 12-24-2006, 05:34 AM   #4
tramni1980
Member
 
Registered: Jul 2006
Location: Tübingen, Germany
Distribution: Slackware64-13.37
Posts: 737

Rep: Reputation: 37
Did you see the installation instructions here:
http://openttd.teamjak.net/faq.php
there are some dependencies there listed and and some other tweaks you need to do to
be able to build from source.
To build source you need the following dependencies, and a working psp development environment:
pspsdk
zlib
libpng
SDL
SDL_mixer
 
Old 12-24-2006, 06:55 AM   #5
majro
LQ Newbie
 
Registered: Dec 2006
Location: Bratislava, Slovakia
Distribution: Slackware 11.0
Posts: 6

Original Poster
Rep: Reputation: 0
Tramni1980, you were right. There is no "make install" for this game . Just "make" and game is playable. I should have read the OpenTTD Wiki.
http://wiki.openttd.org/index.php/Compiling_on_Linux
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
So many errors when I typed the "make" and "make install" command Niceman2005 Linux - Software 23 07-22-2009 03:33 PM
window maker "make" / "make install" problem xiekke Fedora 2 08-08-2007 11:55 AM
Constant errors during "make" or "make install" with SUSE 10.1 Alpha 4 TehFlyingDutchman Linux - Software 3 12-30-2005 07:25 PM
Ndiswrapper install failure - LBA-Linux "make" command fails petteril Linux - Wireless Networking 1 04-23-2005 09:22 AM
When "make install clean" ports fails everytime! Devboy *BSD 9 08-11-2004 08:46 PM


All times are GMT -5. The time now is 07:51 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration