LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
LinkBack Search this Thread
Old 11-10-2004, 08:32 PM   #1
Niceman2005
Member
 
Registered: Nov 2004
Distribution: Fedora Core 2
Posts: 330

Rep: Reputation: 30
So many errors when I typed the "make" and "make install" command


Dear people,

I tried to install squidguard. However after using the comman "make" it generated many errors, which is shown below.

[root@matrix squidGuard-1.2.0]# make
making all in squidGuard-1.2.0
make[1]: Entering directory `/root/squidGuard-1.2.0/src'
making all in src
gcc -I.. -I. -I. -I/usr/local/BerkeleyDB/include -DHAVE_CONFIG_H -g -O2 -I/usr/local/BerkeleyDB/include -c main.c
gcc -I.. -I. -I. -I/usr/local/BerkeleyDB/include -DHAVE_CONFIG_H -g -O2 -I/usr/local/BerkeleyDB/include -c sgLog.c
gcc -I.. -I. -I. -I/usr/local/BerkeleyDB/include -DHAVE_CONFIG_H -g -O2 -I/usr/local/BerkeleyDB/include -c sgDb.c
sgDb.c: In function `sgDbInit':
sgDb.c:101: warning: passing arg 2 of pointer to function from incompatible pointer type
sgDb.c:101: warning: passing arg 4 of pointer to function makes pointer from integer without a cast
sgDb.c:101: error: too few arguments to function
sgDb.c:107: warning: passing arg 2 of pointer to function from incompatible pointer type
sgDb.c:107: warning: passing arg 4 of pointer to function makes pointer from integer without a cast
sgDb.c:107: error: too few arguments to function
make[1]: *** [sgDb.o] Error 1
make[1]: Leaving directory `/root/squidGuard-1.2.0/src'
make: *** [all] Error 1


[root@matrix squidGuard-1.2.0]# make install
making install.bin in squidGuard-1.2.0
cd src && make install.bin
make[1]: Entering directory `/root/squidGuard-1.2.0/src'
gcc -I.. -I. -I. -I/usr/local/BerkeleyDB/include -DHAVE_CONFIG_H -g -O2 -I/usr/local/BerkeleyDB/include -c sgDb.c
sgDb.c: In function `sgDbInit':
sgDb.c:101: warning: passing arg 2 of pointer to function from incompatible pointer type
sgDb.c:101: warning: passing arg 4 of pointer to function makes pointer from integer without a cast
sgDb.c:101: error: too few arguments to function
sgDb.c:107: warning: passing arg 2 of pointer to function from incompatible pointer type
sgDb.c:107: warning: passing arg 4 of pointer to function makes pointer from integer without a cast
sgDb.c:107: error: too few arguments to function
make[1]: *** [sgDb.o] Error 1
make[1]: Leaving directory `/root/squidGuard-1.2.0/src'
make: *** [install.bin] Error 2



anyone knows what is wrong ?
Thanks in advance!
 
Old 11-10-2004, 08:42 PM   #2
masand
Guru
 
Registered: May 2003
Location: INDIA
Distribution: Ubuntu, Solaris,CentOS
Posts: 5,522

Rep: Reputation: 57
hi there

make install won't work untill "make " goes fine

also did u run ./configure

have a look at the INTSALL or readme file in the source for more detalls

regards
 
Old 11-11-2004, 09:18 PM   #3
Niceman2005
Member
 
Registered: Nov 2004
Distribution: Fedora Core 2
Posts: 330

Original Poster
Rep: Reputation: 30
I did ./configure, it was the make part that has errors

Thanks!

But then I did ./configure which was ok.

Only when I got to make that it showed errors.
 
Old 11-11-2004, 10:28 PM   #4
foo_bar_foo
Senior Member
 
Registered: Jun 2004
Posts: 2,553

Rep: Reputation: 51
many many programms get hung up and need certain versions of BerkleyDB or the other
there are ways to keep a little collection of them around so everybody is happy
squidGuard page says it needs db-2.x
i guess check first to see if your distribution has a version of db-2 to install in some compatability function without disturbing the one you are running

if you try to build it yourself by all means use
cd build_unix &&
../dist/configure --prefix=/opt/db-2.x --enable-compat185

so as not to overwrite your current version then i think for the squidGuard config it would be something like
--with-db-lib=/opt/db-2.x/lib --with-db-inc=/opt/db-2.x/include
to point it in the right direction
 
Old 11-12-2004, 07:15 PM   #5
borrrden
Member
 
Registered: May 2004
Location: Philadelphia
Distribution: Fedora Core 3
Posts: 98

Rep: Reputation: 15
It's nothing you did, it's code that your system can't deal with on line 107 of /root/squidGuard-1.2.0/src/sgDb.c

specifically, the function sgDbInit(). The compiler wants more arguments in the function for some reason or another. Unless you are the author, I doubt you will fix it without a headache of effort in trying to find out what the author wanted that specific function to do. Especially if it is not commented code, it will be nearly impossible.

sorry to be the bearer of bad news
 
Old 11-12-2004, 07:21 PM   #6
Niceman2005
Member
 
Registered: Nov 2004
Distribution: Fedora Core 2
Posts: 330

Original Poster
Rep: Reputation: 30
Hi masand, foo_bar_foo and Borrden,

Thank you very much for the help.
I tried other tarball source code , the make command was ok .
Its more relieved to hear that its the author's fault then mine. Because I thought I kept making mistakes.

Once again, thanks!
 
Old 11-20-2004, 05:55 AM   #7
PersianPatient
LQ Newbie
 
Registered: Nov 2004
Posts: 9

Rep: Reputation: 0
Hi there

I have this problem too , I am new to linux networking .

Please tell me how can I finally fix this problem .

Best Regards,
The Persian Patient .
 
Old 11-20-2004, 11:30 PM   #8
PersianPatient
LQ Newbie
 
Registered: Nov 2004
Posts: 9

Rep: Reputation: 0
Done .

but not working !
 
Old 11-21-2004, 10:26 AM   #9
borrrden
Member
 
Registered: May 2004
Location: Philadelphia
Distribution: Fedora Core 3
Posts: 98

Rep: Reputation: 15
Huh? Can you post some output for us to work with?
 
Old 11-21-2004, 06:16 PM   #10
Niceman2005
Member
 
Registered: Nov 2004
Distribution: Fedora Core 2
Posts: 330

Original Poster
Rep: Reputation: 30
to PersianPatient

Hi PersianPatient,

The other guy in the Forum said it was because of the source code error. Its the author's error.
I didn't fix it at the end but I tried download the sourcecode from other source and it worked well.

try to dl the files from other source and try again.
 
Old 11-22-2004, 05:53 AM   #11
PersianPatient
LQ Newbie
 
Registered: Nov 2004
Posts: 9

Rep: Reputation: 0
Thank You .

I have installed the squidGuard on my linux server and configured it to block some domain , for example : sex.com and redirect to another URL but it dose not work .

it allows all domain to open .

please help me to block my unwanted domain .

Best Regards,
The Persian Patient .
 
Old 11-22-2004, 05:47 PM   #12
Niceman2005
Member
 
Registered: Nov 2004
Distribution: Fedora Core 2
Posts: 330

Original Poster
Rep: Reputation: 30
PersianPatient

Hello PersianPatient,

Regarding squidguard, I am also working on it now. i have just finished installing it and whenI started it it says ready to serve. But I have try to test it on any server machine. I am waiting for my administrator to put a dial up line for me to test it. If successful I will show you what I did, at the moment not sure if its successful, I don't want to give you wrong advice yet..

give me a few days.
 
Old 11-23-2004, 01:41 AM   #13
PersianPatient
LQ Newbie
 
Registered: Nov 2004
Posts: 9

Rep: Reputation: 0
Dear Niceman2005

Thank you for your attention . I am waiting for your answer .

Thank you my friend .
The Persian Patient .
 
Old 11-23-2004, 06:29 PM   #14
Niceman2005
Member
 
Registered: Nov 2004
Distribution: Fedora Core 2
Posts: 330

Original Poster
Rep: Reputation: 30
hello Persian patient

Hello Persian patient,

I got stucked when I tried to enable squidguard as redirect_program in the squid configuration file. for some reason it everything don't work after I changed the redirect_program to my squidguard path.

all the squid commands such as squid -k reconfigure, service squid restart gave me msgs like "abort","fatal error permission denied" etc....

I am not sure why...hope I can figure that out.
sorry about that, didn't help youmuch.
 
Old 11-23-2004, 11:47 PM   #15
PersianPatient
LQ Newbie
 
Registered: Nov 2004
Posts: 9

Rep: Reputation: 0
Hello dear Niceman2005 ;

You may need to reconfigure your squidguard.conf file . if you have this problem again , take a look at your squidguard log file .

if you have permission denied error message you need to assign permission to user that you set in your configuration file .

please copy and paste your error messages here .

GoodLuck,
The Persian Patient .
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
problem "make"ing gtk+ "/usr/bin/env: perl -w" caid Linux - Newbie 8 07-29-2005 04:51 AM
How to install "make" command from rpm on cd 2 - red hat linux 7.0 ZARGON Linux - Newbie 2 08-31-2004 10:53 AM
LFS 4.1: Stalled at Perl, "missing seperator" error from "make" SparceMatrix Linux From Scratch 1 06-07-2003 03:31 PM
Why the errors occur after I used "make" command? Xiangbuilder Linux - Hardware 0 04-03-2003 01:12 AM
installing mplayer...... problems occured when "make" was typed.... kublador Linux - General 5 02-22-2003 08:19 AM


All times are GMT -5. The time now is 09:04 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration