LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 07-10-2013, 12:07 AM   #1
NewtonIX
Member
 
Registered: Oct 2003
Location: Colorado
Distribution: SLackware 14
Posts: 56

Rep: Reputation: 16
NVIDIA and ACPI Boot issues


I have been using slack for my servers for over a decade now and a couple months ago I decided to use it as my desktop for the first time.
Everything is perfect except I have to set acpi=off kernel option in order for it to boot.

I would like to enable acpi so my machine will actually shutdown

Attached is a screenfetch with some basic info, I am running 14.0, everything is updated and I am running nvidia 325.08 (beta) drivers, I have also tried their latest stable release with no difference.

I also included a terrible photo of my boot screen with acpi on (it was taken with an ipad). I caught a message about Nvidia Tainting the kernel before the video went haywire as shown at one point, hence the reason I think its a video card/Driver issue that is causing it. I have also tried using vga=normal and it doesn't botch the screen as shown but it will eventually just lockup and it is at different points in the boot process so it is no real indication as to why its locking up.

Just to re-iterate, with acpi=off it boots just fine and I know acpi is supported by my board. I have even tried to two different acpi bios settings and no difference.

I know my way around Slack, at least until i go to init 4 lol
So dont be shy, if im making some noob mistake let me know


Here is my lilo.conf currently ( w/o the acpi=off )

Code:
# LILO configuration file
# generated by 'liloconfig'
#
# Start LILO global section
boot = /dev/sda
compact        # faster, but won't work on all systems.
# Boot BMP Image.
# Bitmap in BMP format: 640x480x8
  bitmap = /boot/slack.bmp
# Menu colors (foreground, background, shadow, highlighted
# foreground, highlighted background, highlighted shadow):
  bmp-colors = 255,0,255,0,255,0
# Location of the option table: location x, location y, number of
# columns, lines per column (max 15), "spill" (this is how many
# entries must be in the first column before the next begins to
# be used.  We don't specify it here, as there's just one column.
  bmp-table = 60,6,1,16
# Timer location x, timer location y, foreground color,
# background color, shadow color.
  bmp-timer = 65,27,0,255
# Standard menu.
# Or, you can comment out the bitmap menu above and
# use a boot message with the standard menu:
#message = /boot/boot_message.txt

# Append any additional kernel parameters:
append=" vt.default_utf8=0 raid=noautodetect rootfstype=ext4"
prompt
timeout = 80
# VESA framebuffer console @ 1024x768x64k
vga = 842 
# Normal VGA console
#vga = normal
# Ask for video mode at boot (time out to normal in 30s)
# vga = ask
# VESA framebuffer console @ 1024x768x64k
# vga=791
# VESA framebuffer console @ 1024x768x32k
# vga=790
# VESA framebuffer console @ 1024x768x256
# vga=773
# VESA framebuffer console @ 800x600x64k
# vga=788
# VESA framebuffer console @ 800x600x32k
# vga=787
# VESA framebuffer console @ 800x600x256
# vga=771
# VESA framebuffer console @ 640x480x64k
# vga=785
# VESA framebuffer console @ 640x480x32k
# vga=784
# VESA framebuffer console @ 640x480x256
# vga=769
# ramdisk = 0     # paranoia setting
# End LILO global section
# Linux bootable partition config begins
image = /boot/vmlinuz
  root = /dev/sda3
  label = Slackware
  read-only  # Partitions should be mounted read-only for checking
# Linux bootable partition config ends
# Windows bootable partition config begins
other = /dev/sda1
  label = WindBlowz
  table = /dev/sda
# Windows bootable partition config ends
Attached Images
File Type: jpg Stats.jpg (179.4 KB, 23 views)
File Type: jpg IMG_0501.jpg (254.3 KB, 22 views)
 
Old 07-10-2013, 02:07 AM   #2
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 3,461

Rep: Reputation: 852Reputation: 852Reputation: 852Reputation: 852Reputation: 852Reputation: 852Reputation: 852
Have you tried debugging the ACPI problem? https://wiki.ubuntu.com/DebuggingACPI
 
Old 07-10-2013, 07:12 AM   #3
elesmod
Member
 
Registered: Sep 2012
Distribution: Slackware
Posts: 84

Rep: Reputation: Disabled
I have a Gigabyte motherboard that refuses to boot many distributions unless I pass acpi=off. After some searching I've found another option that I can pass instead of the acpi one. Now I use
Code:
pci=nocrs
and suspending my machine works fine. I'm not really sure what that option does, but I haven't noticed any drawbacks.
 
Old 07-10-2013, 12:20 PM   #4
NewtonIX
Member
 
Registered: Oct 2003
Location: Colorado
Distribution: SLackware 14
Posts: 56

Original Poster
Rep: Reputation: 16
Thanks I have tried all kinds of work arounds and options but havent tried either of those
I will give them both a run tonight
 
Old 07-10-2013, 01:38 PM   #5
kingbeowulf
Member
 
Registered: Oct 2003
Location: WA
Distribution: Slackware64 14.1, Slackware 14.1
Posts: 523

Rep: Reputation: 140Reputation: 140
Same issue with nouveau? Did you BLACKLIST nouveau? (see /extra) Just loading Nvidia does not unload nouveau - esp. on huge kernel. vga=normal is recommended since Nvidia requires a text mode kernel, not vesafb etc.

Also, try using the generic kernel via an initrd. That might point to which module is the root cause. Check /var/log/dmesg, /var/log/messages/ and /var/log/syslog Remember, will all your cores, it might "look" like the error occurs in different places in the boot process....

Other append="" parameters to try:

noapm (should be deprecated but you never know)
noapic
nomodeset

and others in the link allend posted above.
 
Old 07-10-2013, 03:49 PM   #6
number22
Member
 
Registered: Sep 2006
Location: Earth
Distribution: Slackware 14.1 Slackware64-current multilib
Posts: 188
Blog Entries: 1

Rep: Reputation: 38
try nopat kernel flag and always blacklist nouveau if you use nvidia proprietary driver.
 
Old 07-11-2013, 12:17 AM   #7
NewtonIX
Member
 
Registered: Oct 2003
Location: Colorado
Distribution: SLackware 14
Posts: 56

Original Poster
Rep: Reputation: 16
I sat down and prepared myself for a long session of reboots to try all these kernel flags but decided to first blacklist nouveau since it aparently needs to be either way.
Sure enough after blacklisting that module it booted with not issues with acpi on

Thank you everyone for you help
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Power Issues, vanilla ubuntu kernel, (acpi etc) acpi -V outputs etc jamescondron Linux - Laptop and Netbook 1 02-16-2009 10:48 AM
ACPI issues / Boot Hangups in Slackware Distros kiwisaotome Linux - Laptop and Netbook 5 09-13-2008 07:27 AM
nVidia Nforce4 RAID-1 Boot Issues emrecio Linux - Hardware 1 06-13-2008 06:53 PM
ACPI Issues? kushalkoolwal Linux - Hardware 3 08-15-2007 03:05 PM
issues with boot and nvidia geforce fx5700 mrchaos Linux - Hardware 1 04-18-2005 07:49 PM


All times are GMT -5. The time now is 07:52 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration