LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 07-25-2012, 10:30 AM   #16
a4necromant
Member
 
Registered: Jul 2012
Location: Belarus (A country near Russia, a repoblic of former USSR)
Distribution: slackware 13.47 x64
Posts: 39

Original Poster
Rep: Reputation: Disabled

Quote:
Originally Posted by H_TeXMeX_H View Post
You can make a simple xorg.conf:
Code:
Section "Device"
    Identifier     "intel"
    Driver         "intel"
    VendorName     "Intel Corporation"
EndSection
It doesn't work.
---
After the installation, before I tried to install nvidea driver, 2D worked and x-system worked too. But now only terminal mod.
If there will be some way to restore default x-window parameters, all will be perfect. But I don't know how to restore thiese parameters......
 
Old 07-25-2012, 10:35 AM   #17
H_TeXMeX_H
Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269
If it worked before it was probably using nouveau, so just delete /etc/X11/xorg.conf and let it handle everything.
 
1 members found this post helpful.
Old 07-25-2012, 12:46 PM   #18
T3slider
Senior Member
 
Registered: Jul 2007
Distribution: Slackware64-14.1
Posts: 2,252

Rep: Reputation: 631Reputation: 631Reputation: 631Reputation: 631Reputation: 631Reputation: 631
The nVidia proprietary driver overwrites some system files. You may have to reinstall xorg-server and mesa to restore the original xorg files. I think in theory the nVidia installer backs these files up to /var/lib/nvidia and when uninstalling should copy them back, so perhaps this is not the issue...but to make sure that X is fully restored it couldn't hurt to reinstall xorg-server and mesa. Then try messing around with xorg.conf.
 
1 members found this post helpful.
Old 07-25-2012, 01:48 PM   #19
Didier Spaier
Senior Member
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slackware{,64}-{14.1,current} on a Lenovo Thinkpad T61 6457-4XG
Posts: 4,235

Rep: Reputation: 1040Reputation: 1040Reputation: 1040Reputation: 1040Reputation: 1040Reputation: 1040Reputation: 1040Reputation: 1040
The problem is that when you start X on a computer with a hybrid graphics you can hardly know which graphical processor will be active.

But there is a very simple workaround which is fallback to the "vesa" driver, as both Intel and nVidia chipsets should comply to the vesa standard.

So do this:

1) Get rid of any config files (whose name end in .conf) in /etc/X11 and /etc/X11/xorg.conf.d in removing it or renaming it (so the name don't end in .conf anymore).
You may keep files copied from /usr/share/X11/xorg.conf.d though if any.

2) As root type:
Code:
cd /etc/X11
mv xorg.conf-vesa xorg-vesa.conf
3) Before rebooting, edit lilo.conf to have
Code:
vga=normal
and in the image section add a line with
Code:
append="nomodeset"
then run: "lilo -t -v" and if all goes well: "lilo"

If you prefer, you can append aforementioned kernel parameters to lilo's command line. Hit Tab when you see lilo's greeting screen and type this for instance
Code:
Linux vga=normal nomodeset
You should then have X working though without hardware acceleration and may be with a different definition than the one you would have expected.

And to make sure what are your graphical processors please post the output of following command:
Code:
lspci -k | grep -A3 VGA

Last edited by Didier Spaier; 07-25-2012 at 01:59 PM.
 
1 members found this post helpful.
Old 07-26-2012, 01:04 AM   #20
a4necromant
Member
 
Registered: Jul 2012
Location: Belarus (A country near Russia, a repoblic of former USSR)
Distribution: slackware 13.47 x64
Posts: 39

Original Poster
Rep: Reputation: Disabled
thankyou Didier Spaier, your method is working.

---
(Graffical effects still not working. but I think they will work after I will install bumblebee)
 
Old 07-26-2012, 02:08 AM   #21
a4necromant
Member
 
Registered: Jul 2012
Location: Belarus (A country near Russia, a repoblic of former USSR)
Distribution: slackware 13.47 x64
Posts: 39

Original Poster
Rep: Reputation: Disabled
Faled to install bumblebee. It doesn't work.
Brings an error:
Code:
[error] The bumblebee demon has not been started yet or the socket pass /var/run/bumblebee.socket was incorrect
[error] Could not connect to bublebee daemon - is it running?
 
Old 07-26-2012, 02:52 AM   #22
Didier Spaier
Senior Member
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slackware{,64}-{14.1,current} on a Lenovo Thinkpad T61 6457-4XG
Posts: 4,235

Rep: Reputation: 1040Reputation: 1040Reputation: 1040Reputation: 1040Reputation: 1040Reputation: 1040Reputation: 1040Reputation: 1040
Vesa is a very basic driver, so it's normal that you don't get graphical effects with it.

The goal of this first step was only to get you a working display under X.

Next step will be to use a driver with more features, but to give you further guidance please post the output of:
Code:
lspci -k | grep -A3 VGA
EDIT To be complete, please attach file /var/log/Xorg.0.log (renamed as xlog.txt if needed) to your next post.

Last edited by Didier Spaier; 07-26-2012 at 03:11 AM. Reason: EDIT added
 
Old 07-26-2012, 04:09 AM   #23
a4necromant
Member
 
Registered: Jul 2012
Location: Belarus (A country near Russia, a repoblic of former USSR)
Distribution: slackware 13.47 x64
Posts: 39

Original Poster
Rep: Reputation: Disabled
Exclamation

here is an output from terminal:
Code:
root@darkstar:~# lspci -k | grep -A3 VGA
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
        Subsystem: Samsung Electronics Co Ltd Device c606
        Kernel driver in use: i915
        Kernel modules: i915
Attached Files
File Type: txt Xorg.0.log.old.txt (23.7 KB, 1 views)
 
Old 07-26-2012, 04:38 AM   #24
Didier Spaier
Senior Member
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slackware{,64}-{14.1,current} on a Lenovo Thinkpad T61 6457-4XG
Posts: 4,235

Rep: Reputation: 1040Reputation: 1040Reputation: 1040Reputation: 1040Reputation: 1040Reputation: 1040Reputation: 1040Reputation: 1040
These output shows that you don't have a nVidia GeForceŽ GT 520MX card, but only an Intel integrated graphic processor and it is *not* an Optimus model, unless the nVidia card (if any) be completely disabled. May be you can check if there is a BIOS setting or a physical switch for that?

By the way, what make you think you have a nVidia card? is it stated on some spec, or did you check by yourself?

Chances are you shouldn't have installed the nVidia driver at all.

If I am correct, just reinstall mesa and xorg-server as suggested by T3slider.

I remind you that the command to do that is:
upgradepkg --reinstall <package_name>

EDIT. For this to work, you should rename xorg-vesa.conf as xorg.conf-vesa otherwise the vesa driver will still be used.

Last edited by Didier Spaier; 07-26-2012 at 04:53 AM. Reason: EDIT ...
 
Old 07-26-2012, 05:24 AM   #25
a4necromant
Member
 
Registered: Jul 2012
Location: Belarus (A country near Russia, a repoblic of former USSR)
Distribution: slackware 13.47 x64
Posts: 39

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by Didier Spaier View Post
May be you can check if there is a BIOS setting or a physical switch for that?
There is no switch in bios

Quote:
By the way, what make you think you have a nVidia card? is it stated on some spec, or did you check by yourself?
I know, that I have Nvidea card. In win7 Nvidea driver is downloading automatically. I have checked a lot. There is also an nvidea optimus logo on these notebook(you can see it in attach)....
(These notebook is designed by imperialists and capitalists to run the only one type of OS - Windows NT, by the way I have these problem)
----
After I installed OS on notebook all effects worked, 3D graffics was not warking. Now after all these manipulations I haven't got 2D graffical effects too....
Attached Images
File Type: jpg IMAG0041.jpg (252.8 KB, 12 views)

Last edited by a4necromant; 07-26-2012 at 05:32 AM.
 
Old 07-26-2012, 06:59 AM   #26
Didier Spaier
Senior Member
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slackware{,64}-{14.1,current} on a Lenovo Thinkpad T61 6457-4XG
Posts: 4,235

Rep: Reputation: 1040Reputation: 1040Reputation: 1040Reputation: 1040Reputation: 1040Reputation: 1040Reputation: 1040Reputation: 1040
Unhappy

As lspci only shows the Intel graphical processor, then sorry but I am out of ideas.

I suggest you just reinstall mesa, xorg-server and libdrm, make sure nouveau be not blacklisted in /etc/modprobe.conf/*.conf, rename xorg-vesa.conf as xorg.conf-vesa, and make sure you (re)start the system without the "nomodeset" parameter.

At least you should get back the level of performance you had at time of install.

But maybe somebudddy has a better idea?

PS If you issue following command:
Code:
lspci -vnn | grep '\''[030[02]\]'
You should see two lines, one for Intel and one for nVidia. Is that right?

To know more, see here.

Last edited by Didier Spaier; 07-26-2012 at 07:18 AM.
 
1 members found this post helpful.
Old 07-26-2012, 08:09 AM   #27
a4necromant
Member
 
Registered: Jul 2012
Location: Belarus (A country near Russia, a repoblic of former USSR)
Distribution: slackware 13.47 x64
Posts: 39

Original Poster
Rep: Reputation: Disabled
yes, it's right
Code:
root@darkstar:~# lspci -vnn | grep '\''[030[02]\]'
00:02.0 VGA compatible controller [0300]: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller [8086:0116] (rev 09) (prog-if 00 [VGA controller])
01:00.0 3D controller [0302]: nVidia Corporation Device [10de:1051] (rev a1)
but how will it help me. As I recognized from Samsung support, there are no official drivers for linux for thiese notebook...

Last edited by a4necromant; 07-26-2012 at 08:12 AM.
 
Old 07-26-2012, 08:41 AM   #28
Didier Spaier
Senior Member
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slackware{,64}-{14.1,current} on a Lenovo Thinkpad T61 6457-4XG
Posts: 4,235

Rep: Reputation: 1040Reputation: 1040Reputation: 1040Reputation: 1040Reputation: 1040Reputation: 1040Reputation: 1040Reputation: 1040
Last resort, you could try the recently released 304.22 BETA driver from nVidia.
 
Old 07-26-2012, 12:45 PM   #29
H_TeXMeX_H
Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269
Something interesting I found recently, but not for your laptop:
https://sites.google.com/site/mtrons/projects/eee1015pn

If you can only see the Intel card in lspci, maybe it is that the nvidia card is completely disabled. I'm not sure how to enable it, but you could try using acpi_call somehow. The link above is specific to my netbook, so I doubt the commands there will work, it's just an example.
 
1 members found this post helpful.
Old 07-26-2012, 02:15 PM   #30
Didier Spaier
Senior Member
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slackware{,64}-{14.1,current} on a Lenovo Thinkpad T61 6457-4XG
Posts: 4,235

Rep: Reputation: 1040Reputation: 1040Reputation: 1040Reputation: 1040Reputation: 1040Reputation: 1040Reputation: 1040Reputation: 1040
@H TeXMeX H: In fact the card do show in lspci, not as a "VGA compatible controller" but as a "3D controller". That's my fault somehow, as I suggested to pipe the output to "grep VGA" first.

Anyhow, a4necromant could try bumblebee, but he seems to be more interested by graphical performance than by power saving at the moment, that's why I suggested him to try the beta nVidia driver first.

Would he be satisfied with it, he could then try again bumblebee as it is supposed to be able to cooperate with he blob as well as with nouveau, according to their supported drivers page.

I notice though this warning on the same page:
Quote:
WARNING:You must install the Nvidia binaries in a way that won't break Mesa's LibGL, it's needed for 3D acceleration on the intel card. This means that on most distros you will need a Bumblebee specific package for it to run, the stock packages on most cases will break LibGL. See #33
Unfortunately, I didn't find at what this "#33" refer.

Anyway, if you have bumblebee installed on your Slackware, maybe you could help the OP to install it as he had a problem running it (see his post #21).

Last edited by Didier Spaier; 07-26-2012 at 02:26 PM.
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Bluetooth on Samsung 300E5A a4necromant Slackware 1 07-24-2012 10:33 AM
[SOLVED] wifi on Samsung 300E5A a4necromant Slackware 5 07-24-2012 10:01 AM
Linux on Samsung M70 Notebook Tolot Linux - Laptop and Netbook 6 02-20-2006 02:45 PM
Have MSI NVIDEA FX 5500 TD256 card works good but I cant get the TV out stargazer121 Linux - Newbie 1 06-17-2005 09:57 PM
Nvidea drivers with suse 9.1 compatible with ati card? oily_rags Linux - Hardware 1 09-15-2004 02:09 AM


All times are GMT -5. The time now is 04:50 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration