LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 05-25-2009, 09:22 AM   #1
[GOD]Anck
Member
 
Registered: Dec 2003
Location: The Netherlands
Distribution: Slackware
Posts: 171

Rep: Reputation: 33
nfs4 support


Does Slackware 12.2 have any nfs4 support at all? /sbin/mount.nfs4 seems to be missing, and mount -t nfs4 gives an "unknown filesystem type" error..?
 
Old 05-25-2009, 11:03 AM   #2
onebuck
Moderator
 
Registered: Jan 2005
Location: Midwest USA, Central Illinois
Distribution: SlackwareŽ
Posts: 11,122
Blog Entries: 3

Rep: Reputation: 1404Reputation: 1404Reputation: 1404Reputation: 1404Reputation: 1404Reputation: 1404Reputation: 1404Reputation: 1404Reputation: 1404Reputation: 1404
Hi,

From 'man nfs';

Quote:
NAME
nfs - fstab format and options for the nfs and nfs4 file systems

SYNOPSIS
/etc/fstab

DESCRIPTION
NFS is an Internet Standard protocol created by Sun Microsystems in
1984. NFS was developed to allow file sharing between systems residing
on a local area network. The Linux NFS client supports three versions
of the NFS protocol: NFS version 2 [RFC1094], NFS version 3 [RFC1813],
and NFS version 4 [RFC3530].
I believe that the support is contained/supported by '/sbin/mount.nfs'. You could try the 'auto' to see if it works. You are certain that it is a nfs4 filesystem?
 
Old 05-25-2009, 12:52 PM   #3
[GOD]Anck
Member
 
Registered: Dec 2003
Location: The Netherlands
Distribution: Slackware
Posts: 171

Original Poster
Rep: Reputation: 33
Yes, I'm sure.. I mounted the same filesystem on a Debian box using mount -t nfs4 and /bin/mount showed me:

Code:
10.0.0.17:/data on /mnt/data type nfs4 (rw,addr=10.0.0.17)
When I try from my Slackware box with mount -t auto, it tells me:

Code:
mount: special device 10.0.0.17:/data does not exist
When I try with mount -t nfs I get access denied and the server log complains:

Code:
May 25 19:31:05 s17 mountd[3869]: refused mount request from 10.0.0.26 for /data (/): not exported
mountd shouldn't even be involved in an nfs4 mount, right? So mount -t nfs probably tried to use v3 instead, and failed.

EDIT:

Looked at my kernel config, it seems the default is:

Code:
# CONFIG_NFS_V4 is not set
CONFIG_NFSD_V4=y
Kind of strange that the default has v4 server enabled, but not client, but okay.. on the off chance, I recompiled my kernel with CONFIG_NFS_V4=y, and also reinstalled the nfs-utils package, but neither made any difference.

Last edited by [GOD]Anck; 05-25-2009 at 01:01 PM.
 
Old 05-25-2009, 03:26 PM   #4
[GOD]Anck
Member
 
Registered: Dec 2003
Location: The Netherlands
Distribution: Slackware
Posts: 171

Original Poster
Rep: Reputation: 33
Found my answer in the nfs-utils.SlackBuild, nfs4 support is in fact disabled:

Quote:
# No NFSv4 yet -- it requires additional libraries.
I'll have to build my own then.
 
Old 05-25-2009, 05:33 PM   #5
[GOD]Anck
Member
 
Registered: Dec 2003
Location: The Netherlands
Distribution: Slackware
Posts: 171

Original Poster
Rep: Reputation: 33
For reference, and in case nfs4 support doesn't make it into the next Slackware, here's how to add your own, quick and dirty:
  • Download, configure && make && make install libevent and libnfsidmap, find them at citi
  • Grab the nfs-utils slackbuild and sources from your favorite mirror. Edit the slackbuild, s/--enable-nfsv4=no/--enable-nfsv4/g, comment out line 103 (rm -rf $PKG/sbin/*nfs4), build and install the nfs-utils package
  • Recompile your kernel with CONFIG_NFS_V4=y
  • modprobe nfs, this doesn't get autoloaded for some reason
  • mount -t nfs4 your.nfs4.server:/path /mnt/point (if you don't specify -t, mount will try nfsv3 instead)
 
Old 05-25-2009, 07:54 PM   #6
onebuck
Moderator
 
Registered: Jan 2005
Location: Midwest USA, Central Illinois
Distribution: SlackwareŽ
Posts: 11,122
Blog Entries: 3

Rep: Reputation: 1404Reputation: 1404Reputation: 1404Reputation: 1404Reputation: 1404Reputation: 1404Reputation: 1404Reputation: 1404Reputation: 1404Reputation: 1404
Hi,

I don't use nfs4 at this time but it's good that you found the solution.

Thanks for posting back.
 
Old 11-04-2011, 05:59 PM   #7
camerabambai
Member
 
Registered: Mar 2010
Distribution: Slackware
Posts: 40

Rep: Reputation: 0
Nfs4 works fine on Slackware 13.37
someone know how to set autofs?
 
Old 11-28-2011, 02:54 PM   #8
hpfeil
Member
 
Registered: Nov 2010
Location: Tucson, Arizona US
Distribution: Slackware Current, custom kernel, amd64, Beyond LinuxFromScratch
Posts: 130
Blog Entries: 1

Rep: Reputation: Disabled
Tried to mount an NFSv4 export from a HPC server so I could ramp up openmpi on multiple boxen.
mount.nfs: an incorrect mount option was specified
Checking the SlackBuild configure, "--enable-nfsv4=no" is still in Slackware Current (nfs-utils-1.2.3-x86_64-3). This after spending some time trying to figure out why the directory /var/lib/nfs/v4recovery was missing. If I ssh to the cluster, I can mount /home/hpc1, mpirun appears to work, but I'm rewriting the cpu/core inventory to include the cpuid info (the processes could all be running on the 4 cores on that box). Farther down in nfs-utils.SlackBuild:

# No NFSv4 yet, so remove these:
rm -f $PKG/sbin/*nfs4

provides another clue. Which libraries are missing? I'll try to configure and make the source with nfs4 enabled, maybe ldd will say what's missing?
I know the Slackware Team has their plate full, so we need to pitch in and help in such matters. Current file list has 3148 packages to manage.
`bzcat MANIFEST.bz2 | wc -l` is up to 376,576 files, not that anyone installs everything.
 
Old 11-29-2011, 07:59 AM   #9
camerabambai
Member
 
Registered: Mar 2010
Distribution: Slackware
Posts: 40

Rep: Reputation: 0
libnfsidmap is the first needed
 
Old 11-29-2011, 08:08 AM   #10
camerabambai
Member
 
Registered: Mar 2010
Distribution: Slackware
Posts: 40

Rep: Reputation: 0
libgssglue is another one
librpcsecgss another one

Last edited by camerabambai; 11-29-2011 at 08:14 AM.
 
Old 11-29-2011, 08:24 AM   #11
camerabambai
Member
 
Registered: Mar 2010
Distribution: Slackware
Posts: 40

Rep: Reputation: 0
Try to recompile but

checking for krb5_get_error_message in -lgssapi_krb5... yes
checking for krb5_get_init_creds_opt_set_addressless in -lgssapi_krb5... no
checking for authgss_create_default in -lrpcsecgss... no
configure: error: librpcsecgss not found.
make: *** Nessun obiettivo specificato e nessun makefile trovato. Stop.
make: *** Nessun obiettivo specificato e nessun makefile trovato. Stop.

Of course i had installed librpcsecgss
 
Old 11-29-2011, 12:10 PM   #12
camerabambai
Member
 
Registered: Mar 2010
Distribution: Slackware
Posts: 40

Rep: Reputation: 0
http://canich.net/slackware/krb5.html

Probably found solution
 
Old 11-29-2011, 12:34 PM   #13
camerabambai
Member
 
Registered: Mar 2010
Distribution: Slackware
Posts: 40

Rep: Reputation: 0
checking for unistd.h... yes
checking for clnt_tli_create in -ltirpc... no
configure: error: libtirpc not found.

 
Old 12-03-2011, 06:20 PM   #14
camerabambai
Member
 
Registered: Mar 2010
Distribution: Slackware
Posts: 40

Rep: Reputation: 0
With tirpc package from ponce.cc and other packages listed
in canick.net works fine.
 
Old 12-03-2011, 07:39 PM   #15
camerabambai
Member
 
Registered: Mar 2010
Distribution: Slackware
Posts: 40

Rep: Reputation: 0
Nfs4 works fine
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
packages required for NFS4? cool47 Red Hat 1 03-19-2008 09:42 PM
NFS4 group enumeration utahnix Linux - Networking 0 01-31-2007 04:00 PM
how can I deploy a nfs4 server? dirtgod Linux - Networking 1 12-16-2006 09:53 PM
acl and Nfs4 collen Linux - Networking 0 09-30-2004 07:58 AM
Nfs4 not work.. collen Linux - Networking 0 09-02-2004 03:23 AM


All times are GMT -5. The time now is 10:40 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration