LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 10-03-2012, 03:07 PM   #1
Habitual
Senior Member
 
Registered: Jan 2011
Distribution: Slack14_64_Multilib
Posts: 3,040
Blog Entries: 4

Rep: Reputation: 734Reputation: 734Reputation: 734Reputation: 734Reputation: 734Reputation: 734Reputation: 734
My dog ate my WiFi...


OK, but seriously...
I have this card:
Code:
03:00.0 Network controller: Broadcom Corporation BCM4321 802.11a/b/g/n (rev 01)
It was working after I followed this posts' suggestion(s) by installing these:
Code:
ll -1 /var/log/packages/ | egrep "b43|wicd"
-rw-r--r--  1 root root    2612 Oct  3 12:34 b43-firmware-5.10.56.27.3-fw-1_SBo
-rw-r--r--  1 root root     831 Oct  3 12:34 b43-fwcutter-014-i486-1_SBo
-rw-r--r--  1 root root   13813 Oct  3 12:42 wicd-1.7.2.4-i486-4
and then edited /etc/modprobe.d/b43_blacklist.conf and added:
Code:
blacklist b43
blacklist b43legacy
blacklist bcma
blacklist ssb
and rebooted. And it was working. I am not sure how I managed to break it after that. I did a couple of reboots after editing the blacklist, but AFAICT, it only worked after the install and the first reboot...

I installed wicd with
Code:
slackpkg install wicd
I have read AlienBob's "Configuring your network in Slackware" where it suggests editing /etc/rc.d/rc.inet1.conf which mine has these relative entries which were added by me after it quit working:
Code:
IFNAME[4]="wlan0"
IPADDR[4]="192.168.1.2"
NETMASK[4]="255.255.255.0"
USE_DHCP[4]="yes"
GATEWAY="192.168.1.1"
WLAN_ESSID[4]=got_milk
(yes, I have a router and I use ACLs for security and the MAC address is in the allow list)

/etc/udev/rules.d/70-persistent-net.rules | grep wlan0 has these details...
Code:
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="00:16:cf:b4:5c:c3", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="wlan*", NAME="wlan0"
I am pretty sure I ran a dhcpcd command somewhere, but I can't remember the exact command and my root history doesn't show it either.

At no time did I ever run
Code:
/etc/rc.d/rc.wireless
/var/log/messages has numerous entries such as:
Code:
Oct  3 13:05:38 My-KungFu kernel: [ 1228.055189] ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
Oct  3 13:05:42 My-KungFu kernel: [ 1231.643911] ADDRCONF(NETDEV_UP): wlan0: link is not ready
I removed wicd and re-installed and rebooted. "No wireless networks found" says wicd and "no wireless extensions." says iwconfig.

I'm tired of rebooting

Thank you all for your time.

Last edited by Habitual; 10-03-2012 at 03:09 PM. Reason: added links to post and bob's wiki...
 
Old 10-03-2012, 03:09 PM   #2
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,175

Rep: Reputation: Disabled
If you want to use WICD then please remove all network configuration from /etc/rc.d/rc,inet1.conf - thr two will conflict. Also, you have to tell WICD the name of your wireless interface - it probably does not yet know that it is "wlan0".

Eric
 
Old 10-03-2012, 03:12 PM   #3
Habitual
Senior Member
 
Registered: Jan 2011
Distribution: Slack14_64_Multilib
Posts: 3,040
Blog Entries: 4

Original Poster
Rep: Reputation: 734Reputation: 734Reputation: 734Reputation: 734Reputation: 734Reputation: 734Reputation: 734
Thanks Bob.

Man, you are quick!

Edit0: Thanks Eric!

Edit1: reboot (sigh)?

Last edited by Habitual; 10-03-2012 at 03:14 PM.
 
Old 10-03-2012, 03:34 PM   #4
FeyFre
Member
 
Registered: Jun 2010
Location: Ukraine, Vinnitsa
Distribution: Slackware
Posts: 307

Rep: Reputation: 22
Quote:
Edit1: reboot (sigh)?
It is enough to down interface and then restart wicd.
 
Old 10-03-2012, 03:42 PM   #5
Habitual
Senior Member
 
Registered: Jan 2011
Distribution: Slack14_64_Multilib
Posts: 3,040
Blog Entries: 4

Original Poster
Rep: Reputation: 734Reputation: 734Reputation: 734Reputation: 734Reputation: 734Reputation: 734Reputation: 734
ifconfig or iwconfig doesn't show any wlan0, still.

I bounced /usr/sbin/wicd anyway. same same.
 
Old 10-03-2012, 06:59 PM   #6
turtleli
Member
 
Registered: Aug 2012
Location: UK
Distribution: Slackware 14.1
Posts: 128

Rep: Reputation: Disabled
If wlan0 does not appear in ifconfig/iwconfig it is unlikely to have anything to do with wicd.

It is a bit unclear which driver you are attempting to use. Are you trying to use b43 or wl? I think wl might be the better driver for your wireless card as this says that b43 only partially supports it.

Just in case, did you try to modprobe whatever driver you are using?
 
Old 10-03-2012, 07:29 PM   #7
Habitual
Senior Member
 
Registered: Jan 2011
Distribution: Slack14_64_Multilib
Posts: 3,040
Blog Entries: 4

Original Poster
Rep: Reputation: 734Reputation: 734Reputation: 734Reputation: 734Reputation: 734Reputation: 734Reputation: 734
Quote:
Originally Posted by turtleli View Post
If wlan0 does not appear in ifconfig/iwconfig it is unlikely to have anything to do with wicd...
Well that is good news, sorta.

Quote:
Originally Posted by turtleli View Post
....did you try to modprobe whatever driver you are using?
I (ab)used a modprobe earlier, and a dhcpd command that I didn't document.

Eric's page says "/sbin/modprobe 3c59x" but I don't have a 3com card, not sure what to actually use in place of it...I will have to re-read some docs tomorrow and try again.

Thank you for your time.

Woo-hoo!
Code:
/sbin/modprobe b43
I'm guessing now I should remove "blacklist b43" from /etc/modprobe.d/b43_blacklist.conf
to survice reboot?

Edit: update from another post....
"If you use the b43-firmware and b43-fwcutter packages do not blacklist anything." says ReaperX7 over here...

Thanks.

Edit: mv /etc/modprobe.d/b43_blacklist.conf to .org and rebooted.
All fixed.

Last edited by Habitual; 10-04-2012 at 04:01 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Yellow Dog 5.0 PS3 and Wifi not working. 36Blade Linux - Wireless Networking 2 05-03-2009 07:29 AM
Trouble with connecting to wifi on my PS3 with yellow dog 6.1 marvinsae Linux - Networking 4 01-23-2009 09:10 PM
Yellow Dog Ps3 Wifi problems coolhandjay Linux - Hardware 5 12-13-2007 08:41 PM


All times are GMT -5. The time now is 01:24 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration