LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 10-08-2009, 11:11 AM   #1
globaltree
Member
 
Registered: Oct 2007
Location: Oregon
Distribution: Slackware 12.2
Posts: 65

Rep: Reputation: 18
Unhappy multiple slack boxes not posting to forms -- had to use winxp just to post this


I am traumatized: I am forced to winxp just to post to this forum

The scenario: I am visiting my mom, and decided to put slackware on her winxp box, and did the usual shrink the xp partition, and install slackware successfully. I installed 12.2. She has dsl, and I installed a netgear 802.11 g router, so my son can connect with his thinkpad running slackware 12.2, but my mom's box connects via ethernet to one of the ethernet ports on the router... the router is doing nat. (not a bridge)...

I know her ISP is blocking port 25, as I can't access my home mail server, and have to use a webmail interface to send mail...

I installed the full 12.2, all the sets, except for kdei. I also installed the patches.

I am running ip tables with the script from http://wiki.linuxquestions.org/wiki/..._a_workstation , which I saved as /etc/rc.d/rc.firewall, and used an entry in rc.local that starts it when booting. I've installed flash player 10. I've installed the libdvd* stuff. But other than that, her box is still a fresh install.

Both, with my son's thinkpad, which has been working fine at home and at hotspots on the way, and with my mom's new slackbox, and while using firefox (haven't tried other browser), firefox is able to surf web fine, but whenever I go to post (either here, or at facebook, or anywhere), it times out. Facebook gives me a network transport error, and asks to check my connection... When I post at LQ, it hangs for a while, and then says done on the status bar, but has whitescreen and doesn't take me back to thread. If I go to thread in new window, the submission is not there.

I have no idea what could cause this, but I really want my mom to like linux, because she is an educator who does lots of remote education, so I think she will like moodle, and made it her home page...

Please help.
 
Old 10-08-2009, 11:20 AM   #2
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 3,519

Rep: Reputation: 873Reputation: 873Reputation: 873Reputation: 873Reputation: 873Reputation: 873Reputation: 873
You need to type your posts more quickly! ( or else get in the habit of saving your typing to the clipboard before posting). I have this problem when posting from my work, There is something monitoring whether the connection is idle for an amount of time, after which it disconnects. The solution is to reconnect, restart your post and paste what you saved. It may be that Windows works because it is sending keep alive packets that maintain the connection.
 
Old 10-08-2009, 11:35 AM   #3
onebuck
Moderator
 
Registered: Jan 2005
Location: Midwest USA, Central Illinois
Distribution: SlackwareŽ
Posts: 11,450
Blog Entries: 4

Rep: Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505
Hi,

Quote:
Originally Posted by globaltree View Post
I am traumatized: I am forced to winxp just to post to this forum
At least you got here.

Quote:
Originally Posted by globaltree View Post

The scenario: I am visiting my mom, and decided to put slackware on her winxp box, and did the usual shrink the xp partition, and install slackware successfully. I installed 12.2. She has dsl, and I installed a netgear 802.11 g router, so my son can connect with his thinkpad running slackware 12.2, but my mom's box connects via ethernet to one of the ethernet ports on the router... the router is doing nat. (not a bridge)...
You could use Slackware 13.

Quote:
Originally Posted by globaltree View Post
I know her ISP is blocking port 25, as I can't access my home mail server, and have to use a webmail interface to send mail...

I installed the full 12.2, all the sets, except for kdei. I also installed the patches.

I am running ip tables with the script from http://wiki.linuxquestions.org/wiki/..._a_workstation , which I saved as /etc/rc.d/rc.firewall, and used an entry in rc.local that starts it when booting. I've installed flash player 10. I've installed the libdvd* stuff. But other than that, her box is still a fresh install.
I like to use Aien_Bob' Slackware adaptation of 'Easy Firewall Generator for IPtables' to start out. I've never had a problem with adapting the tables for my use.

You could have done 'chmod +x /etc/rc.d/rc.firewall' to start your script.

Quote:
Originally Posted by globaltree View Post
Both, with my son's thinkpad, which has been working fine at home and at hotspots on the way, and with my mom's new slackbox, and while using firefox (haven't tried other browser), firefox is able to surf web fine, but whenever I go to post (either here, or at facebook, or anywhere), it times out. Facebook gives me a network transport error, and asks to check my connection... When I post at LQ, it hangs for a while, and then says done on the status bar, but has whitescreen and doesn't take me back to thread. If I go to thread in new window, the submission is not there.

I have no idea what could cause this, but I really want my mom to like linux, because she is an educator who does lots of remote education, so I think she will like moodle, and made it her home page...

Please help.
Check your router since the problem seems to not be related to the Slackware install. Unless you happen to have the same firewall on son's laptop.
 
Old 10-08-2009, 12:51 PM   #4
globaltree
Member
 
Registered: Oct 2007
Location: Oregon
Distribution: Slackware 12.2
Posts: 65

Original Poster
Rep: Reputation: 18
Thanks for the quick responses.

I tested the timeout theory... (on my son's thinkpad, so I won't have to logout of lq on the winxp box): right after running /etc/rc.d/inet1 and obtaining fresh ip address, I immediately opened facebook, and tried to send a message to my wife... I can type "hi" very quickly, but the same thing happened:
Code:
Transport error (#1001 while retrieving data from endpoint '/ajax/gigaboxx/endpoint/MessageComposerEndpoint.php':  A network error occurred.  Check that you are connected to the internet.
But it is still connected: immediately afterwards, I opened a new window in firefox, and was able to perform a google search just fine. The google search form doesn't have any problems accepting POST... hmm., I do notice that both lq and facebook was posting to php scripts, unlike google.

My home network has an openbsd box protecting it, so I do not have very much experience with iptables. But since my son's machine was no longer at my home network (and since tcpdump -i eth0 on my mom's slackbox was showing arriving packets from some isp in newyork), I decided to run iptables on both of them, so I installed the same firewall script on both of them. I had made rc.firewall executable, and the lines I added to rc.local to make sure it started on a reboot were:
Code:
# Enable Firewall
if [ -x /etc/rc.d/rc.firewall ]; then
sh /etc/rc.d/rc.firewall start
fi
The end result is

Code:
sudo iptables --list

Chain INPUT (policy DROP)
target     prot  opt  source          desitination
ACCEPT     tcp   --   anywhere        anywhere          tcp dpt:ssh
ACCEPT     all   --   anywhere        anywhere          state RELATED, ESTABLISHED
ACCEPT     all   --   localhost       anywhere

Chain FORWARD (policy DROP)
target     prot  opt  source          destination

Chain OUTPUT (policy ACCEPT)
target     prot  opt  source          destination
Seems like it lets ssh in (in case I need to help mom after I leave), and drops everything else, except for responses to requests initiated on mom's box.

I am leaning towards her ISP being funky... But I don't understand, if it is the router, why, when rebooting into winxp on mom's box, I can post just fine... But just in case, I will bypass the router, and plug mom's box directly into dsl modem and report results...

Haven't gotten as excited about slack13 as I don't have any 64bit architecture (well, I do have a macbook, but I fried it trying to get it ready for slackware, and my thread about it apparently stumped our entire lq community: http://www.linuxquestions.org/questi...acbook-734484/ ), and I already had the 12.2 sets on a portable hard drive.
 
Old 10-08-2009, 02:25 PM   #5
onebuck
Moderator
 
Registered: Jan 2005
Location: Midwest USA, Central Illinois
Distribution: SlackwareŽ
Posts: 11,450
Blog Entries: 4

Rep: Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505
Hi,

Slackware 13 is either a x86_32 or X86_64, this selection is left to the user to decide the architecture.

BTW, you don't need the start in '/etc/rc.d/rc.local' for the firewall if the script is executable. You can restart the inet or reboot.

I would disable the 'etc/rc.d/rc.firewall' to see if indeed you are having a table problem. You're not going to get into a problem with a short term test. As long as you don't initiate some untrusted script or download/install something that is viral.

Since you are using 'FF', what about plugins? NoScript or AdBlock come to mind? I know that Google-analytic, GoogleLeadservice and GoogleSyndication have given me fits so each has been added to my 'untrusted' when I access LQ. I also notice that a lot of stuff is serviced via 'simplecdn.net' here at LQ. The other day my refresh was into 5-25 second delay from 'simplecdn.net' for .gif, .jpg and other icon files. This same problem popped up months ago but then faded. My refresh and post period lags are around 1.6 sec typically but when that snake raises its' head the lag is not tolerable.
 
Old 10-08-2009, 02:29 PM   #6
globaltree
Member
 
Registered: Oct 2007
Location: Oregon
Distribution: Slackware 12.2
Posts: 65

Original Poster
Rep: Reputation: 18
Using slackware to post again... issue was with router, grr

Well,

I'm successfully posting this to lq, using mom's slackware box, after I directly connected it to dsl modem and bypassed the router...

The netgear wgr614 router is very inexpensive; I use it when I travel to places that have broadband, but not wifi, and it has never failed before... pretty weird...

Thanks for all the fast help. I love LQ.
case closed

Last edited by globaltree; 10-08-2009 at 02:34 PM.
 
Old 10-09-2009, 03:30 AM   #7
globaltree
Member
 
Registered: Oct 2007
Location: Oregon
Distribution: Slackware 12.2
Posts: 65

Original Poster
Rep: Reputation: 18
netgear wgr614 v6 linux friendly wan settings

For the sake of thoroughness (and to save anybody who has same netgear router the hassle I just went through), I am pleased to say that it can be configured to be more linux friendly.

The steps I took:

1. I downloaded most recent firmware from http://kb.netgear.com/app/products/model/a_id/2588, then logged in to router and used the "firmware ugrade" option to select firmware file and uploaded it to router.

2. In the WAN setup, I unchecked "connect automatically as required" (I think this really meant, stay disconnected as much as possible).

3. Also in the WAN setup, I changed the NAT Filtering setting from "secured" to "open" (iptables is doing this job anyways)

And now I can post to LQ while connected through the router, and the facebook apps are working, etc.
 
  


Reply

Tags
firefox, netgear, slackware


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Hi - just posting first post... jennyellwood LinuxQuestions.org Member Intro 7 07-29-2009 03:47 PM
Posting to post thede LinuxQuestions.org Member Intro 1 03-04-2008 07:42 PM
posting to post links ;-) rostedt LinuxQuestions.org Member Intro 1 02-18-2008 02:34 PM
What? I have to post before posting?? phunkizm LinuxQuestions.org Member Intro 1 06-02-2007 06:03 PM
Posting to CGI Forms goldcougar Linux - Newbie 1 07-02-2004 11:13 AM


All times are GMT -5. The time now is 05:25 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration