LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 07-10-2010, 01:06 PM   #1
slugman
Member
 
Registered: Jun 2010
Location: AZ
Distribution: Slackware
Posts: 69

Rep: Reputation: 1
multi-lib Slackware64 13.1


Hello everyone! I am following Eric's guide on setting up MultiLib (found here: http://alien.slackbook.org/dokuwiki/...kware:multilib), and it doesn't seem too bad. Since I am using 13.1, I downloaded all of the required 13.1 packages (and the debug for kicks), ran
Code:
upgradepkg --reinstall --install-new *.t?z
and everything upgraded successfully, including compat32 tools.

Ok so next step. I downloaded the 32 bit 13.1 iso via the torrent from the main slackware site. Next, I ran
Code:
mkdir /iso && mount -o loop -t iso9660 /path/to/slackware.iso /iso
This mounts to /iso, ok cool. Because I mounted the dvd iso to /iso, my source tree now resides at /iso/source. Next, after creating /compat32 and changing into the directory, I do
Code:
massconvert32.sh -i /iso/source/
This fails miserably however, and outputs the following:

Code:
root@darkstar:/compat32# massconvert32.sh -i /iso/source/
***
*** Starting the conversion process:
*** 'A' series:
ls: cannot access /iso/source/a/bzip2-*.t?z: No such file or directory
*** FAIL: package 'bzip2' was not found!
ls: cannot access /iso/source/a/cups-*.t?z: No such file or directory
*** FAIL: package 'cups' was not found!
ls: cannot access /iso/source/a/cxxlibs-*.t?z: No such file or directory
*** FAIL: package 'cxxlibs' was not found!
ls: cannot access /iso/source/a/dbus-*.t?z: No such file or directory
*** FAIL: package 'dbus' was not found!
ls: cannot access /iso/source/a/e2fsprogs-*.t?z: No such file or directory
*** FAIL: package 'e2fsprogs' was not found!
ls: cannot access /iso/source/a/openssl-solibs-*.t?z: No such file or directory
*** FAIL: package 'openssl-solibs' was not found!
ls: cannot access /iso/source/a/util-linux-ng-*.t?z: No such file or directory
*** FAIL: package 'util-linux-ng' was not found!
*** 'AP' series:
ls: cannot access /iso/source/ap/mpg123-*.t?z: No such file or directory
*** FAIL: package 'mpg123' was not found!
ls: cannot access /iso/source/ap/mysql-*.t?z: No such file or directory
*** FAIL: package 'mysql' was not found!
*** 'D' series:
ls: cannot access /iso/source/d/libtool-*.t?z: No such file or directory
*** FAIL: package 'libtool' was not found!
*** 'L' series:
ls: cannot access /iso/source/l/alsa-lib-*.t?z: No such file or directory
*** FAIL: package 'alsa-lib' was not found!
ls: cannot access /iso/source/l/alsa-oss-*.t?z: No such file or directory
*** FAIL: package 'alsa-oss' was not found!
ls: cannot access /iso/source/l/atk-*.t?z: No such file or directory
*** FAIL: package 'atk' was not found!
ls: cannot access /iso/source/l/audiofile-*.t?z: No such file or directory
*** FAIL: package 'audiofile' was not found!
ls: cannot access /iso/source/l/cairo-*.t?z: No such file or directory
*** FAIL: package 'cairo' was not found!
ls: cannot access /iso/source/l/dbus-glib-*.t?z: No such file or directory
*** FAIL: package 'dbus-glib' was not found!
ls: cannot access /iso/source/l/esound-*.t?z: No such file or directory
*** FAIL: package 'esound' was not found!
ls: cannot access /iso/source/l/expat-*.t?z: No such file or directory
*** FAIL: package 'expat' was not found!
ls: cannot access /iso/source/l/freetype-*.t?z: No such file or directory
*** FAIL: package 'freetype' was not found!
ls: cannot access /iso/source/l/gamin-*.t?z: No such file or directory
*** FAIL: package 'gamin' was not found!
ls: cannot access /iso/source/l/glib2-*.t?z: No such file or directory
*** FAIL: package 'glib2' was not found!
ls: cannot access /iso/source/l/gtk+2-*.t?z: No such file or directory
*** FAIL: package 'gtk+2' was not found!
ls: cannot access /iso/source/l/hal-*.t?z: No such file or directory
*** FAIL: package 'hal' was not found!
ls: cannot access /iso/source/l/jasper-*.t?z: No such file or directory
*** FAIL: package 'jasper' was not found!
ls: cannot access /iso/source/l/lcms-*.t?z: No such file or directory
*** FAIL: package 'lcms' was not found!
ls: cannot access /iso/source/l/libart_lgpl-*.t?z: No such file or directory
*** FAIL: package 'libart_lgpl' was not found!
ls: cannot access /iso/source/l/libexif-*.t?z: No such file or directory
*** FAIL: package 'libexif' was not found!
ls: cannot access /iso/source/l/libgphoto2-*.t?z: No such file or directory
*** FAIL: package 'libgphoto2' was not found!
ls: cannot access /iso/source/l/libjpeg-*.t?z: No such file or directory
*** FAIL: package 'libjpeg' was not found!
ls: cannot access /iso/source/l/libidn-*.t?z: No such file or directory
*** FAIL: package 'libidn' was not found!
ls: cannot access /iso/source/l/libmng-*.t?z: No such file or directory
*** FAIL: package 'libmng' was not found!
ls: cannot access /iso/source/l/libpng-*.t?z: No such file or directory
*** FAIL: package 'libpng' was not found!
ls: cannot access /iso/source/l/libtermcap-*.t?z: No such file or directory
*** FAIL: package 'libtermcap' was not found!
ls: cannot access /iso/source/l/libtiff-*.t?z: No such file or directory
*** FAIL: package 'libtiff' was not found!
ls: cannot access /iso/source/l/libxml2-*.t?z: No such file or directory
*** FAIL: package 'libxml2' was not found!
ls: cannot access /iso/source/l/libxslt-*.t?z: No such file or directory
*** FAIL: package 'libxslt' was not found!
ls: cannot access /iso/source/l/ncurses-*.t?z: No such file or directory
*** FAIL: package 'ncurses' was not found!
ls: cannot access /iso/source/l/pango-*.t?z: No such file or directory
*** FAIL: package 'pango' was not found!
ls: cannot access /iso/source/l/popt-*.t?z: No such file or directory
*** FAIL: package 'popt' was not found!
ls: cannot access /iso/source/l/qt-*.t?z: No such file or directory
*** FAIL: package 'qt' was not found!
ls: cannot access /iso/source/l/readline-*.t?z: No such file or directory
*** FAIL: package 'readline' was not found!
ls: cannot access /iso/source/l/sdl-*.t?z: No such file or directory
*** FAIL: package 'sdl' was not found!
ls: cannot access /iso/source/l/seamonkey-solibs-*.t?z: No such file or directory
*** FAIL: package 'seamonkey-solibs' was not found!
ls: cannot access /iso/source/l/svgalib-*.t?z: No such file or directory
*** FAIL: package 'svgalib' was not found!
ls: cannot access /iso/source/l/v4l-utils-*.t?z: No such file or directory
*** FAIL: package 'v4l-utils' was not found!
ls: cannot access /iso/source/l/zlib-*.t?z: No such file or directory
*** FAIL: package 'zlib' was not found!
*** 'N' series:
ls: cannot access /iso/source/n/curl-*.t?z: No such file or directory
*** FAIL: package 'curl' was not found!
ls: cannot access /iso/source/n/cyrus-sasl-*.t?z: No such file or directory
*** FAIL: package 'cyrus-sasl' was not found!
ls: cannot access /iso/source/n/gnutls-*.t?z: No such file or directory
*** FAIL: package 'gnutls' was not found!
ls: cannot access /iso/source/n/libgcrypt-*.t?z: No such file or directory
*** FAIL: package 'libgcrypt' was not found!
ls: cannot access /iso/source/n/libgpg-error-*.t?z: No such file or directory
*** FAIL: package 'libgpg-error' was not found!
ls: cannot access /iso/source/n/openldap-client-*.t?z: No such file or directory
*** FAIL: package 'openldap-client' was not found!
ls: cannot access /iso/source/n/openssl-*.t?z: No such file or directory
*** FAIL: package 'openssl' was not found!
*** 'X' series:
ls: cannot access /iso/source/x/fontconfig-*.t?z: No such file or directory
*** FAIL: package 'fontconfig' was not found!
ls: cannot access /iso/source/x/glew-*.t?z: No such file or directory
*** FAIL: package 'glew' was not found!
ls: cannot access /iso/source/x/libFS-*.t?z: No such file or directory
*** FAIL: package 'libFS' was not found!
ls: cannot access /iso/source/x/libICE-*.t?z: No such file or directory
*** FAIL: package 'libICE' was not found!
ls: cannot access /iso/source/x/libSM-*.t?z: No such file or directory
*** FAIL: package 'libSM' was not found!
ls: cannot access /iso/source/x/libX11-*.t?z: No such file or directory
*** FAIL: package 'libX11' was not found!
ls: cannot access /iso/source/x/libXScrnSaver-*.t?z: No such file or directory
*** FAIL: package 'libXScrnSaver' was not found!
ls: cannot access /iso/source/x/libXTrap-*.t?z: No such file or directory
*** FAIL: package 'libXTrap' was not found!
ls: cannot access /iso/source/x/libXau-*.t?z: No such file or directory
*** FAIL: package 'libXau' was not found!
ls: cannot access /iso/source/x/libXaw-*.t?z: No such file or directory
*** FAIL: package 'libXaw' was not found!
ls: cannot access /iso/source/x/libXcomposite-*.t?z: No such file or directory
*** FAIL: package 'libXcomposite' was not found!
ls: cannot access /iso/source/x/libXcursor-*.t?z: No such file or directory
*** FAIL: package 'libXcursor' was not found!
ls: cannot access /iso/source/x/libXdamage-*.t?z: No such file or directory
*** FAIL: package 'libXdamage' was not found!
ls: cannot access /iso/source/x/libXdmcp-*.t?z: No such file or directory
*** FAIL: package 'libXdmcp' was not found!
ls: cannot access /iso/source/x/libXevie-*.t?z: No such file or directory
*** FAIL: package 'libXevie' was not found!
ls: cannot access /iso/source/x/libXext-*.t?z: No such file or directory
*** FAIL: package 'libXext' was not found!
ls: cannot access /iso/source/x/libXfixes-*.t?z: No such file or directory
*** FAIL: package 'libXfixes' was not found!
ls: cannot access /iso/source/x/libXfont-*.t?z: No such file or directory
*** FAIL: package 'libXfont' was not found!
ls: cannot access /iso/source/x/libXfontcache-*.t?z: No such file or directory
*** FAIL: package 'libXfontcache' was not found!
ls: cannot access /iso/source/x/libXft-*.t?z: No such file or directory
*** FAIL: package 'libXft' was not found!
ls: cannot access /iso/source/x/libXi-*.t?z: No such file or directory
*** FAIL: package 'libXi' was not found!
ls: cannot access /iso/source/x/libXinerama-*.t?z: No such file or directory
*** FAIL: package 'libXinerama' was not found!
ls: cannot access /iso/source/x/libXmu-*.t?z: No such file or directory
*** FAIL: package 'libXmu' was not found!
ls: cannot access /iso/source/x/libXp-*.t?z: No such file or directory
*** FAIL: package 'libXp' was not found!
ls: cannot access /iso/source/x/libXpm-*.t?z: No such file or directory
*** FAIL: package 'libXpm' was not found!
ls: cannot access /iso/source/x/libXprintUtil-*.t?z: No such file or directory
*** FAIL: package 'libXprintUtil' was not found!
ls: cannot access /iso/source/x/libXrandr-*.t?z: No such file or directory
*** FAIL: package 'libXrandr' was not found!
ls: cannot access /iso/source/x/libXrender-*.t?z: No such file or directory
*** FAIL: package 'libXrender' was not found!
ls: cannot access /iso/source/x/libXres-*.t?z: No such file or directory
*** FAIL: package 'libXres' was not found!
ls: cannot access /iso/source/x/libXt-*.t?z: No such file or directory
*** FAIL: package 'libXt' was not found!
ls: cannot access /iso/source/x/libXtst-*.t?z: No such file or directory
*** FAIL: package 'libXtst' was not found!
ls: cannot access /iso/source/x/libXv-*.t?z: No such file or directory
*** FAIL: package 'libXv' was not found!
ls: cannot access /iso/source/x/libXvMC-*.t?z: No such file or directory
*** FAIL: package 'libXvMC' was not found!
ls: cannot access /iso/source/x/libXxf86dga-*.t?z: No such file or directory
*** FAIL: package 'libXxf86dga' was not found!
ls: cannot access /iso/source/x/libXxf86misc-*.t?z: No such file or directory
*** FAIL: package 'libXxf86misc' was not found!
ls: cannot access /iso/source/x/libXxf86vm-*.t?z: No such file or directory
*** FAIL: package 'libXxf86vm' was not found!
ls: cannot access /iso/source/x/libdmx-*.t?z: No such file or directory
*** FAIL: package 'libdmx' was not found!
ls: cannot access /iso/source/x/libdrm-*.t?z: No such file or directory
*** FAIL: package 'libdrm' was not found!
ls: cannot access /iso/source/x/libfontenc-*.t?z: No such file or directory
*** FAIL: package 'libfontenc' was not found!
ls: cannot access /iso/source/x/libxcb-*.t?z: No such file or directory
*** FAIL: package 'libxcb' was not found!
ls: cannot access /iso/source/x/mesa-*.t?z: No such file or directory
*** FAIL: package 'mesa' was not found!
ls: cannot access /iso/source/x/pixman-*.t?z: No such file or directory
*** FAIL: package 'pixman' was not found!
*** Conversion done!
Weird. Considering I just installed 13.1 a week ago, I figured I'd cut my losses and retry the procedure with a fresh-new install of 13.1. This morning I went ahead and did just that. Immediately after installation, I upgraded the multi-lib packages first thing (along with installing compat32 tools). All 13--including the debugger--upgraded & installed with no problems. However I still receive the same error: ls: cannot access /path/to/package No such file or directory*** FAIL: packages 'abc" was not found!. (where abc are all the packages above)

So, I thought, perhaps this has something to do with permissions. Just to be safe, I ran
Code:
chmod -775 /iso
and remounted the dvd iso image. It mounts fine, however the massconver32 script failed with the same error message.

I even tried specifying the -u option for massconvert32.sh, but this failed with a similar error message:
Code:
oot@darkstar:/compat32# massconvert32.sh -u http://slackware.mirrors.pair.com/slackware-13.1/source/
***
*** Starting the conversion process:
*** 'A' series:
--- Downloading 'a/bzip2'...
mget: a/bzip2-*.t?z: no files found                            
ls: cannot access /tmp/alienBOB/a/bzip2-*.t?z: No such file or directory
*** FAIL: package 'bzip2' was not found!
--- Downloading 'a/cups'...
mget: a/cups-*.t?z: no files found                             
ls: cannot access /tmp/alienBOB/a/cups-*.t?z: No such file or directory
*** FAIL: package 'cups' was not found!
and so forth for the rest of the packages.

Does anyone have any ideas? It boggles my mind that I can't access these packages when i have them mounted directly as an .iso! Isn't that better than mounting from a disc? Should I try burning the dvd iso, and mounting that? It just seems silly that I should have to waste a perfectly good dvd when the .iso image resides on my external nearby.

Any thoughts and suggestions are greatly appreciated. Thanks!

Last edited by slugman; 07-10-2010 at 01:11 PM. Reason: i can't type
 
Old 07-10-2010, 01:09 PM   #2
sycamorex
LQ Veteran
 
Registered: Nov 2005
Location: London
Distribution: Slackware64-current
Posts: 5,572
Blog Entries: 1

Rep: Reputation: 1027Reputation: 1027Reputation: 1027Reputation: 1027Reputation: 1027Reputation: 1027Reputation: 1027Reputation: 1027
I think the problem lies in the fact that when you mount an iso image it's a read-only system. I think you need to copy the selected directories somewhere and the do it again.
 
Old 07-10-2010, 01:27 PM   #3
Petri Kaukasoina
Member
 
Registered: Mar 2007
Posts: 242

Rep: Reputation: 86
The DVD has the slackware packages in directory "slackware", not in "source" (which contains the source code, by the way).
 
1 members found this post helpful.
Old 07-10-2010, 01:28 PM   #4
slugman
Member
 
Registered: Jun 2010
Location: AZ
Distribution: Slackware
Posts: 69

Original Poster
Rep: Reputation: 1
Cool oh noes

god damn it if only i could read! yes yes it all makes sense now. I owe you a beer Petri--thank you!

Code:
massconvert32.sh -i /iso/slackware
did the trick. Everything's converting as we speak.

Last edited by slugman; 07-10-2010 at 01:33 PM. Reason: hot damn
 
Old 07-10-2010, 01:29 PM   #5
sycamorex
LQ Veteran
 
Registered: Nov 2005
Location: London
Distribution: Slackware64-current
Posts: 5,572
Blog Entries: 1

Rep: Reputation: 1027Reputation: 1027Reputation: 1027Reputation: 1027Reputation: 1027Reputation: 1027Reputation: 1027Reputation: 1027
Quote:
Originally Posted by Petri Kaukasoina View Post
The DVD has the slackware packages in directory "slackware", not in "source" (which contains the source code, by the way).
You're right. I didn't spot it. The fact that mounting iso creates a read-only directory probably has nothing to do with the OP's problem.

Last edited by sycamorex; 07-10-2010 at 01:38 PM.
 
Old 07-10-2010, 01:40 PM   #6
slugman
Member
 
Registered: Jun 2010
Location: AZ
Distribution: Slackware
Posts: 69

Original Poster
Rep: Reputation: 1
no worries sycamorex i'm glad i got all the help i did.

As a side note, Eric's guide does mention
Quote:
For the sake of this example I will assume that you have a local 32bit Slackware directory tree available at ”/home/ftp/pub/slackware/slackware-13.0/slackware/”.
i'm not sure why i thought the packages where in slackware-13.0/source.
 
  


Reply

Tags
multilib, slackware13, slackware64


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Missing libuuid.so.1 in multi-lib samac Slackware 7 02-23-2011 02:51 PM
Slackware64 multi-lib from AlienBOB 13.1 can't compile VMware Server 2.0.2 b-203138 SCerovec Slackware 11 07-10-2010 08:55 AM
Slackware64-current (after the big one) multi-lib - some thoughts. samac Slackware 3 03-06-2010 11:43 AM
Slack64 Multi-Lib VirtualBox OSE slackass Slackware 5 11-11-2009 12:43 AM
Multi-Lib from Pure-64 reptiler Linux - General 10 04-01-2009 11:01 PM


All times are GMT -5. The time now is 01:19 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration