LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 01-21-2003, 12:11 AM   #1
TheMad
LQ Newbie
 
Registered: Jan 2003
Posts: 29

Rep: Reputation: 15
Mounting NTFS Partitions


How would one go about mounting NTFS partitions on Slackware 8.1?

I've tried sticking in entries into /etc/fstab to no avail.

TheMad

Last edited by TheMad; 01-21-2003 at 01:30 AM.
 
Old 01-21-2003, 01:35 AM   #2
BoonZie
Member
 
Registered: Oct 2002
Location: Malmoe Sweden
Distribution: Slackware 9.1
Posts: 50

Rep: Reputation: 15
Do you have the partitoins on the same machine, or are they on a network?
 
Old 01-21-2003, 01:38 AM   #3
TheMad
LQ Newbie
 
Registered: Jan 2003
Posts: 29

Original Poster
Rep: Reputation: 15
Same machine. Different hard drives, though (well, 2/3 of them are, at least).

TheMad
 
Old 01-21-2003, 02:02 AM   #4
BoonZie
Member
 
Registered: Oct 2002
Location: Malmoe Sweden
Distribution: Slackware 9.1
Posts: 50

Rep: Reputation: 15
I think you should do something like this:
mount -t ntfs /dev/"the name of the partition ex. hdb1" /"where you like to mount it"

Im not realy shure about the syntax, so check out the man pages for mount (man mount).
You have to tell Slack what filesystem you wants to mount, the path to the partiton and where you want to mount it.

If you can mount it manually, you can start editing your fstab-file to get it to mount automatically. You use about the same syntax in the fstab as when you mount it manually. Again - check the man pages.
 
Old 01-21-2003, 05:33 AM   #5
Darin
Senior Member
 
Registered: Jan 2003
Location: Portland, OR USA
Distribution: Slackware, SLAX, Gentoo, RH/Fedora
Posts: 1,024

Rep: Reputation: 45
mount -t ntfs /dev/sda1 /mnt/ddrive

or to make it permenant, put an entry in fstab:

/dev/sda1 /mnt/ddrive ntfs defaults 0 0

use the appropriate drive and partition for your box and make sure the mount point exists (usually as an empty directory) before you mount it.

ntfs filesystem support is a module in the kernel, if you don't have it then you have to build a custom kernel.
 
Old 01-21-2003, 12:39 PM   #6
LSD
Member
 
Registered: Jan 2003
Location: Northam, W.A., Australia
Distribution: Gentoo ~x86
Posts: 321

Rep: Reputation: 30
Slackware (at least version 8.1) provides an NTFS module right out of the box (which I find surprising considering it's still an experimental feature). Typing modprobe ntfs as root will activate it on a per session basis, you can enable it every time you boot by uncommenting the ntfs line in /etc/rc.d/rc.modules (did I get it right this time? ).
 
Old 01-21-2003, 12:57 PM   #7
Darin
Senior Member
 
Registered: Jan 2003
Location: Portland, OR USA
Distribution: Slackware, SLAX, Gentoo, RH/Fedora
Posts: 1,024

Rep: Reputation: 45
It is still read only, odd that it's an included module but maybe Slackware just throws modules for everything in as default. Also, the modprobe ntfs should be optional since it is supposed to autoload when you try to use it with the mount command (my box did that.)
 
Old 01-21-2003, 03:14 PM   #8
TheMad
LQ Newbie
 
Registered: Jan 2003
Posts: 29

Original Poster
Rep: Reputation: 15
Many thanks. I've got them mounted now and whatnot. One last question, though. How do I make it so that all users can access the mounted partitions? At the end of the line in /etc/fstab/ there are two numbers which I simply set to 0 0. However, I can only access the partitions as root, which is not optimal. Thanks again.

TheMad
 
Old 01-21-2003, 05:16 PM   #9
antint
LQ Newbie
 
Registered: Jan 2003
Location: Stockholm, Sweden
Distribution: Slackware 8.0
Posts: 4

Rep: Reputation: 0
In the fstab, change the field (the 4th field) "default" to e.g. umask=22.

Old entry:
/dev/sda1 /mnt/ddrive ntfs defaults 0 0

New entry:
/dev/sda1 /mnt/ddrive ntfs umask=22 0 0

You may also set the owner and group with uid and gid options, like:
/dev/sda1 /mnt/ddrive ntfs uid=joe,group=users,umask=22 0 0

I also recomend you to make sure it's mounted read-only with the ro option like:
/dev/sda1 /mnt/ddrive ntfs ro,uid=joe,group=users,umask=22 0 0

For details, see Documentation/filesystems/ntfs.txt in the Linux source directory.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Mounting NTFS partitions question danritter Linux - Newbie 2 09-12-2005 02:14 AM
Mounting NTFS Partitions on Ubuntu vivekian Ubuntu 2 08-01-2005 10:34 AM
Mounting NTFS partitions with write access Tinky1901 Debian 13 04-09-2005 09:22 AM
Mounting NTFS Partitions in RH9 smevans Red Hat 26 11-09-2003 02:47 PM
Mounting NTFS-partitions and getting readingrights for users. Festiz Linux - Newbie 10 10-28-2003 10:45 AM


All times are GMT -5. The time now is 03:33 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration