LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 10-26-2002, 10:02 AM   #1
monki
LQ Newbie
 
Registered: Oct 2002
Distribution: Slackware 8.1
Posts: 14

Rep: Reputation: 0
modem problems on slack 8.1 "sorry the modem is busy"


Sup everyone.. i recently installed slack 8.1 upgrading from 8.0 .. when trying to dial up to my isp on X using kppp .. i get the error "sorry the modem is busy" .. i do not have a winmodem ..it used to work before. anyone know how i fix this problem? what command to use..or any other help would be appreciated
 
Old 10-26-2002, 02:26 PM   #2
Excalibur
Senior Member
 
Registered: Jun 2002
Location: Northern VA, USA
Distribution: Ubuntu
Posts: 1,180

Rep: Reputation: 45
Check the link /dev/modem and see if it exists. If it does then check to make sure it is valid and pointing to your modem. You chould check kppp configuration and see what it is actually looking for.
 
Old 10-26-2002, 02:51 PM   #3
monki
LQ Newbie
 
Registered: Oct 2002
Distribution: Slackware 8.1
Posts: 14

Original Poster
Rep: Reputation: 0
the link to /dev/modem points to /dev/ttyS1 ..everything for my modem seems to be in order and all the configuration is correct..there must be another problem somewhere.. i really need help with this..so if anyone or Excalibur can help..please it would be appreciated
 
Old 10-26-2002, 07:10 PM   #4
Excalibur
Senior Member
 
Registered: Jun 2002
Location: Northern VA, USA
Distribution: Ubuntu
Posts: 1,180

Rep: Reputation: 45
Are you logged in as root?
 
Old 10-27-2002, 12:13 AM   #5
moses
Senior Member
 
Registered: Sep 2002
Location: Arizona, US, Earth
Distribution: Slackware, (Non-Linux: Solaris 7,8,9; OSX; BeOS)
Posts: 1,152

Rep: Reputation: 46
Did you change the kernel when you upgraded? does your kernel support
PPP? did you use the same port in 8.0? is this an internal modem?
 
Old 10-27-2002, 08:49 AM   #6
monki
LQ Newbie
 
Registered: Oct 2002
Distribution: Slackware 8.1
Posts: 14

Original Poster
Rep: Reputation: 0
Excalibur: yes im running it as root.. my kernel supports PPP and yea my modem is internal.. im gonna try reinstalling slack .. hopefully it will work

Last edited by monki; 10-27-2002 at 08:51 AM.
 
Old 10-27-2002, 01:02 PM   #7
Excalibur
Senior Member
 
Registered: Jun 2002
Location: Northern VA, USA
Distribution: Ubuntu
Posts: 1,180

Rep: Reputation: 45
Is your modem installed on COM2: (/dev/ttyS1)

Also, check in the /var/run directory for an old pid file. It might be called ttyS1.pid, modem.pid, ppp0.pid, kppp.pid or similar. If kppp detects that it thinks a process is using the modem port then it could report that it is busy. "pid" stands for process identification and the file should contain a valid process number using the resource. But if a process dies unexpectedly then it might leave the pid file.
 
Old 10-29-2002, 10:38 AM   #8
monki
LQ Newbie
 
Registered: Oct 2002
Distribution: Slackware 8.1
Posts: 14

Original Poster
Rep: Reputation: 0
yes excalibur the modem is install on COM2 .. i looked in the /var/run dir ..no files similar to kppp or ppp0 or ne thing like that.. still says modem is busy.. i dunno wuts going on but its getting me very upset.. is there ne thing else i could do ? ..i have no clue whats goin on
 
Old 10-29-2002, 11:44 AM   #9
moses
Senior Member
 
Registered: Sep 2002
Location: Arizona, US, Earth
Distribution: Slackware, (Non-Linux: Solaris 7,8,9; OSX; BeOS)
Posts: 1,152

Rep: Reputation: 46
What happens if you do a:

echo "atdt" > /dev/modem
 
Old 10-29-2002, 12:16 PM   #10
moses
Senior Member
 
Registered: Sep 2002
Location: Arizona, US, Earth
Distribution: Slackware, (Non-Linux: Solaris 7,8,9; OSX; BeOS)
Posts: 1,152

Rep: Reputation: 46
Since you're using Slackware, you have another option that isn't as pretty
as kppp, but usually works.

As root, in an xterm or console, do:

cp /etc/resolv.conf /etc/resolv.conf.back
(only necessary if you've setup your DNS server via some other
means, if this file is basically empty, you don't need to back it up)
pppsetup

this will take you through setting up a script that starts your PPP
connection. You'll need to know what happens when you connect (does
your IP require you to log in? do they call you back? same thing you
provided to kppp). Go through the setup, and when you're done, you
should be able to run the script in
/usr/sbin/ppp-go
to start the PPP connection
and
/usr/sbin/ppp-off
to end the PPP connection.

Let us know how this goes. . .
 
Old 10-29-2002, 11:07 PM   #11
monki
LQ Newbie
 
Registered: Oct 2002
Distribution: Slackware 8.1
Posts: 14

Original Poster
Rep: Reputation: 0
well moses..ive already tried the whole ppp-go thing and it just says connect script failed when i try to use it.. when i type echo "atdt" /dev/modem it brings me back to the command line.. i also tried echo "atdt" /dev/ttyS1 and it says input/output error.. have any other ideas?
 
Old 10-30-2002, 12:30 AM   #12
moses
Senior Member
 
Registered: Sep 2002
Location: Arizona, US, Earth
Distribution: Slackware, (Non-Linux: Solaris 7,8,9; OSX; BeOS)
Posts: 1,152

Rep: Reputation: 46
It's very important that you use the redirect after the atdt:

echo atdt > /dev/ttyS1

should give you the same result as

echo atdt > /dev/modem

if /dev/modem points to /dev/ttyS1.
If this is not the case, let's try figuring out what is wrong with /dev/ttyS1
since you seem sure that's where your modem is and you are getting an
error on something that should not give an error.

post the output of:
cat /proc/devices
 
Old 10-30-2002, 08:59 AM   #13
monki
LQ Newbie
 
Registered: Oct 2002
Distribution: Slackware 8.1
Posts: 14

Original Poster
Rep: Reputation: 0
Ok now when i type echo atdt /dev/ttyS1 it gives me the same thing as echo atdt /dev/modem ... heres the output of cat /proc/devices

Character Devices:
1 mem
2 pty
3 ttyp
4 ttyS
5 cua
7 vcs
10 misc
14 sound
21 sg
29 fb
109 lvm
128 ptm
129 ptm
136 pts
137 pts
162 raw

Block devices:
1 ramdisk
2 fd
3 ide0
7 loop
9 md
22 ide1
43 nbd
58 lvm


thats the output of cat /proc/devices
 
Old 10-30-2002, 11:39 AM   #14
moses
Senior Member
 
Registered: Sep 2002
Location: Arizona, US, Earth
Distribution: Slackware, (Non-Linux: Solaris 7,8,9; OSX; BeOS)
Posts: 1,152

Rep: Reputation: 46
So, just to be clear, when you

echo atdt > /dev/ttyS1

it just returns with no error?

Good. This means the device isn't necessarily all funked up.

Now, let's try this:

echo "atdt#####" > /dev/ttyS1

where ##### is the number you would usually dial to connect to your ISP.
You should hear a dialtone (if you are connected to a phone line) for a
second, then hear the modem dialing the number, and possibly an
answer from the other modem. If you aren't connected to a phone line,
you'll get nothing.

What we're doing is just making sure the device (not the modem, but the
device "file" that linux sees) is working (well, OK, we're also checking that
the modem works).

If the other modem answers and you want to hang up:

echo "ath" > /dev/ttyS1

Last edited by moses; 10-30-2002 at 11:41 AM.
 
Old 10-30-2002, 12:41 PM   #15
monki
LQ Newbie
 
Registered: Oct 2002
Distribution: Slackware 8.1
Posts: 14

Original Poster
Rep: Reputation: 0
ok i did the echo "atdt12123592000" > /dev/ttyS1 when i did it it just brought me back to the command line..im hooked up to a fone line but it didnt dial anything ..
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
"Modem Is Busy" error when trying to connect to the Internet with kppp checho4 Linux - Hardware 3 08-19-2005 07:17 AM
"modem is busy"? Iain1974 Mandriva 1 03-15-2005 10:18 AM
"modem is busy" error ruh31 Linux - Networking 5 02-01-2005 02:01 PM
Suse 9.0 Pro - fixing "modem is busy" problem mooseman Linux - General 0 03-06-2004 01:52 PM
"Modem Ready." "Sorry, Modem is busy." mkzmonkeylagger Linux - Hardware 1 04-16-2002 08:34 PM


All times are GMT -5. The time now is 08:54 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration