LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 10-30-2002, 02:57 PM   #16
moses
Senior Member
 
Registered: Sep 2002
Location: Arizona, US, Earth
Distribution: Slackware, (Non-Linux: Solaris 7,8,9; OSX; BeOS)
Posts: 1,152

Rep: Reputation: 46

It looks like your modem is either not detected by linux, or is not on ttyS1.
There are several possibilities for why, but let's stay in diagnostic mode for
a while longer. . .

do a:

dmesg | less

and look for any indication of Linux noticing the serial device on ttyS1 (or
anywhere). Depending on your set up, dmesg may not show enough from
the early boot sequence. If that's the case, there is another trick to seeing
the boot messages, but you need to make sure linux boots to the console.

Look in /var/log/syslog and /var/log/messages to see if there are any issues
with the serial devices.

Ok, the above was diagnostic, below are some things you can try to make
sure you system is trying to start the serial ports at boot:

Run the serial setup script by hand:

/etc/rc.d/rc.serial
If you get errors about "Command not found", you need to edit the file
and make sure the following is on the FIRST line :

#!/bin/sh

If you get an error about "Permission denied", you need to set the
executable bit:
chmod +x /etc/rc.d/rc.serial

If you get it to run, and it tells you something like:

/dev/ttyS0 at 0x03f8 (irq = 4) is a 16550A
/dev/ttyS1 at 0x02f8 (irq = 3) is a 16550A

It should have worked, try the echo "atdt#" > /dev/ttyS1 again.
If this works, next edit your /etc/rc.d/rc.S and look for "rc.serial". Make
sure the start command for rc.serial is not commented out. It should look
like:

if [ -x /etc/rc.d/rc.serial ]; then
. /etc/rc.d/rc.serial
fi

Last edited by moses; 10-30-2002 at 03:00 PM.
 
Old 10-31-2002, 01:20 AM   #17
monki
LQ Newbie
 
Registered: Oct 2002
Distribution: Slackware 8.1
Posts: 14

Original Poster
Rep: Reputation: 0
ok i did all that u said moses..and it worked.. i had to add #!/bin/sh to the rc.serial file and i had to uncomment the /etc/rc.serial line .. and i had to add the

if [ -x /etc/rc.d/rc.serial ]; then
. /etc/rc.d/rc.serial
fi

to the rc.S file ..it worked...but whenever i reboot it says the modem is busy again.. lol..i dunno wuts goin on

Last edited by monki; 10-31-2002 at 01:22 AM.
 
Old 10-31-2002, 01:31 AM   #18
moses
Senior Member
 
Registered: Sep 2002
Location: Arizona, US, Earth
Distribution: Slackware, (Non-Linux: Solaris 7,8,9; OSX; BeOS)
Posts: 1,152

Rep: Reputation: 46
When you say it worked, you mean the echo atdt### > /dev/ttyS1 dialed?

Ok, does the rc.serial file have the executable bit set?
chmod +x /etc/rc.d/rc.serial

check to see if the serial device is being initialized on boot:
dmesg | grep ttyS
 
Old 10-31-2002, 01:34 AM   #19
moses
Senior Member
 
Registered: Sep 2002
Location: Arizona, US, Earth
Distribution: Slackware, (Non-Linux: Solaris 7,8,9; OSX; BeOS)
Posts: 1,152

Rep: Reputation: 46
Also, does the rc.S file contain two instances of running the
/etc/rc.d/rc.serial script? It should only contain one, and it should be
within the "if" statement. . .
 
Old 10-31-2002, 09:53 AM   #20
monki
LQ Newbie
 
Registered: Oct 2002
Distribution: Slackware 8.1
Posts: 14

Original Poster
Rep: Reputation: 0
Thumbs up

everything is good now moses it works! .. the echo "atdt##" > /dev/ttyS1 doesnt work ..but ppp-on works and kppp works in X .. thankz for all your help you taught me alot of shit in the process of all this..i appreciate all the help..thankz alot man
 
Old 10-31-2002, 10:24 AM   #21
monki
LQ Newbie
 
Registered: Oct 2002
Distribution: Slackware 8.1
Posts: 14

Original Poster
Rep: Reputation: 0
i just realized something moses..the modem only works if i dont type in : modprobe sb

i use modprobe to open my sound in gnome when i use it the modem doesnt work..and if i use modprobe while im connected to my ISP the modem stops sending and recieving information.. thats weird dont ya think?
 
Old 10-31-2002, 12:40 PM   #22
moses
Senior Member
 
Registered: Sep 2002
Location: Arizona, US, Earth
Distribution: Slackware, (Non-Linux: Solaris 7,8,9; OSX; BeOS)
Posts: 1,152

Rep: Reputation: 46
It sounds like you have IRQ problems. How old is your computer? your
modem? your sound card?
 
Old 10-31-2002, 02:31 PM   #23
monki
LQ Newbie
 
Registered: Oct 2002
Distribution: Slackware 8.1
Posts: 14

Original Poster
Rep: Reputation: 0
I dont really know how old the computer is ..my friend just sold it to me ..it looks pretty old though.. i got a 56k telepath voice/fax modem and a soundblaster soundcard .. i opened up my pc and i see there is a wire going from my soundcard into my modem.. i unplugged it and tried to see if i could modprobe and use the modem...but it didnt make a difference ..
 
Old 10-31-2002, 04:48 PM   #24
moses
Senior Member
 
Registered: Sep 2002
Location: Arizona, US, Earth
Distribution: Slackware, (Non-Linux: Solaris 7,8,9; OSX; BeOS)
Posts: 1,152

Rep: Reputation: 46
cat /proc/interrupts

cat /proc/ioports

Look to see if the modem and the sound card share either IRQ or IO. If
they do, and they are stingy, you can have problems, including random
lockups.

To fix it, you may have to change the IRQ of the modem or sound card by
changing jumpers on the hardware.
 
Old 11-01-2002, 08:44 AM   #25
monki
LQ Newbie
 
Registered: Oct 2002
Distribution: Slackware 8.1
Posts: 14

Original Poster
Rep: Reputation: 0
i tryed cat /proc/ioports and cat /proc/interrupts .. the soundblaster and modem do not share the same irq ..
 
Old 11-02-2002, 01:59 AM   #26
moses
Senior Member
 
Registered: Sep 2002
Location: Arizona, US, Earth
Distribution: Slackware, (Non-Linux: Solaris 7,8,9; OSX; BeOS)
Posts: 1,152

Rep: Reputation: 46
Hmmm. . .

Very weird.
Is the soundcard on a PCI slot or an ISA slot? If it's on PCI, you might
try moving it to another slot. If it's on ISA, it won't make a difference.

In /usr/src/linux/Documentation/sound/Soundblaster, there is an
explanation of the various parameters one can use when loading the
sb module. You might try some different parameters, like turning off(on)
DMA, uart401, etc. Maybe try making sure the pnp stuff is off, and
manually setting the io, irq, etc.

I'm taking shots in the dark right now, since I don't really know why this
is happening, some of this may cause your computer to lock up.
 
Old 11-05-2002, 05:03 PM   #27
newpenguin
Member
 
Registered: Sep 2002
Location: lahore pakistan
Distribution: slackware,redhat, FreeBSD,openbsd
Posts: 219

Rep: Reputation: 30
have you tried on /dev/tttyS0?
send here your
setserial -bg /dev/ttyS*|more

and

cat /proc/interrupts
cat /proc/ioports
 
Old 11-21-2002, 10:55 AM   #28
thequestion
LQ Newbie
 
Registered: Nov 2002
Location: Jersey
Distribution: Slackware,Mandrake,SuSe
Posts: 3

Rep: Reputation: 0
Is it a PCI modem? I use a Us Rob modem and its on ttyS4, you might want to have a sym link /dev/modem -> /dev/ttyS4 and see if that fixes it. In any distro I had it was always ttyS4 for a PCI modem.
 
Old 11-22-2002, 08:58 PM   #29
moses
Senior Member
 
Registered: Sep 2002
Location: Arizona, US, Earth
Distribution: Slackware, (Non-Linux: Solaris 7,8,9; OSX; BeOS)
Posts: 1,152

Rep: Reputation: 46
Another thought, if you are still around.
Do you have PNP enabled in the BIOS? Linux can have problems with
certain hardware when the BIOS sets the parameters, instead of letting
linux detect them. . . Try disabling pnp in your BIOS.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
"Modem Is Busy" error when trying to connect to the Internet with kppp checho4 Linux - Hardware 3 08-19-2005 08:17 AM
"modem is busy"? Iain1974 Mandriva 1 03-15-2005 11:18 AM
"modem is busy" error ruh31 Linux - Networking 5 02-01-2005 03:01 PM
Suse 9.0 Pro - fixing "modem is busy" problem mooseman Linux - General 0 03-06-2004 02:52 PM
"Modem Ready." "Sorry, Modem is busy." mkzmonkeylagger Linux - Hardware 1 04-16-2002 09:34 PM


All times are GMT -5. The time now is 10:28 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration