LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 03-14-2014, 03:48 AM   #1
danielxs
Member
 
Registered: Feb 2014
Posts: 44

Rep: Reputation: Disabled
mintube is not playing video or audio files


Hi! I have recently installed minitube under slackware 14.1, and I also have installed phonon, phonon-gstreamer, and even phonon-vlc, but when I launch minitube from terminal I get this error:
QPainter::begin: Paint device returned engine == 0, type: 3
QPainter::setCompositionMode: Painter not active
QPainter::end: Painter not active, aborted
WARNING: bool Phonon::FactoryPrivate::createBackend() phonon backend plugin could not be loaded
WARNING: bool Phonon::FactoryPrivate::createBackend() phonon backend plugin could not be loaded
WARNING: bool Phonon::FactoryPrivate::createBackend() phonon backend plugin could not be loaded
WARNING: bool Phonon::FactoryPrivate::createBackend() phonon backend plugin could not be loaded
WARNING: bool Phonon::FactoryPrivate::createBackend() phonon backend plugin could not be loaded
WARNING: Phonon::createPath: Cannot connect Phonon::MediaObject ( no objectName ) to Phonon::AudioOutput ( no objectName ).
WARNING: bool Phonon::FactoryPrivate::createBackend() phonon backend plugin could not be loaded
WARNING: bool Phonon::FactoryPrivate::createBackend() phonon backend plugin could not be loaded
WARNING: bool Phonon::FactoryPrivate::createBackend() phonon backend plugin could not be loaded
WARNING: Phonon::createPath: Cannot connect Phonon::MediaObject ( no objectName ) to Phonon::VideoWidget ( no objectName ).
WARNING: bool Phonon::FactoryPrivate::createBackend() phonon backend plugin could not be loaded
I searched the google an I found this link related to my kind of error: http://www.linuxquestions.org/questi...5429915-print/ In that thread the error was solved, by building minitube with exporting kde libs flag mentioned,
"so I looked around and found this: https://bugs.archlinux.org/task/27850

archlinux applies this patch: I rebuilt phonon with that and it seems to solve the issue.

as a workaround you can also export the QT_PLUGIN_PATH variable like this before launching minitube (/usr/lib64/kde4/plugins if you are on slackware64):
Code:
export QT_PLUGIN_PATH=/usr/lib/kde4/plugins"
But I don't have kde desktop installed, and I don't plan to install it just for minitube. An the fact is I also don't know how to build minitube exporting the required libraries. So, if anyone knows how to build minitube right, I will apreciate the help.
Thanks in advance!

Last edited by danielxs; 03-14-2014 at 03:50 AM.
 
Old 03-14-2014, 04:32 AM   #2
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 2,504

Rep: Reputation: 912Reputation: 912Reputation: 912Reputation: 912Reputation: 912Reputation: 912Reputation: 912Reputation: 912
if you have installed phonon-gstreamer you should have the gstreamer phonon plugin in /usr/lib/kde4/plugins (/usr/lib64/kde4/plugins if you got slackware64), so the less intrusive thing that you can do is open up a terminal, do an export of a variable and then launch minitube
Code:
export QT_PLUGIN_PATH=/usr/lib/kde4/plugins
minitube
obviously you should have installed gstreamer too.

(it's not my intention to be rude at all, just a plain consideration, but) take in account that only full installs of Slackware are supported, so if something doesn't work in your setup because you decided not to install something you are mainly on your own.
 
Old 03-14-2014, 06:15 AM   #3
danielxs
Member
 
Registered: Feb 2014
Posts: 44

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by ponce View Post
if you have installed phonon-gstreamer you should have the gstreamer phonon plugin in /usr/lib/kde4/plugins (/usr/lib64/kde4/plugins if you got slackware64), so the less intrusive thing that you can do is open up a terminal, do an export of a variable and then launch minitube
Code:
export QT_PLUGIN_PATH=/usr/lib/kde4/plugins
minitube
obviously you should have installed gstreamer too.

(it's not my intention to be rude at all, just a plain consideration, but) take in account that only full installs of Slackware are supported, so if something doesn't work in your setup because you decided not to install something you are mainly on your own.
Thank you very much! I did that export thing before, but only as root. I thought I can only export those libraries only as root, but now I used that command as a regular user and it worked. Thanks!
 
Old 03-14-2014, 06:30 AM   #4
danielxs
Member
 
Registered: Feb 2014
Posts: 44

Original Poster
Rep: Reputation: Disabled
I still have another problem. Exporting QT_PLUGIN_PATH=/usr/lib/kde4/plugins only last 1 time after I run minitube, so every time I want to use minitube I have to enter the export command. How can I make it permanent? Can I rebuild minitube including kde4 plugins?
Ok. I used a sh script with: QT_PLUGIN_PATH=/usr/lib/kde4/plugins and
minitube commands, but I'm curious if there isn't any other way?!

Last edited by danielxs; 03-14-2014 at 06:41 AM.
 
Old 03-14-2014, 12:53 PM   #5
larryhaja
Member
 
Registered: Jul 2008
Distribution: Slackware 13.1
Posts: 293

Rep: Reputation: 76
I ran into this as well when I build phonon-backend-vlc. I also updated phonon while I was at it to a newer version because it had Qt5 support. My solution was just to make a symlink during the phonon build process so that the phonon_backend plugins were found in the qt plugins directory. Not the best solution but it worked for me. I don't have my system in front of me but I believe I did something like this in the phonon slackbuild.

Code:
ln -s /usr/lib${LIBDIRSUFFIX}/kde4/plugins/phonon_backend $PKG/usr/lib${LIBDIRSUFFIX}/qt/plugins/phonon_backend
I would believe setting an environment variable "export QT_PLUGIN_PATH=/usr/lib/kde4/plugins" would be easier to do in ~/.profile or ~/.bash_profile.

Last edited by larryhaja; 03-14-2014 at 10:42 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
what will i do when playing an audio and video files? travis1205 Linux - Software 4 09-24-2007 09:30 AM
only audio but no video when playing .mpeg files with MPlayer-0.90 koodoo Linux - Newbie 3 10-01-2004 04:43 AM
playing audio and video cd's amadigoc Linux - General 1 06-28-2004 09:17 PM


All times are GMT -5. The time now is 05:23 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration