LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 04-26-2005, 04:57 PM   #1
whitshade
Member
 
Registered: Sep 2003
Location: New Hampshire
Distribution: Ubuntu 12.04
Posts: 69
Blog Entries: 1

Rep: Reputation: 15
Unhappy lilo.conf and linux as default boot


This really isn't a Slack issue, so much as a LILO issue, but here goes. I'm trying to set up Lilo to boot to Linux by default (the system in dual boot with Win98 and Slack 9.1. LILO works fine, but it won't boot to Linux by default. I've added "default=Linux" just before the "prompt" line and "lba32" (but I'm not sure it's in the right place. I've run LILO after every change I've made, but with no luck. I had it booting to Linux by default on a previous installation, but my notes on what I did are woefully sketchy. Below is my lilo.conf. If someone could just take a look to see if I missed something, I'd be grateful. I do a lot of web design (with Quanta Plus!) and I know that sometimes it takes an objective view to find the little things that may have been missed.

Thanks for your assistance.

# LILO configuration file
# generated by 'liloconfig'
#
# Start LILO global section
boot = /dev/hda3
message = /boot/boot_message.txt
lba32
default = Linux
prompt
timeout = "1200"
# Override dangerous defaults that rewrite the partition table:
change-rules
reset
# VESA framebuffer console @ 1024x768x256
vga = 773
# Normal VGA console
# vga = normal
# VESA framebuffer console @ 1024x768x64k
# vga=791
# VESA framebuffer console @ 1024x768x32k
# vga=790
# VESA framebuffer console @ 1024x768x256
# vga=773
# VESA framebuffer console @ 800x600x64k
# vga=788
# VESA framebuffer console @ 800x600x32k
# vga=787
# VESA framebuffer console @ 800x600x256
# vga=771
# VESA framebuffer console @ 640x480x64k
# vga=785
# VESA framebuffer console @ 640x480x32k
# vga=784
# VESA framebuffer console @ 640x480x256
# vga=769
# End LILO global section
# DOS bootable partition config begins
other = /dev/hda1
label = Dos
table = /dev/hda
# DOS bootable partition config ends
# Linux bootable partition config begins
image = /boot/vmlinuz
root = /dev/hda3
label = Linux
read-only
# Linux bootable partition config ends
 
Old 04-26-2005, 05:09 PM   #2
XavierP
Moderator
 
Registered: Nov 2002
Location: Kent, England
Distribution: Lubuntu
Posts: 19,176
Blog Entries: 4

Rep: Reputation: 430Reputation: 430Reputation: 430Reputation: 430Reputation: 430
Reverse the order in which you have the Linux and Windows entries in Lilo.conf.

Thus
Code:
# End LILO global section
# Linux bootable partition config begins
image = /boot/vmlinuz
root = /dev/hda3
label = Linux
read-only
# Linux bootable partition config ends
# DOS bootable partition config begins
other = /dev/hda1
label = Dos
table = /dev/hda
# DOS bootable partition config ends
and that should mean that Linux boots first. (oh, and don't forget to run lilo before the reboot)
 
Old 04-26-2005, 06:39 PM   #3
mdarby
Member
 
Registered: Nov 2004
Location: Columbus, Ohio
Distribution: Slackware-Current / Debian
Posts: 795

Rep: Reputation: 30
- or -
you could specify
Code:
default=Linux
in lilo.conf, then run 'lilo' as root.
 
Old 04-26-2005, 07:55 PM   #4
whitshade
Member
 
Registered: Sep 2003
Location: New Hampshire
Distribution: Ubuntu 12.04
Posts: 69
Blog Entries: 1

Original Poster
Rep: Reputation: 15
Thanks, people. Unfortunately none of those suggestions seem to do it. I don't know what the problem is. It's almost like there are two distinct lilo.conf files and I'm editing the wrong one. I know this is impossible (?), but I've seen it happen with web pages before. I struggle to fix a page and realize the browser is viewing an unedited backup or something. This is why I wanted a second opinion. It's almost maddening. Fortunately for me, I'm already mad. One thing of note is that I changed the label on the "DOS" drive to "Windows98." When I run LILO, it displays "Added Linux *" "Added Windows98", so something's getting through. I'm stumped. There's got to be something up with my previously posted lilo.conf, but damned if I know what.
 
Old 04-26-2005, 08:02 PM   #5
egag
Senior Member
 
Registered: Jul 2004
Location: Netherlands
Distribution: Slackware
Posts: 2,721

Rep: Reputation: 52
you'll have to set : boot=/dev/hda
otherwise it will be installed in the bootblock of hda3 instead of the mbr.

egag
 
Old 04-26-2005, 08:20 PM   #6
kencaz
Senior Member
 
Registered: Mar 2005
Location: Las Vegas, NV
Distribution: Mandriva Slackware FreeBSD
Posts: 1,468

Rep: Reputation: 47
I think your right "egag"

Also I think the default should be above the boot:
default = Linux
boot = /dev/hda

Otherwise I think lilo would execute the boot = /dev/hda3 before even getting to the label.

KC
 
Old 04-26-2005, 08:32 PM   #7
whitshade
Member
 
Registered: Sep 2003
Location: New Hampshire
Distribution: Ubuntu 12.04
Posts: 69
Blog Entries: 1

Original Poster
Rep: Reputation: 15
Talking

Well, that was it. I knew it was something in the code. When I was prompted to install LILO, I drew a blank as to where I installed it the last time ("MBR (possibly dangerous)" sounds so ill-boding, I guess). Thanks, egag, and everyone else ,too. This forum has once again saved my sanity (oh ... wait... too late for that). All is well with my (computer) world once again. Forums rock! You people rock!

Last edited by whitshade; 04-26-2005 at 08:49 PM.
 
Old 04-26-2005, 08:47 PM   #8
egag
Senior Member
 
Registered: Jul 2004
Location: Netherlands
Distribution: Slackware
Posts: 2,721

Rep: Reputation: 52
ok

egag
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
the "default" ( as we have in grub.conf ) option of lilo.conf ??? b0nd Linux - Newbie 4 09-14-2005 05:51 AM
Changing default OS in lilo.conf mecister Linux - General 1 06-27-2004 07:14 PM
Why does LILO boot Linux by default? Kramer Linux - Hardware 4 11-11-2003 07:03 PM
How do I change the Default in LILO.CONF timmy toad Linux - Newbie 3 09-26-2003 01:28 PM
help me conf lilo for dual linux boot bosewicht Linux - Newbie 17 09-20-2003 10:08 AM


All times are GMT -5. The time now is 10:14 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration