LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices



Reply
 
Search this Thread
Old 09-12-2005, 11:08 PM   #1
b0nd
Senior Member
 
Registered: Jan 2005
Distribution: Slackware, BackTrack, Windows XP
Posts: 1,020

Rep: Reputation: 45
the "default" ( as we have in grub.conf ) option of lilo.conf ???


hello all,
i'm new to lilo.
posting my /etc/lilo.conf

Code:
bond@bond:~$ cat /etc/lilo.conf
# LILO configuration file
# generated by 'liloconfig'
#
# Start LILO global section
boot = /dev/hda
message = /boot/boot_message.txt
prompt
timeout = 600
# Override dangerous defaults that rewrite the partition table:
change-rules
  reset
# VESA framebuffer console @ 1024x768x256
vga = 773
# Normal VGA console
# vga = normal
# VESA framebuffer console @ 1024x768x64k
# vga=791
# VESA framebuffer console @ 1024x768x32k
# vga=790
# VESA framebuffer console @ 1024x768x256
# vga=773
# VESA framebuffer console @ 800x600x64k
# vga=788
# VESA framebuffer console @ 800x600x32k
# vga=787
# VESA framebuffer console @ 800x600x256
# vga=771
# VESA framebuffer console @ 640x480x64k
# vga=785
# VESA framebuffer console @ 640x480x32k
# vga=784
# VESA framebuffer console @ 640x480x256
# vga=769
# End LILO global section
# Linux bootable partition config begins
image = /boot/vmlinuz
  root = /dev/hda8
  label = Slackware
  read-only

image = /mnt/fedora/boot/vmlinuz-2.6.5-1.358
  initrd = /mnt/fedora/boot/initrd-2.6.5-1.358.img
  root = /dev/hda7
  label = FedoraCore_2
  append = "rhgb quiet"
  read-only


image = /mnt/vector/boot/vmlinuz
    root = /dev/hda9
    label = VectorLinux
#    append = ""
    read-only
    initrd = /mnt/vector/boot/initrd.gz


# Linux bootable partition config ends
bond@bond:~$
as you can see i've 3 distros...........
but where is the option for default booting selection.....as we have "default" in grub.conf.??

regards
 
Old 09-12-2005, 11:37 PM   #2
greyhoundz1718
LQ Newbie
 
Registered: Nov 2002
Location: Manila, Philippines
Distribution: RH 6.2, 7.0, 7.1, 7.2, 7.3, 8.0
Posts: 12

Rep: Reputation: 0
default=linux

Hi,

It's been a while since I've seen LILO, however, as far as I can remember, there should be a line in lilo.conf similar to default in grub. Please see below, on this example I have a linux option to boot as default . But then again it's been a while I saw a lilo.conf file:

boot=/dev/hda
map=/boot/map
install=/boot/boot.b
prompt
timeout=50
message=/boot/message
lba32
default=linux

c**,)
greyhoundz
 
Old 09-13-2005, 08:31 AM   #3
b0nd
Senior Member
 
Registered: Jan 2005
Distribution: Slackware, BackTrack, Windows XP
Posts: 1,020

Original Poster
Rep: Reputation: 45
Re: default=linux

Quote:
Originally posted by greyhoundz1718
Hi,

It's been a while since I've seen LILO, however, as far as I can remember, there should be a line in lilo.conf similar to default in grub. Please see below, on this example I have a linux option to boot as default . But then again it's been a while I saw a lilo.conf file:

boot=/dev/hda
map=/boot/map
install=/boot/boot.b
prompt
timeout=50
message=/boot/message
lba32
default=linux

c**,)
greyhoundz
i've already posted my /etc/lilo.conf.........
but i can't see any "default" there

regards
 
Old 09-13-2005, 09:40 AM   #4
geeman2.0
Member
 
Registered: Feb 2005
Location: Ontario, Canada
Distribution: Gentoo, Slackware
Posts: 345

Rep: Reputation: 30
From the lilo.conf man page

Code:
default=name 
Uses the specified image as the default boot image. If `default' is omitted, the image appearing first in the configuration file is used.
So in other words, you don't need a default line.
If it's not there then the first image in the list is default.
If you want to change this, then add in "default=whatever" in the global section.
 
Old 09-14-2005, 06:51 AM   #5
b0nd
Senior Member
 
Registered: Jan 2005
Distribution: Slackware, BackTrack, Windows XP
Posts: 1,020

Original Poster
Rep: Reputation: 45
Quote:
Originally posted by geeman2.0
From the lilo.conf man page

Code:
default=name 
Uses the specified image as the default boot image. If `default' is omitted, the image appearing first in the configuration file is used.
So in other words, you don't need a default line.
If it's not there then the first image in the list is default.
If you want to change this, then add in "default=whatever" in the global section.
Its working man !!!
I tried both the methods.

1. in the global section i added a line ....default="whatever was the name of distro in lilo.conf"
and
2. instead of adding "default" line.......i cut paste the entries for a distro and placed it at first positions.

In both ways its working......
noticed one more thing that unlike in grub.conf......default=0 or default=1 doesn't work in case of lilo.conf.
the name should be specified instead of numeric value

thanks geeman and grayhound

regards
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
dhcpd.conf "option routers" non fixed TroelsSmit Linux - Networking 1 08-11-2005 05:31 AM
doubt in editing "grub.conf" in multi distro machine b0nd Linux - Newbie 6 08-06-2005 10:46 AM
dns named.conf: "view" unknown option rioguia Linux - Networking 16 11-02-2004 12:04 PM
Lilo.conf append "prof=office" , what is it? cbarthel Linux - Software 1 06-04-2004 05:32 AM
lilo.conf "label=" question nrunge Linux - Newbie 6 11-08-2003 10:16 AM


All times are GMT -5. The time now is 02:01 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration