LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 12-24-2011, 04:14 AM   #1
Cultist
Member
 
Registered: Feb 2010
Location: Chicago, IL
Distribution: Slackware64 14.1
Posts: 777

Rep: Reputation: 101Reputation: 101
latex error installing texlive via sbopkg


SO I was trying to install texlive. I removed tetex and tetex-docs beforehand like the readme says, and proceeded to build. Files all downloaded properly, but after it runs for a bit, it gives met his error:

Code:
checking for latex... no
checking for elatex... no
checking for lambda... no
checking for pdflatex... no
configure: error: LATEX is required to build xindy rules
=== configuring in xindy failed
make[2]: *** [subutils] Error 1
make[2]: Leaving directory `/tmp/SBo/texlive-20110705-source/Work/utils'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/tmp/SBo/texlive-20110705-source/Work/utils'
make: *** [all-recursive] Error 1
Command exited with non-zero status 2
213.27user 78.58system 5:30.62elapsed 88%CPU (0avgtext+0avgdata 674928maxresident)k
16inputs+1020128outputs (0major+24810714minor)pagefaults 0swaps
+ echo 2
done (exit status 2) Sat Dec 24 05:07:04 EST 2011
My exact process was to type
Code:
su -
, remove tetex and tetex-doc, open sbopkg, and install texlive.

The error seems to indicate that I'm missing Latex, and Google has not helped me to figure out this problem. I can't even find a latex package to try to install.

This is while running in Terminal in xfce in Slackware64 -current.

Any solutions would be greatly appreciated.
 
Old 12-24-2011, 07:09 AM   #2
amani
Senior Member
 
Registered: Jul 2006
Location: Kolkata, India
Distribution: 64-bit GNU/Linux, Kubuntu64, Fedora QA, Slackware,
Posts: 2,758

Rep: Reputation: Disabled
sbopkg is not stable yet. paths?

better install from texlive dvd or manually.
 
Old 12-24-2011, 11:15 PM   #3
Cultist
Member
 
Registered: Feb 2010
Location: Chicago, IL
Distribution: Slackware64 14.1
Posts: 777

Original Poster
Rep: Reputation: 101Reputation: 101
Okay, I'm an idiot.

The problem was that I wasn't literal enough with the readme. I removed tetex and tetex-doc before trying to compile texlive, but all the readme actually says is to remove them before INSTALLING texlive. I reinstalled the packages, compiled texlive without issue, removed the packages again, installed texlive, and all is well.
 
Old 12-25-2011, 01:26 AM   #4
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 2,380

Rep: Reputation: 840Reputation: 840Reputation: 840Reputation: 840Reputation: 840Reputation: 840Reputation: 840
Quote:
Originally Posted by amani View Post
sbopkg is not stable yet.
?

can you please explain why you say that?

Last edited by ponce; 12-25-2011 at 01:29 AM.
 
Old 12-26-2011, 10:23 AM   #5
amani
Senior Member
 
Registered: Jul 2006
Location: Kolkata, India
Distribution: 64-bit GNU/Linux, Kubuntu64, Fedora QA, Slackware,
Posts: 2,758

Rep: Reputation: Disabled
http://sbopkg.org/ says it is still in testing phase.
 
Old 12-26-2011, 12:23 PM   #6
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 2,380

Rep: Reputation: 840Reputation: 840Reputation: 840Reputation: 840Reputation: 840Reputation: 840Reputation: 840
ah, that means pretty nothing, it's just a disclaimer, I used it for years building thousands of packages without any fault

has it failed for you?
 
Old 01-01-2012, 04:57 PM   #7
firekage
Member
 
Registered: May 2011
Location: Poland
Distribution: Slackware, Ubuntu, Arch
Posts: 272

Rep: Reputation: 7
Quote:
Originally Posted by Cultist View Post
Okay, I'm an idiot.

The problem was that I wasn't literal enough with the readme. I removed tetex and tetex-doc before trying to compile texlive, but all the readme actually says is to remove them before INSTALLING texlive. I reinstalled the packages, compiled texlive without issue, removed the packages again, installed texlive, and all is well.
I have the same error but in my case, i only tried to compile it. I hadn't remove anything when compiling and error is still present. Don't know why. I don't use sbopkg, i tried to compiling it with terminal, still no progess.

Code:
checking what warning flags to pass to the C compiler... -Wimplicit -Wreturn-type -Wdeclaration-after-statement -Wno-unknown-pragmas
checking for clisp... clisp
checking for perl... perl
checking for latex... no
checking for elatex... no
checking for lambda... no
checking for pdflatex... no
configure: error: LATEX is required to build xindy rules
=== configuring in xindy failed
make[2]: *** [subutils] Error 1
make[2]: Leaving directory `/tmp/SBo/texlive-20110705-source/Work/utils'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/tmp/SBo/texlive-20110705-source/Work/utils'
make: *** [all-recursive] Error 1
Command exited with non-zero status 2
195.99user 21.86system 4:27.00elapsed 81%CPU (0avgtext+0avgdata 396208maxresident)k
0inputs+566528outputs (0major+19572551minor)pagefaults 0swaps
+ echo 2
done (exit status 2) Sun Jan 1 23:51:40 CET 2012
root@darkstar:/tmp/texlive# ^C
root@darkstar:/tmp/texlive# mcedit tex
texi2html-5.0.tar.bz2           texlive-20110705-texmf.tar.xz
texlive-20110705-extra.tar.xz   texlive.SlackBuild
texlive-20110705-source.tar.xz  texlive.info
root@darkstar:/tmp/texlive# mcedit texlive.SlackBuild
I downloaded all files from slackbuild, with sources.

Last edited by firekage; 01-01-2012 at 05:16 PM.
 
Old 01-09-2012, 07:53 AM   #8
lunarDarkside
LQ Newbie
 
Registered: Jan 2012
Posts: 1

Rep: Reputation: Disabled
i change 'enable-xindy' to 'disable-xindy' in the texlive.SlackBuild file, and then compile and install without error.

after that i manually installed xindy package, but havn't given it a full test yet.
 
1 members found this post helpful.
Old 01-09-2012, 09:43 AM   #9
firekage
Member
 
Registered: May 2011
Location: Poland
Distribution: Slackware, Ubuntu, Arch
Posts: 272

Rep: Reputation: 7
Quote:
Originally Posted by lunarDarkside View Post
i change 'enable-xindy' to 'disable-xindy' in the texlive.SlackBuild file, and then compile and install without error.

after that i manually installed xindy package, but havn't given it a full test yet.

Thank you for this tip I didn't know that it can be disabled.
 
Old 01-21-2012, 01:59 PM   #10
JohnV2
Member
 
Registered: Oct 2011
Distribution: Slackware
Posts: 66

Rep: Reputation: Disabled
Thumbs up

Quote:
Originally Posted by firekage View Post
I have the same error but in my case, i only tried to compile it. I hadn't remove anything when compiling and error is still present. Don't know why. I don't use sbopkg, i tried to compiling it with terminal, still no progess.

Code:
checking what warning flags to pass to the C compiler... -Wimplicit -Wreturn-type -Wdeclaration-after-statement -Wno-unknown-pragmas
checking for clisp... clisp
checking for perl... perl
checking for latex... no
checking for elatex... no
checking for lambda... no
checking for pdflatex... no
configure: error: LATEX is required to build xindy rules
=== configuring in xindy failed
make[2]: *** [subutils] Error 1
make[2]: Leaving directory `/tmp/SBo/texlive-20110705-source/Work/utils'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/tmp/SBo/texlive-20110705-source/Work/utils'
make: *** [all-recursive] Error 1
Command exited with non-zero status 2
195.99user 21.86system 4:27.00elapsed 81%CPU (0avgtext+0avgdata 396208maxresident)k
0inputs+566528outputs (0major+19572551minor)pagefaults 0swaps
+ echo 2
done (exit status 2) Sun Jan 1 23:51:40 CET 2012
root@darkstar:/tmp/texlive# ^C
root@darkstar:/tmp/texlive# mcedit tex
texi2html-5.0.tar.bz2           texlive-20110705-texmf.tar.xz
texlive-20110705-extra.tar.xz   texlive.SlackBuild
texlive-20110705-source.tar.xz  texlive.info
root@darkstar:/tmp/texlive# mcedit texlive.SlackBuild
I downloaded all files from slackbuild, with sources.
Hi

you need to do "su -l" I've tested...

look at this http://slackbuilds.org/howto/#su

best regards,
John
 
1 members found this post helpful.
Old 01-22-2012, 03:29 AM   #11
firekage
Member
 
Registered: May 2011
Location: Poland
Distribution: Slackware, Ubuntu, Arch
Posts: 272

Rep: Reputation: 7
Quote:
Originally Posted by JohnV2 View Post
Hi

you need to do "su -l" I've tested...

look at this http://slackbuilds.org/howto/#su

best regards,
John
I don't understand. In what purpose? I've tried to install it with root privileages with su, and given password so i was not as a user but as a root. It is because of mentioned at slackubilds.org path?

Last edited by firekage; 01-22-2012 at 03:31 AM.
 
Old 01-23-2012, 01:40 PM   #12
JohnV2
Member
 
Registered: Oct 2011
Distribution: Slackware
Posts: 66

Rep: Reputation: Disabled
Smile

Quote:
Originally Posted by firekage View Post
I don't understand. In what purpose? I've tried to install it with root privileages with su, and given password so i was not as a user but as a root. It is because of mentioned at slackubilds.org path?
Yes of course... the installer was not to be able to find xindy because of the path.

check "$ env" like this "$ env | grep PATH" and look for example this environment variable "PATH=", you see?

now you can do this:
# slocate -u (if you never ran before)
# slocate xindy

where is it? in the user account you have /usr/share/texmf/bin moreover if you check root PATH you don't have it... that's why

best regards,

John
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Installing package texlive Psionman Linux - Newbie 3 12-09-2011 12:11 PM
update texlive (tlmgr): no texlive.tlpdb tramni1980 Slackware 3 03-30-2011 07:30 AM
Trouble installing LaTeX texlive abbotslad Linux - Software 4 01-10-2011 07:48 AM
Error installing texlive-base package igadoter Ubuntu 1 01-02-2011 08:05 AM
Debian lenny: texlive-latex-base, W: invalid date kaz2100 Debian 0 11-07-2008 09:09 PM


All times are GMT -5. The time now is 08:54 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration