LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 05-30-2010, 02:43 AM   #1
Interject
Member
 
Registered: Jun 2009
Distribution: Slackware 12.2/13.1
Posts: 41

Rep: Reputation: 16
kdenlive and 13.1


Has anyone got kdenlive to work successfully, I can run it but apparently I don't have the "avformat module" so I cannot view clips/edit.(I have ffmpeg/mlt and the req libraries as far as I know)

I ran 'locate avformat' which tells me I actually do have avformat.
Code:
user@darkstar:~$ locate avformat
/usr/local/lib/libavformat.a
/usr/local/lib/pkgconfig/libavformat.pc
/usr/local/include/libavformat
/usr/local/include/libavformat/avio.h
/usr/local/include/libavformat/avformat.h
/usr/lib/mlt/libmltavformat.so
/usr/lib/vlc/demux/libavformat_plugin.la
/usr/lib/vlc/demux/libavformat_plugin.so
/usr/share/mlt/avformat
/usr/share/mlt/avformat/producer_avformat.yml
I installed kdenlive using this package
 
Old 05-30-2010, 03:46 AM   #2
vdemuth
Member
 
Registered: Oct 2003
Location: West Midlands, UK
Distribution: Slackware 14 (Server),Suse 13.1 (Desktop),, Mepis on the wifes lappy
Posts: 767

Rep: Reputation: 92
Had no luck with the package you used, but the ones from here work fine under 13.1. Grab all three packages and with any luck you'll be good to go.
 
Old 05-30-2010, 06:11 AM   #3
Interject
Member
 
Registered: Jun 2009
Distribution: Slackware 12.2/13.1
Posts: 41

Original Poster
Rep: Reputation: 16
Unfortunately that website returns a 404 when fetching the 32 bit package
 
Old 05-30-2010, 08:58 AM   #4
vdemuth
Member
 
Registered: Oct 2003
Location: West Midlands, UK
Distribution: Slackware 14 (Server),Suse 13.1 (Desktop),, Mepis on the wifes lappy
Posts: 767

Rep: Reputation: 92
Which version of ffmpeg do you have. I had to compile my own in order to get things working correctly.
 
Old 05-30-2010, 09:31 AM   #5
Interject
Member
 
Registered: Jun 2009
Distribution: Slackware 12.2/13.1
Posts: 41

Original Poster
Rep: Reputation: 16
Quote:
Originally Posted by vdemuth View Post
Which version of ffmpeg do you have. I had to compile my own in order to get things working correctly.
I compiled/downloaded today.
Code:
FFmpeg version SVN-r23386
 
Old 05-30-2010, 11:40 AM   #6
stormtracknole
Member
 
Registered: Aug 2005
Location: The Big Easy
Distribution: Slackware, RHEL
Posts: 817

Rep: Reputation: 104Reputation: 104
There is a slackbuild for it here. Make sure you follow the directions and get all the needed dependencies first.
 
Old 05-30-2010, 11:41 AM   #7
stormtracknole
Member
 
Registered: Aug 2005
Location: The Big Easy
Distribution: Slackware, RHEL
Posts: 817

Rep: Reputation: 104Reputation: 104
You may also want to take a look at openshot. I've used both, and in my opinion, openshot seem to be more simple in doing some easy things.
 
Old 05-31-2010, 04:30 AM   #8
Interject
Member
 
Registered: Jun 2009
Distribution: Slackware 12.2/13.1
Posts: 41

Original Poster
Rep: Reputation: 16
I built the slackbuild installed the package etc... still missing "Avfromat module". All I can do is shrug I don't know what I'm missing dependency wise.
I guess I'll have a shot at openshot (I won't have much hair left after this)

EDIT: Well, so much for openshot :/ that can't detect any codecs.
"No formats or codecs were found. Please check the OpenShot preferences and configure the 'melt' command name."

The problem seems to be with melt, which I have installed several a binary packages/compiled doesn't want to play files(ffplay works with them).
Code:
user@darkstar:~/Documents/CaptureTests$ melt file 
Failed to load "file"

Last edited by Interject; 05-31-2010 at 06:18 AM.
 
Old 05-31-2010, 09:46 AM   #9
stormtracknole
Member
 
Registered: Aug 2005
Location: The Big Easy
Distribution: Slackware, RHEL
Posts: 817

Rep: Reputation: 104Reputation: 104
Quote:
Originally Posted by Interject View Post
I built the slackbuild installed the package etc... still missing "Avfromat module". All I can do is shrug I don't know what I'm missing dependency wise.
I guess I'll have a shot at openshot (I won't have much hair left after this)

EDIT: Well, so much for openshot :/ that can't detect any codecs.
"No formats or codecs were found. Please check the OpenShot preferences and configure the 'melt' command name."

The problem seems to be with melt, which I have installed several a binary packages/compiled doesn't want to play files(ffplay works with them).
Code:
user@darkstar:~/Documents/CaptureTests$ melt file 
Failed to load "file"
How did you build ffmpeg? Did you use the version from slackbuilds.org site? I have both kdenlive and openshot built on my 13.1 box and they both work correctly. Make sure that all dependecies are met, which are quite a bit.
 
Old 05-31-2010, 10:01 AM   #10
Interject
Member
 
Registered: Jun 2009
Distribution: Slackware 12.2/13.1
Posts: 41

Original Poster
Rep: Reputation: 16
Quote:
Originally Posted by stormtracknole View Post
How did you build ffmpeg? Did you use the version from slackbuilds.org site? I have both kdenlive and openshot built on my 13.1 box and they both work correctly. Make sure that all dependecies are met, which are quite a bit.
Downloaded from the SVN and configured with
(I've also tried with a prebuilt package from slacky.eu)
Code:
./configure --prefix=/usr --enable-shared --enable-libmp3lame --enable-gpl --enable-libfaad --enable-libvorbis --enable-pthreads --enable-libfaac --enable-libxvid --enable-postproc --enable-x11grab --enable-libgsm --enable-libx264 --enable-libtheora --enable-libdc1394 --enable-nonfree --disable-stripping --enable-avfilter --disable-decoder=libdirac --enable-libschroedinger --disable-encoder=libschroedinger --enable-avfilter-lavf --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-version3
 
Old 05-31-2010, 02:03 PM   #11
stormtracknole
Member
 
Registered: Aug 2005
Location: The Big Easy
Distribution: Slackware, RHEL
Posts: 817

Rep: Reputation: 104Reputation: 104
Quote:
Originally Posted by Interject View Post
Downloaded from the SVN and configured with
(I've also tried with a prebuilt package from slacky.eu)
Code:
./configure --prefix=/usr --enable-shared --enable-libmp3lame --enable-gpl --enable-libfaad --enable-libvorbis --enable-pthreads --enable-libfaac --enable-libxvid --enable-postproc --enable-x11grab --enable-libgsm --enable-libx264 --enable-libtheora --enable-libdc1394 --enable-nonfree --disable-stripping --enable-avfilter --disable-decoder=libdirac --enable-libschroedinger --disable-encoder=libschroedinger --enable-avfilter-lavf --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-version3
What do you get when you type ffmpeg on a terminal? I'm thinking that you have not satisfied all the needed dependencies. Try building ffmpeg from the slackbuilds.org site.
 
Old 07-06-2010, 01:50 PM   #12
logicalfuzz
Member
 
Registered: Aug 2005
Distribution: Arch Linux
Posts: 291

Rep: Reputation: 39
I am facing the same problem on slackware 13.0. I have used all packages from slackbuilds. Here is some info that may be useful. Please help resolve.....

Code:
root@slackhome:~# ffmpeg --version
FFmpeg version 0.5.1, Copyright (c) 2000-2009 Fabrice Bellard, et al.
  configuration: --prefix=/usr --libdir=/usr/lib --shlibdir=/usr/lib --mandir=/usr/man --disable-debug --enable-shared 
--disable-static --enable-pthreads --enable-libtheora --enable-gpl --enable-version3 --enable-postproc --enable-swscale 
--enable-x11grab --enable-avfilter --enable-avfilter-lavf --arch=i486 --enable-libfaadbin --enable-libvorbis 
--enable-libmp3lame --disable-stripping --disable-decoder=libdirac --disable-decoder=libschroedinger --enable-libdc1394 
--enable-libmp3lame --enable-libfaac --enable-libfaad --enable-libxvid --enable-libx264 --enable-libdirac 
--enable-libschroedinger --disable-vdpau --enable-nonfree --enable-libamr-nb --enable-libamr-wb --enable-libopencore-amrnb 
--enable-libopencore-amrwb --enable-runtime-cpudetect     
  libavutil     49.15. 0 / 49.15. 0                                                                                                                    
  libavcodec    52.20. 1 / 52.20. 1                                                                                                                    
  libavformat   52.31. 0 / 52.31. 0                                                                                                                    
  libavdevice   52. 1. 0 / 52. 1. 0                                                                                                                    
  libavfilter    0. 4. 0 /  0. 4. 0                                                                                                                    
  libswscale     0. 7. 1 /  0. 7. 1                                                                                                                    
  libpostproc   51. 2. 0 / 51. 2. 0                                                                                                                    
  built on Jul  3 2010 22:51:32, gcc: 4.3.3                                                                                                            
ffmpeg: missing argument for option '--version'
root@slackhome:~# melt /home/njathan/Videos/60\ Minutes\ -\ Google.avi                                                                                 
Failed to load "/home/njathan/Videos/60 Minutes - Google.avi"                                                                                          
Usage: melt [options] [producer [name=value]* ]+                                                                                                       
Options:                                                                                                                                               
  -attach filter[:arg] [name=value]*       Attach a filter to the output                                                                               
  -attach-cut filter[:arg] [name=value]*   Attach a filter to a cut                                                                                    
  -attach-track filter[:arg] [name=value]* Attach a filter to a track   
.......</snip>.......
 
Old 07-06-2010, 08:21 PM   #13
ryerke
Member
 
Registered: Dec 2006
Location: Fresno CA
Distribution: Slackware 13 Slackware 13.37 ARMEDSlack 13.37
Posts: 89

Rep: Reputation: 21
That one gave me trouble too. I needed to "su -" to get root when compiling ffmpeg. That is were your avformat comes from. If you simply su into root you will not load the proper environment variables to compile properly. I am successfully using kdenlive from slackbuilds.org. You need to be very careful when gathering the dependencies and compile in order so that certain libs are available at compile time. Pay close attention to the readme and you should be golden.
 
Old 07-07-2010, 12:22 AM   #14
logicalfuzz
Member
 
Registered: Aug 2005
Distribution: Arch Linux
Posts: 291

Rep: Reputation: 39
Quote:
Originally Posted by ryerke View Post
I needed to "su -" to get root when compiling ffmpeg. That is were your avformat comes from. If you simply su into root you will not load the proper environment variables to compile properly.
I too did a 'su -' (thats a habit ) before letting sbopkg compile ffmpeg.

Quote:
Originally Posted by ryerke View Post
I am successfully using kdenlive from slackbuilds.org. You need to be very careful when gathering the dependencies and compile in order so that certain libs are available at compile time. Pay close attention to the readme and you should be golden.
Are you using ffmpeg, mlt and other packages also from slackbuilds.org?
It would be great if you can share the compile options for ffmpeg thats making your kdenlive detect avformat.... (ffmpeg was the only one where i had to do custom changes in slackbuilds.info file, while following a kdenlive forum post)
 
Old 07-07-2010, 02:20 PM   #15
logicalfuzz
Member
 
Registered: Aug 2005
Distribution: Arch Linux
Posts: 291

Rep: Reputation: 39
libquicktime was the culprit... compiled and installed it, and recompiled kdenlive. Avformat detected
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
problem with kdenlive kite dirk Linux - Newbie 0 10-24-2009 01:12 AM
kdenlive dual monitor? jmite Linux - Newbie 2 01-25-2009 08:47 PM
LXer: Kdenlive 0.7, for KDE 4 LXer Syndicated Linux News 0 11-13-2008 01:30 AM
kdenlive: problem with a transation eantoranz Linux - Software 0 10-09-2007 04:01 PM
kdenlive crash D.A. Linux - Software 0 09-08-2007 11:27 AM


All times are GMT -5. The time now is 03:45 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration