LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 01-30-2005, 07:53 AM   #1
DaneM
Member
 
Registered: Oct 2003
Location: Chico, CA, USA
Distribution: Linux Mint
Posts: 745

Rep: Reputation: 81
Init 4: Logging out of KDE causes black screen, freeze with GDM, KDM and XDM


Hello everybody.

I've got a problem: Whenever I try to "end current session" with KDE with KDM login manager, it boots me back to tty1, but doesn't let me type anything. ttys 2-5 don't work either, while I'm in KDE, or after logging-out. tty6 will allow me to shut down smoothly. With GDM I get a black screen and freeze while trying to log in (don't know what would happen logging out, obviously), and XDM will show the login screen after ending the session, but the colors are inversed and I can't type anything or switch to another tty.

I recently made some changes to get even one tty to work (with KDM). In /opt/kde/share/config/Xservers, I've changed the line:

Code:
:0 local@tty1 /usr/X11R6/bin/X
to

Code:
:0 local /usr/X11R6/bin/X vt7 -terminate -nolisten tcp
For XDM, in order to get even a frozen and inversed image (as opposed to frozen and a blank screen) I changed the following line in /etc/X11/xdm/Xservers:

Code:
:0 local /usr/X11R6/bin/X
to

Code:
:0 local /usr/X11R6/bin/X vt7 -terminate -nolisten tcp
The web site that directed me to do this is here. I modified the lines slightly because the ones they gave me didn't work at all.

To boot into init 4 instead of 3, I changed line in /etc/inittab from

Code:
id:3:initdefault:
to

Code:
id:4:initdefault:
Can anybody help me fix this? I appreciate your help.

--Dane
 
Old 01-30-2005, 08:03 AM   #2
carboncopy
Senior Member
 
Registered: Jan 2003
Location: Malaysia
Distribution: Fedora Core, Slackware, Mac OS X, Debian, OpenSUSE
Posts: 1,210
Blog Entries: 4

Rep: Reputation: 45
1. Are you using nvidia driver?

2. Did you custom compiled your kernel?

3. Which kernel version are you running?
 
Old 01-30-2005, 08:16 AM   #3
DaneM
Member
 
Registered: Oct 2003
Location: Chico, CA, USA
Distribution: Linux Mint
Posts: 745

Original Poster
Rep: Reputation: 81
Thanks for posting, carboncopy.

1. I am using the latest (last I checked) ATI Radeon driver for Xorg 6.8.1, which I compiled myself.

2. I custom-compiled my kernel.

3. 2.6.7-ck6 (2.6.7 with Con Kolivas patch).
 
Old 01-30-2005, 09:25 AM   #4
carboncopy
Senior Member
 
Registered: Jan 2003
Location: Malaysia
Distribution: Fedora Core, Slackware, Mac OS X, Debian, OpenSUSE
Posts: 1,210
Blog Entries: 4

Rep: Reputation: 45
Do you have frame buffer compiled with the kernel? If yes, recompile your kernel without frame buffer.
 
Old 01-30-2005, 03:32 PM   #5
DaneM
Member
 
Registered: Oct 2003
Location: Chico, CA, USA
Distribution: Linux Mint
Posts: 745

Original Poster
Rep: Reputation: 81
OK, I'll try that. I must say, though, that I'm concerned that I'll have the "blank-screen-while-in-terminal" problem; also bootsplash (I believe) requires a framebuffer.

I'll give it a shot and report back.

--Dane
 
Old 01-31-2005, 05:38 PM   #6
DaneM
Member
 
Registered: Oct 2003
Location: Chico, CA, USA
Distribution: Linux Mint
Posts: 745

Original Poster
Rep: Reputation: 81
Hello.

I followed your suggestion and recompiled the kernel without the frame buffer. The result was a blank screen while starting up and a nasty green one while logging out/shutting down.

Any more suggestions?

Thanks for your help.

--Dane
 
Old 02-02-2005, 04:08 PM   #7
DaneM
Member
 
Registered: Oct 2003
Location: Chico, CA, USA
Distribution: Linux Mint
Posts: 745

Original Poster
Rep: Reputation: 81
*bump*
 
Old 02-02-2005, 04:24 PM   #8
egag
Senior Member
 
Registered: Jul 2004
Location: Netherlands
Distribution: Slackware
Posts: 2,721

Rep: Reputation: 52
edit your lilo.conf and put in " vga=normal "
then rerun lilo and reboot.

egag
 
Old 02-02-2005, 06:10 PM   #9
DaneM
Member
 
Registered: Oct 2003
Location: Chico, CA, USA
Distribution: Linux Mint
Posts: 745

Original Poster
Rep: Reputation: 81
Hi, egag.

I tried what you told me, but to no avail. Upon logout I still got kicked back to an unusable tty1. Any more suggestions?

Thanks for your help.

--Dane
 
Old 02-02-2005, 06:23 PM   #10
egag
Senior Member
 
Registered: Jul 2004
Location: Netherlands
Distribution: Slackware
Posts: 2,721

Rep: Reputation: 52
well...rereading your first post i have.
a little time ago there was also a thread about unusable tty, and IIRC correct,
you should add an option in the graph " server " section of xorg.conf.

smth like : option <see next post>
( this is probably not correct )

if i can find it on this forum i'll post it ( if still needed )

egag

Last edited by egag; 02-02-2005 at 07:01 PM.
 
Old 02-02-2005, 07:00 PM   #11
egag
Senior Member
 
Registered: Jul 2004
Location: Netherlands
Distribution: Slackware
Posts: 2,721

Rep: Reputation: 52
well...you could try this :

---------------
# Nick 24/07/2004 - attempt to stop corruption exiting X
Option "ConnectedMonitor" "CRT"
Option "IgnoreDisplayDevices" "TV"
----------------

egag
 
Old 02-02-2005, 08:48 PM   #12
DaneM
Member
 
Registered: Oct 2003
Location: Chico, CA, USA
Distribution: Linux Mint
Posts: 745

Original Poster
Rep: Reputation: 81
Hello.

I tried what you suggested and added those lines to my /etc/X11/xorg.conf, but it didn't change anything other than the text resolution in the ttys. I'm beginning to think that it might be a problem with the configuration files, such as inittab or the rc.x files, or perhaps xorg.conf. What really puzzles me is:

1) Why are there only two ttys active: tty1 and tty6 (and tty7 if you count the GUI)? I found something in inittab mentioning this problem, but I can't really make heads or tails of it.

2) Why is it kicking me out to tty1 at all, when I would expect it just to stay in tty7?

Your suggestions are always appreciated.

--Dane
 
Old 02-02-2005, 10:13 PM   #13
carboncopy
Senior Member
 
Registered: Jan 2003
Location: Malaysia
Distribution: Fedora Core, Slackware, Mac OS X, Debian, OpenSUSE
Posts: 1,210
Blog Entries: 4

Rep: Reputation: 45
Hi DaneM,

Sorry for not warning you about the vga=normal thing. Slipped my mine. And was a way from my comp for couple of days.

Are you starting up in runlevel 3 or 4? By default, if you are using runlevel 4, there is only tty1 and tty6. But if you are using runlevel 3, you should have tty1 to 6 or more (not sure).
 
Old 02-02-2005, 10:24 PM   #14
DaneM
Member
 
Registered: Oct 2003
Location: Chico, CA, USA
Distribution: Linux Mint
Posts: 745

Original Poster
Rep: Reputation: 81
Welcome back, carboncopy!

I normally boot into init 3, but recently, in order to find ways to make Slackware easier for non-Linux people, I've been experimenting with init 4 so that I can have a graphical login.

Pretty much what I want to is

1) Have a pretty GUI login so people won't freak out at having to type "startx".

2) Have tty1-6 working in case something goes wrong. (Not essential, but definately nice,)

I figure that if Mandrake can do it, I should be able to do it with Slackware, right?

We're getting closer, I think...

--Dane
 
Old 02-03-2005, 08:38 PM   #15
DaneM
Member
 
Registered: Oct 2003
Location: Chico, CA, USA
Distribution: Linux Mint
Posts: 745

Original Poster
Rep: Reputation: 81
Update:

I went into /etc/inittab and changed these lines:

Code:
# These are the standard console login getties in multiuser mode:
     52 c1:1235:respawn:/sbin/agetty 38400 tty1 linux
     53 c2:1235:respawn:/sbin/agetty 38400 tty2 linux
     54 c3:1235:respawn:/sbin/agetty 38400 tty3 linux
     55 c4:1235:respawn:/sbin/agetty 38400 tty4 linux
     56 c5:1235:respawn:/sbin/agetty 38400 tty5 linux
     57 c6:12345:respawn:/sbin/agetty 38400 tty6 linux
to this:

Code:
# These are the standard console login getties in multiuser mode:
     52 c1:12345:respawn:/sbin/agetty 38400 tty1 linux
     53 c2:12345:respawn:/sbin/agetty 38400 tty2 linux
     54 c3:12345:respawn:/sbin/agetty 38400 tty3 linux
     55 c4:12345:respawn:/sbin/agetty 38400 tty4 linux
     56 c5:12345:respawn:/sbin/agetty 38400 tty5 linux
     57 c6:12345:respawn:/sbin/agetty 38400 tty6 linux
All the ttys work now, and when I logout, instead of getting an unusable prompt, I get a usable one. Still not what I'm going for, but I think it's a step in the right direction.

--Dane
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
alternatives to xdm, gdm, or kdm hdo781 Debian 1 02-02-2005 11:55 AM
gdm, kdm, xdm daemons, which do I need? Feldon Linux - Software 5 10-16-2004 10:56 PM
Cannot start xdm, kdm or gdm icisyd Linux - Newbie 13 09-23-2004 07:38 PM
kdm cannot login to KDE, but gdm and xdm work fine?? ming0 Slackware 2 09-01-2004 03:08 AM
X login screen XDM/KDM/GDM jesselong Linux - Software 4 06-12-2004 11:02 PM


All times are GMT -5. The time now is 02:24 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration