LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 09-07-2012, 08:43 PM   #1
staus
Member
 
Registered: Apr 2004
Posts: 66

Rep: Reputation: 2
How do I kill ipv6 in 64 bit Slack current?


I absolutely can't figure out how to keep the ipv6 module from loading.

I've edited /etc/modprobe.d/blacklist.conf, created /etc/modprobe.d/ipv6.conf, and edited lilo.conf with disable_ipv6=1.
Nothing stops the ipv6 module form loading.

My main gripe is that "slackpkg update" hangs resolving the mirror url for about 5 seconds or so, multiple times.

I want Slackware to run fast, not hang on something so silly.
Thanks for any ideas. A google search turned up solutions that didn't work.

Thanks for any help.
 
Old 09-07-2012, 09:13 PM   #2
Woodsman
Senior Member
 
Registered: Oct 2005
Distribution: Slackware 14.1
Posts: 3,482

Rep: Reputation: 534Reputation: 534Reputation: 534Reputation: 534Reputation: 534Reputation: 534
The following in /etc/modprobe.d/aliases.conf still works:

alias net-pf-10 off # INET6, IPv6 Protocol
 
Old 09-07-2012, 09:37 PM   #3
staus
Member
 
Registered: Apr 2004
Posts: 66

Original Poster
Rep: Reputation: 2
Thanks. This did indeed stop the ipv6 module being loaded.
But, the hangup resolving the slackpkg mirror is still happening.
It evidently wasn't the ipv6 module.

My work computer has the current 32 bit Slackware installed, and there is no delay resolving
the mirrors.

Another 64 bit mystery, I will probably never solve.
 
Old 09-07-2012, 09:49 PM   #4
wildwizard
Member
 
Registered: Apr 2009
Location: Oz
Distribution: slackware64-14.0
Posts: 755

Rep: Reputation: 226Reputation: 226Reputation: 226
So what is the contents of /etc/resolv.conf when you have this problem?
 
Old 09-08-2012, 12:26 AM   #5
kikinovak
Senior Member
 
Registered: Jun 2011
Location: Montpezat (South France)
Distribution: Slackware, Slackware64
Posts: 1,602

Rep: Reputation: 742Reputation: 742Reputation: 742Reputation: 742Reputation: 742Reputation: 742Reputation: 742
Quote:
Originally Posted by staus View Post
I've edited /etc/modprobe.d/blacklist.conf, created /etc/modprobe.d/ipv6.conf, and edited lilo.conf with disable_ipv6=1.
Nothing stops the ipv6 module form loading.
The correct syntax is ipv6.disable=1. Works here.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to kill pids for all sessions for a specific user except their current one? jasonws Programming 3 10-22-2010 03:39 PM
Slack64-current - CTRL-ALT-BACKSPACE doesn't kill X GrapefruiTgirl Slackware 8 08-29-2009 09:32 AM
slackware current ipv6 mattydee Slackware 3 05-24-2009 06:34 PM
updating Slack 10.2 with slack-current isos nacha Slackware 2 06-02-2006 08:52 PM
current Slack-Current giving troubles? r_jensen11 Slackware 5 02-02-2004 05:08 PM


All times are GMT -5. The time now is 09:17 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration