LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   How do I kill ipv6 in 64 bit Slack current? (http://www.linuxquestions.org/questions/slackware-14/how-do-i-kill-ipv6-in-64-bit-slack-current-4175426187/)

staus 09-07-2012 08:43 PM

How do I kill ipv6 in 64 bit Slack current?
 
I absolutely can't figure out how to keep the ipv6 module from loading.

I've edited /etc/modprobe.d/blacklist.conf, created /etc/modprobe.d/ipv6.conf, and edited lilo.conf with disable_ipv6=1.
Nothing stops the ipv6 module form loading.

My main gripe is that "slackpkg update" hangs resolving the mirror url for about 5 seconds or so, multiple times.

I want Slackware to run fast, not hang on something so silly.
Thanks for any ideas. A google search turned up solutions that didn't work.

Thanks for any help.

Woodsman 09-07-2012 09:13 PM

The following in /etc/modprobe.d/aliases.conf still works:

alias net-pf-10 off # INET6, IPv6 Protocol

staus 09-07-2012 09:37 PM

Thanks. This did indeed stop the ipv6 module being loaded.
But, the hangup resolving the slackpkg mirror is still happening.
It evidently wasn't the ipv6 module.

My work computer has the current 32 bit Slackware installed, and there is no delay resolving
the mirrors.

Another 64 bit mystery, I will probably never solve.

wildwizard 09-07-2012 09:49 PM

So what is the contents of /etc/resolv.conf when you have this problem?

kikinovak 09-08-2012 12:26 AM

Quote:

Originally Posted by staus (Post 4775365)
I've edited /etc/modprobe.d/blacklist.conf, created /etc/modprobe.d/ipv6.conf, and edited lilo.conf with disable_ipv6=1.
Nothing stops the ipv6 module form loading.

The correct syntax is ipv6.disable=1. Works here.


All times are GMT -5. The time now is 11:16 PM.