Review your favorite Linux distribution.
Go Back > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Slackware This Forum is for the discussion of Slackware Linux.


  Search this Thread
Old 11-17-2013, 04:29 AM   #1
Registered: Sep 2012
Posts: 118

Rep: Reputation: Disabled
Post hdmi audio on cards using the radeon module

If you had hdmi audio working in Slackware 14.0 and it not working in 14.1 with your card that uses the radeon module, you probably need to load the module with the argument.
If you load it from initrd you might have to modify /boot/initrd-tree/load_kernel_modules and rebuild your initrd, and update lilo.

Somewhere along the line of kernels between 3.2 and 3.10 it started defaulting to disabled. Lots about that on Google. I had trouble finding the cause because appears to work, alsa will show the audio card present and the hdmi subdevice even when disabled. So I thought I'd share here. Audio applications will appear to be playing you just won't hear anything. I can't find anything that indicates its disabled, but don't be fooled. Make sure the argument is passed and suddenly everything works.
Old 11-18-2013, 04:26 AM   #2
LQ Guru
Registered: Oct 2003
Posts: 5,067

Rep: Reputation: Disabled

do you mean a bootloader parameter of ?
as per
Old 11-18-2013, 06:24 PM   #3
Registered: Sep 2012
Posts: 118

Original Poster
Rep: Reputation: Disabled
I had to add it to modify


and enter the argument as just audio=1 not

then rebuild the initrd, ( just calling makeinitrd with no arguments )

I was unsuccessful passing the arguments on the append line in lilo.conf's global section as well as the addappend line in my kernel stanza. YMMV. If you are able to get it work via the bootloader like in the blog post you mentioned let me know, maybe I am doing something wrong, but I can't imagine what. It would be preferable to use the bootloader so as to avoid needing to alter initrd files.


audio, hdmi, radeon

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
HDMI, two Radeon graphic cards sw@x Linux - Laptop and Netbook 9 07-16-2013 06:09 AM
LXer: Radeon DRM Finally Has HD 6000 Series HDMI Audio LXer Syndicated Linux News 0 06-19-2012 07:40 AM
HDMI Audio doesn't work - Debian Squeeze (Intel HDMI) felipefv Linux - Hardware 8 02-06-2012 10:47 AM
LXer: New Radeon HDMI Audio Patches Published LXer Syndicated Linux News 0 12-08-2011 08:31 PM
ATI Radeon $200 onboard HDMI audio issue on slackware64/kde4 Sm0k3 Slackware 2 12-24-2009 12:15 PM

All times are GMT -5. The time now is 03:43 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration