LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   hdmi audio on cards using the radeon module (http://www.linuxquestions.org/questions/slackware-14/hdmi-audio-on-cards-using-the-radeon-module-4175484879/)

chemfire 11-17-2013 04:29 AM

hdmi audio on cards using the radeon module
 
If you had hdmi audio working in Slackware 14.0 and it not working in 14.1 with your card that uses the radeon module, you probably need to load the module with the argument.
Code:

audio=1
If you load it from initrd you might have to modify /boot/initrd-tree/load_kernel_modules and rebuild your initrd, and update lilo.

Somewhere along the line of kernels between 3.2 and 3.10 it started defaulting to disabled. Lots about that on Google. I had trouble finding the cause because appears to work, alsa will show the audio card present and the hdmi subdevice even when disabled. So I thought I'd share here. Audio applications will appear to be playing you just won't hear anything. I can't find anything that indicates its disabled, but don't be fooled. Make sure the argument is passed and suddenly everything works.

aus9 11-18-2013 04:26 AM

Hi

Quote:

audio=1
do you mean a bootloader parameter of ?
Quote:

radeon.audio=1
as per http://dananickerson.wordpress.com/

chemfire 11-18-2013 06:24 PM

I had to add it to modify

/boot/initrd-tree/load_kernel_modules

and enter the argument as just audio=1 not radeon.audio=1

then rebuild the initrd, ( just calling makeinitrd with no arguments )

I was unsuccessful passing the arguments on the append line in lilo.conf's global section as well as the addappend line in my kernel stanza. YMMV. If you are able to get it work via the bootloader like in the blog post you mentioned let me know, maybe I am doing something wrong, but I can't imagine what. It would be preferable to use the bootloader so as to avoid needing to alter initrd files.


All times are GMT -5. The time now is 08:40 AM.