LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 09-27-2006, 03:15 AM   #1
mahdif
Member
 
Registered: Sep 2006
Distribution: Slackware
Posts: 75

Rep: Reputation: 15
Gslapt problem on Slackware 10.2


Hi

When I run gslapt(which i instlled via slapt-get) as root, i get the following error message:

Xlib: connection to ":0.0" refused by server
Xlib: No protocol specified


(gslapt:8900): Gtk-WARNING **: cannot open display:


any ideas?
 
Old 09-27-2006, 11:23 AM   #2
vharishankar
Senior Member
 
Registered: Dec 2003
Posts: 3,142
Blog Entries: 4

Rep: Reputation: 121Reputation: 121
Try launching it using something like kdesu or sux rather than su.
 
Old 09-27-2006, 06:47 PM   #3
konsolebox
Senior Member
 
Registered: Oct 2005
Distribution: Gentoo, Slackware, LFS
Posts: 2,245
Blog Entries: 15

Rep: Reputation: 233Reputation: 233Reputation: 233
perhaps you haven't configured x to run in root. try to run x as a user then su or sudo in a terminal like xterm or konsole.
 
Old 09-27-2006, 08:05 PM   #4
pbhj
Member
 
Registered: Dec 2002
Location: UK
Distribution: Slackware 12; Ubuntu 7.10
Posts: 358

Rep: Reputation: 31
allow access to X from other hosts

You're trying to run it using from a user X session, yeah?

You need to do, as user ($):
Code:
xhost +
That enables all users to access the current X session, you can do "xhost localhost" instead if you're concerned about security. I have this is one the bash RC files.

To switch access off again do "xhost -"
 
Old 09-30-2006, 02:45 AM   #5
mahdif
Member
 
Registered: Sep 2006
Distribution: Slackware
Posts: 75

Original Poster
Rep: Reputation: 15
I solved the problem. I edited the K menu and configured Gslapt to be run as root!
Thanks for your help!
 
Old 08-28-2011, 05:50 PM   #6
Geremia
Member
 
Registered: Apr 2011
Distribution: Slackware 14.1
Posts: 208

Rep: Reputation: 5
Quote:
Originally Posted by mahdif View Post
Hi

When I run gslapt(which i instlled via slapt-get) as root, i get the following error message:

Xlib: connection to ":0.0" refused by server
Xlib: No protocol specified


(gslapt:8900): Gtk-WARNING **: cannot open display:


any ideas?
I got this problem when increasing my runlevel from 3 to 4 in /etc/inittab.
 
  


Reply

Tags
connection, refused, xhost


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Gslapt/slapt-get upgraded packages saf Slackware 4 05-31-2006 12:34 AM
How to load installation programs from a CD using Gslapt. Manizales VectorLinux 3 04-07-2006 04:07 AM
slapt-get (gslapt) dhbiker Slackware 9 02-17-2006 03:27 AM
unable to use gslapt adityavpratap Slackware 3 11-20-2005 06:11 PM
Slackware 9.0 Lan Card problem and a problem adding a user! BmxFace Slackware 1 07-03-2003 07:05 PM


All times are GMT -5. The time now is 03:05 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration