LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 01-28-2014, 08:22 PM   #16
ReaperX7
Senior Member
 
Registered: Jul 2011
Distribution: LFS-SVN, Slackware-14.1, PCBSD-10.0
Posts: 2,883
Blog Entries: 15

Rep: Reputation: 743Reputation: 743Reputation: 743Reputation: 743Reputation: 743Reputation: 743Reputation: 743

Okay now that's puzzling...
 
Old 01-28-2014, 08:37 PM   #17
enorbet
Member
 
Registered: Jun 2003
Location: Virginia
Distribution: Slackware 14 is Main OpSys on Main PC, 2ndary are OpenSuSe 13 and SolydK
Posts: 674

Rep: Reputation: 268Reputation: 268Reputation: 268
Since I'm just naturally curious, why do you reboot again once you boot in to a session that works?
 
Old 01-28-2014, 08:47 PM   #18
tb75252
Member
 
Registered: Oct 2010
Distribution: Slackware 14.1 (64-bit)
Posts: 91

Original Poster
Rep: Reputation: 2
Quote:
Originally Posted by enorbet View Post
Since I'm just naturally curious, why do you reboot again once you boot in to a session that works?
The first and second reboots allowed me to listen to Internet music using Soma which is a stream player that can be launched via the command line. But I wanted to listen to either AccuRadio.com or Pandora.com using Firefox.
 
Old 01-28-2014, 09:47 PM   #19
ReaperX7
Senior Member
 
Registered: Jul 2011
Distribution: LFS-SVN, Slackware-14.1, PCBSD-10.0
Posts: 2,883
Blog Entries: 15

Rep: Reputation: 743Reputation: 743Reputation: 743Reputation: 743Reputation: 743Reputation: 743Reputation: 743
At this point, I'm thinking this is an ALSA/dmix related issue. The audio should just work without a problem.

Although this may seem a radical solution, it did work for me on LFS.

Try installing PulseAudio. Normally this is generally a terrible idea, but the SBo for this is a clean implementation over ALSA and dmix, so it should work well. PulseAudio will auto-direct a lot of audio around your system to the appropriate output channels using it's audio output management daemon.

The SBo to build the package is located here:

http://slackbuilds.org/repository/14...io/pulseaudio/

Then delete the modules.conf and .asoundrc files

The only other solution I can think of would be to update the kernel and chance a fix that way, or blacklist out ALSA and install the OSSv4 drivers and see how they fair.

Last edited by ReaperX7; 01-28-2014 at 09:55 PM.
 
Old 01-30-2014, 09:21 PM   #20
tb75252
Member
 
Registered: Oct 2010
Distribution: Slackware 14.1 (64-bit)
Posts: 91

Original Poster
Rep: Reputation: 2
Quote:
Originally Posted by ReaperX7 View Post
At this point, I'm thinking this is an ALSA/dmix related issue. The audio should just work without a problem.

Although this may seem a radical solution, it did work for me on LFS.

Try installing PulseAudio. Normally this is generally a terrible idea, but the SBo for this is a clean implementation over ALSA and dmix, so it should work well. PulseAudio will auto-direct a lot of audio around your system to the appropriate output channels using it's audio output management daemon.

The SBo to build the package is located here:

http://slackbuilds.org/repository/14...io/pulseaudio/

Then delete the modules.conf and .asoundrc files

The only other solution I can think of would be to update the kernel and chance a fix that way, or blacklist out ALSA and install the OSSv4 drivers and see how they fair.
Well, that did not make an iota of difference... I'm almost inclined to reinstall Slackware and see if things get better! Maybe something went wrong during the first installation.
 
Old 01-30-2014, 10:10 PM   #21
D1ver
Member
 
Registered: Jan 2010
Distribution: Slackware 13.37
Posts: 527
Blog Entries: 3

Rep: Reputation: 126Reputation: 126
I had a similar problem which I discussed in a little blog post here..

Try adding a file to /etc/modprobe.d/ called 'snd_virtuoso.conf' with the line
Code:
options snd slot=snd_virtuoso,snd_hda_intel
Then rename/delete the /etc/asound.conf and reboot and cross your fingers..
 
Old 01-30-2014, 10:18 PM   #22
Drakeo
Senior Member
 
Registered: Jan 2008
Location: Urbana IL
Distribution: Slackware, Slacko,
Posts: 2,455
Blog Entries: 3

Rep: Reputation: 182Reputation: 182
this is the kde environment I am sure you went into setting and set default Right . Then I am sure I hope you then applied it to your device list per per application in settings right. When you are sure you have that set up. So then I am not sure.

because if you don't save to those device list per application then you can have the problems with the .kde/share/config/kmixrc , I always get with multiple sound device kde likes to read alsa and change to what alsa default or config is. . just my 2 cents
 
Old 01-30-2014, 10:51 PM   #23
tb75252
Member
 
Registered: Oct 2010
Distribution: Slackware 14.1 (64-bit)
Posts: 91

Original Poster
Rep: Reputation: 2
Quote:
Originally Posted by D1ver View Post
I had a similar problem which I discussed in a little blog post here..

Try adding a file to /etc/modprobe.d/ called 'snd_virtuoso.conf' with the line
Code:
options snd slot=snd_virtuoso,snd_hda_intel
Then rename/delete the /etc/asound.conf and reboot and cross your fingers..
Unfortunately it does not work.
 
Old 01-30-2014, 11:28 PM   #24
ReaperX7
Senior Member
 
Registered: Jul 2011
Distribution: LFS-SVN, Slackware-14.1, PCBSD-10.0
Posts: 2,883
Blog Entries: 15

Rep: Reputation: 743Reputation: 743Reputation: 743Reputation: 743Reputation: 743Reputation: 743Reputation: 743
At this point... you may have only one option...

OSSv4.

Now granted this driver isn't as difficult to use as ALSA, but it does require extra steps to get working, but it MAY solve your problems... but I won't guarantee it. It could just be a problem with the ALSA audio stack, the sound card, or who knows what.

You'll need all of these at least to get OSSv4 to install on Slackware with the latest kernel.

1. The SlackBuild

http://slackbuilds.org/repository/14.1/system/oss/

2. Kernels up to version 3.13 patch...

Code:
diff -ur oss-v4.2-build2008-src-gpl.orig/setup/Linux/oss/build/osscore.c oss-v4.2-build2008-src-gpl/setup/Linux/oss/build/osscore.c
--- oss-v4.2-build2008-src-gpl.orig/setup/Linux/oss/build/osscore.c	2013-11-06 22:22:05.760399613 +0400
+++ oss-v4.2-build2008-src-gpl/setup/Linux/oss/build/osscore.c	2013-11-06 22:34:41.908792755 +0400
@@ -436,11 +436,15 @@
 int
 oss_get_uid (void)
 {
+#if LINUX_VERSION_CODE >= KERNEL_VERSION(3,13,0)
+  return __kuid_val(current->cred->uid);
+#else
 #if LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,29)
   return current->cred->uid;
 #else
   return current->uid;
 #endif
+#endif
 }
 
 typedef struct tmout_desc
If this doesn't work, I honestly don't know any more tricks to get your audio fully working. You'll have to block and blacklist ALSA, but OSSv4 works really well, and some people actually say it works better than ALSA.
 
Old 01-30-2014, 11:50 PM   #25
Daedra
Senior Member
 
Registered: Dec 2005
Location: Springfield, MO
Distribution: Slackware64-14.1
Posts: 1,216

Rep: Reputation: 177Reputation: 177
Quote:
Originally Posted by tb75252 View Post
Unfortunately it does not work.
Try Adding options snd_virtuoso index=0 to the snd_virtuoso.conf file, might not work but give it a try.
 
Old 01-31-2014, 06:04 AM   #26
ReaperX7
Senior Member
 
Registered: Jul 2011
Distribution: LFS-SVN, Slackware-14.1, PCBSD-10.0
Posts: 2,883
Blog Entries: 15

Rep: Reputation: 743Reputation: 743Reputation: 743Reputation: 743Reputation: 743Reputation: 743Reputation: 743
The strange thing I find is, I have the PCIe edition of that card the Xonar DX PCIe 7.1. When I've used it I've never had any issues getting audio to work correctly unless it was multi-source audio. PulseAudio cleared it up on LFS and Slackware both using the channel routing mixer provided by Pulse. It also worked well with OSS's mixer using the OSSv4 driver.

I know that Adobe Flash can require using HAL still, though it can be easily installed from the 13.37 repository, but usually that's for DRM which is completely unrelated though.

I do know that when I did use KDE, phonon didn't like to play well with setting up multi-source audio, so I used Xfce which uses GStreamer and it tended to work fine.

It very well could be Phonon causing the problems now that I think about it.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
IPTABLES frustration vonedaddy Linux - Newbie 4 02-26-2010 12:44 PM
samba frustration solar1951 Linux - Networking 9 07-18-2007 05:04 AM
Emacs Frustration skibud2 Linux - Software 1 09-17-2003 10:36 PM
PPP Frustration cocoanutmaster Linux - Networking 1 11-21-2002 03:46 PM
~sobbing in frustration~ novicered Linux - Software 5 11-14-2001 11:46 PM


All times are GMT -5. The time now is 10:20 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration