LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 11-15-2010, 11:28 PM   #1
Jack128
Member
 
Registered: Feb 2009
Location: Germany
Distribution: Slackware64 Current
Posts: 90

Rep: Reputation: 22
Question Fonts Issue after Current Update on 20101114


Hello,
I just upgraded my Current64 box, and now I got strange
Sans Serif fonts, Devaju Sans seems to be the same, if
I change it on the KDE settings. The really strange thing
is, I had run latest X.Org-Testing from Robby, so the font-
versions are equal. I run KDE 4.5.3, alienbob's build, and
Multilib current stage.

Thanks for any kind of infos. =)
Regards, Jack.
 
Click here to see the post LQ members have rated as the most helpful post in this thread.
Old 11-15-2010, 11:34 PM   #2
Daedra
Senior Member
 
Registered: Dec 2005
Location: Springfield, MO
Distribution: Slackware64-14.1
Posts: 1,222

Rep: Reputation: 177Reputation: 177
Maybe the update changed your font DPI? edit /usr/bin/startx and add the line defaultserverargs="-dpi 96" and see if that fixes the problem.
 
Old 11-16-2010, 12:28 AM   #3
stormtracknole
Member
 
Registered: Aug 2005
Location: The Big Easy
Distribution: Slackware, RHEL
Posts: 817

Rep: Reputation: 104Reputation: 104
Try reverting back to the previous freetype package and see if that helps.
 
Old 11-16-2010, 06:24 AM   #4
55020
Member
 
Registered: Sep 2009
Location: Yorks. W.R. 167397
Distribution: Slackware
Posts: 365
Blog Entries: 4

Rep: Reputation: 330Reputation: 330Reputation: 330Reputation: 330
Don't revert the freetype package. The general idea of reverting the freetype package is to go back to autohints, but you can tell the new freetype package to autohint with just --

Code:
cd /etc/fonts/conf.d
ln -s ../fonts.avail/10-autohint.conf .
You probably also want to do this, particularly if you previously installed webcore-fonts from SBo --

Code:
rm 60-liberation.conf
It'll all take effect when you restart X. Either log out and log in again, or reboot if you're uncertain :-)

Last edited by 55020; 11-16-2010 at 06:26 AM.
 
3 members found this post helpful.
Old 11-16-2010, 06:42 AM   #5
stormtracknole
Member
 
Registered: Aug 2005
Location: The Big Easy
Distribution: Slackware, RHEL
Posts: 817

Rep: Reputation: 104Reputation: 104
Quote:
Originally Posted by 55020 View Post
Don't revert the freetype package. The general idea of reverting the freetype package is to go back to autohints, but you can tell the new freetype package to autohint with just --

Code:
cd /etc/fonts/conf.d
ln -s ../fonts.avail/10-autohint.conf .
You probably also want to do this, particularly if you previously installed webcore-fonts from SBo --

Code:
rm 60-liberation.conf

It'll all take effect when you restart X. Either log out and log in again, or reboot if you're uncertain :-)
Good info!! I will have to try that also since I reverted freetype as a temporary solution.
 
Old 11-16-2010, 06:58 AM   #6
bender647
LQ Newbie
 
Registered: May 2003
Location: Boston
Distribution: Slackware 10 on i486/586/PentiumM; Solaris 2.8 on sparc; FreeBSD on i686
Posts: 24

Rep: Reputation: 15
fontconfig broken with upgrade

It's amazing what an effect autohinting has: I thought fontconfig was completely ignoring my font choices but they just looked like crap.

Adding the following stanza to my ~/.fonts.conf file restored autohinting. I copied this from /etc/fonts/conf.avail/10-autohint.conf (I prefer to make aesthetic changes in my own directory rather than force them on everybody).

Code:
<fontconfig>
<!--  Use the Autohinter --> 
  <match target="font">
    <edit name="autohint" mode="assign"><bool>true</bool></edit>
  </match>
</fontconfig>

Last edited by bender647; 11-16-2010 at 07:20 AM.
 
Old 11-16-2010, 08:26 AM   #7
Jack128
Member
 
Registered: Feb 2009
Location: Germany
Distribution: Slackware64 Current
Posts: 90

Original Poster
Rep: Reputation: 22
Big thanks to everyone, for the fast help. =)
55020's solution worked quite well, now
it's looking good, such as before the update.

Best regards,
Jack.
 
Old 11-16-2010, 09:59 AM   #8
GazL
Senior Member
 
Registered: May 2008
Posts: 3,392

Rep: Reputation: 917Reputation: 917Reputation: 917Reputation: 917Reputation: 917Reputation: 917Reputation: 917Reputation: 917
I've just been working through some of the options in XFCE's appearance settings which is a good way to see which fonts look good with various settings of anti-alias, hinting, and sub-pixel order. Some of the fonts really don't do well with some of the combinations you can set.

I used to use DejaVu Sans as I've always liked the way it looks, but it seems to be missing a 'regular' style now and I can't get a decent display with it no matter what combination of settings I use.

Liberation Sans 10, anti-aliased, slight hinting, subpixel-none seems to be working reasonably for me at the moment. If I turn hinting up to medium or high, bold text looks better but normal text gets a little too thin for my liking.

Now, I just need to see if I can adjust the fonts/conf.d to use similar settings outside of XFCE.

Last edited by GazL; 11-16-2010 at 04:40 PM.
 
Old 12-09-2010, 01:53 AM   #9
veeall
Member
 
Registered: May 2007
Location: Estonia
Distribution: Slackware 12.1, slackware64-current
Posts: 255

Rep: Reputation: 43
Quote:
Originally Posted by 55020 View Post
ln -s ../fonts.avail/10-autohint.conf .
The directory should probably be /etc/fonts/conf.avail/ - nevertheless downgrading freetype worked better here since it also reverted opera menu fonts to look normal.

Here are couple of screenshots. With the new freetype:
http://www.upload.ee/image/973444/pilt1.png

With freetype from slack 13.1:
http://www.upload.ee/image/973445/pilt2.png

IMHO, the last one is much better. At 96 dpi, when using font sizes above 8 pt, the new fonts doesn't look as horribly hinted as at 8 pt, though.

Last edited by veeall; 12-09-2010 at 01:55 AM.
 
Old 02-11-2011, 09:20 AM   #10
lemmens
LQ Newbie
 
Registered: Jan 2005
Location: netherlands
Distribution: slackware64 13.37 + current
Posts: 22

Rep: Reputation: 1
Thanks a lot for this nice (auto) hint :-)

I installed Slack current and searched for a day why my (KDE) fonts suddenly looked so ugly. But when I stumbled upon this thread and just did the following (as root) :

cd /etc/fonts/conf.d
ln -s ../conf.avail/10-autohint.conf .

everything worked perfectly well again and my fonts are just as nice as before !

Kees L

Last edited by lemmens; 02-11-2011 at 09:23 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Tiny fonts in program menus, etc on current. Mol_Bolom Slackware 2 02-01-2010 10:37 PM
Ghostscript fonts in Slackware current allend Slackware 3 09-07-2007 08:53 AM
Open Office fonts in -current dive Slackware 4 05-09-2007 11:30 AM
Current status of True Type fonts issue ronaldv General 4 10-12-2004 04:35 AM
Having Issue w/ Truetype fonts - Mozilla Issue clove Linux - Software 4 02-18-2004 08:26 AM


All times are GMT -5. The time now is 10:44 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration