LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 01-12-2004, 03:47 AM   #1
Fr33B33R
LQ Newbie
 
Registered: Jan 2004
Posts: 5

Rep: Reputation: 0
FATAL: could not load /lib/modules/2.6.1/modules.dep


Hi,

I just compiled and installed 2.6.1 for the first time. I have never compiled a kernel before so I didn't know which options in menuconfig would be mandatory or useful.

Anyhow, my system works, but, I get a warning:

FATAL: could not load /lib/modules/2.6.1/modules.dep : No such file or directory
FATAL: could not load /lib/modules/2.6.1/modules.dep : No such file or directory

(yes, repeated twice)


Is this as fatal as the name implies? IIRC, I compiled using the new loadable/unloadable modules option. Could that be the issue?
 
Old 01-12-2004, 05:07 AM   #2
kadaver
Member
 
Registered: Nov 2003
Location: Beautiful Northern-sweden (Luleň)
Posts: 90

Rep: Reputation: 15
Had the same problem.
This might be related to the depmod command. I had this in my /etc/rc.d/rc.modules:

'depmod -a'

If it isn't there try a:

'cat /etc/rc.d/* | grep depmod'

Or you might want to check the error logs in /var/log for more information...
I commented it out since the kernel loads all the modules it needs anyway so depmod is unessesary. Worked like a charm.
Cheers!
 
Old 01-12-2004, 05:11 AM   #3
kadaver
Member
 
Registered: Nov 2003
Location: Beautiful Northern-sweden (Luleň)
Posts: 90

Rep: Reputation: 15
BTW
Check out /usr/doc/Linux-HOWTOs/Kernel-HOWTO if you want to learn some more!
 
Old 01-12-2004, 05:40 AM   #4
Fr33B33R
LQ Newbie
 
Registered: Jan 2004
Posts: 5

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by kadaver
Had the same problem.
This might be related to the depmod command. I had this in my /etc/rc.d/rc.modules:

'depmod -a'

If it isn't there try a:

'cat /etc/rc.d/* | grep depmod'

Or you might want to check the error logs in /var/log for more information...
I commented it out since the kernel loads all the modules it needs anyway so depmod is unessesary. Worked like a charm.
Cheers!
In file /etc/rc.d/rc.modules there is "/sbin/depmod -a" on row 34 and "/sbin/depmod -A" on row 40 (note the capital letter A; is that a problem?).

I need to check the link you gave me to see what that means... Tjena!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
modprobe: FATAL: Could not load /lib/modules/.../modules.dep Ankardo Debian 9 02-01-2011 05:09 PM
/lib/modules/2.6.8/modules.dep not found killer_bunny Debian 1 10-17-2004 10:06 PM
Compile Error- /lib/modules/extra/modules.dep UpChuck Debian 2 01-11-2004 10:20 AM
/etc/conf.modules is more recent than /lib/module/2.2.15-4mdk/modules.dep Derek-kun Linux - Newbie 3 09-26-2003 02:56 AM
Slack9 - no PPP (can't open dependencies file /lib/modules/2.4.18/modules.dep) bluehz Slackware 1 05-04-2003 02:32 PM


All times are GMT -5. The time now is 04:30 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration