LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 06-19-2005, 04:42 PM   #1
Ankardo
LQ Newbie
 
Registered: Jun 2005
Distribution: Debian
Posts: 6

Rep: Reputation: 0
modprobe: FATAL: Could not load /lib/modules/.../modules.dep


No such file or directory.
What I have done:
- installed source packet for kernel-2.6.8.
- edited (make xconfig) config-2.6.8-2-k7 that is the kernel version I use
- followed literally instructions in Creating custom kernels wit Debian's kernel-package system

I am using grup boot loader.

The above mentioned guide does not mentioned initrd.img. Ok withour initrd.img
I got error "cannot open root device hda1. Please append a correct root= boot option.

So I figured that I need initrd.img which I made using mkinitrd -o initrd.img-custom.version
and edited grubs accordingly.

No I'll get error
modprobe: FATAL: Could not load /lib/modules/2.6.8.custem/modules.deb, no such
file or directory.
Kernel PANIC....

Well, modules dep definetely exist in that directory.

I can boot to 2.6.8-2-k7 with no problem, which I have installed from binary package.
I must not be the first person to encounter this problem (am I stupid or what) but
I was able to find only one portugease page where this problem was addressed
and I didn't understand a bit of it :-(

I have spent evenings now and tried nearly everything except the right way
and I'm becoming a little bit desperate. Custom kernel making cannot be
this difficult. I must have missed something trivial but I cannot figure out what.
Any ideas what I am missing????
 
Old 06-19-2005, 05:12 PM   #2
Noth
Member
 
Registered: Jun 2005
Distribution: Debian
Posts: 356

Rep: Reputation: 30
modprobe should not trying to load modules.dep, it's dependency information not a module.

Default Debian kernels make everything a module, if you didn't create an initrd you'll need to go through and make sure your storage controller's driver is compiled statically into your kernel.
 
Old 07-24-2005, 08:37 AM   #3
Bonch
Member
 
Registered: Oct 2004
Location: Estonia
Distribution: Debian - sarge
Posts: 38

Rep: Reputation: 15
I have the same problem,
I have installed 2.6.12 kernel and made initrd file and it all worked, but after I reinstalled linux and tried to build the same kernel source with the same .config file it gave me an error when I tried to execute initrd -o /boot/initrd.img-2.6.12-2-386 2.6.12.2 command. After that error when I try to boot my new kernel it starts booting and gives me an error "modprobe: FATAL: Could not load /lib/modules/2.6.8.custem/modules.deb, no such
file or directory. " for about a 30 sec and than booting goes ahead and in the end system became totally operatable
 
Old 02-10-2007, 06:20 AM   #4
ChristofArn
LQ Newbie
 
Registered: Feb 2007
Location: In the middle of the mountains of switzerland
Distribution: Debian, Ubuntu, Kanotix
Posts: 2

Rep: Reputation: 0
Use initramfs instead of initrd

I had the same error message, so I suppose, it's the same problem.

I solved it by using initramfs instead of initrd.

I read the previous error messages, befor "modprobe: FATAL: Could not load /lib/modules". I saw, that this error might have occured because the file system couldn't be mounted.

On http://de.wikipedia.org/wiki/Initramfs (this is a german article, in the English wikipedia, this article is missing) I found, that initrd only works, if the drivers for the file system are fix compiled into the kernel. Initrd will not work, if the needed drivers are compiled as modules - and compiling as modules is the standard in most kernels, I learnt.

Initramfs is the successor of initrd. It works independently from this question. So I installed the debian-package "inintramfs-tools".
Within the folder, where my kernel-sources are (don't know, if this is nessecary), I did
Code:
update-inintramfs -c -k 2.6.20
-c says: create (a inintramfs)
-k XYZ says, for whitch Kernel the initramfs should be created.
(Note: There is an other tool named "mkinintramfs". I didn't use it, because it's recommended only for advanced users. "update-inintramfs" is recommended for people like I am.)

Then, I found a new file named "initrd.img-2.6.20" in /boot/.
I inserted
Code:
initrd        /boot/initrd.img-2.6.20
into my file /boot/grub/menu.1st

- and it worked.

Last edited by ChristofArn; 02-10-2007 at 01:09 PM.
 
Old 03-10-2007, 02:07 AM   #5
rmwilliamsjr
LQ Newbie
 
Registered: Mar 2007
Posts: 1

Rep: Reputation: 0
thank you

Quote:
Originally Posted by ChristofArn
I had the same error message, so I suppose, it's the same problem.

I solved it by using initramfs instead of initrd.

I read the previous error messages, befor "modprobe: FATAL: Could not load /lib/modules". I saw, that this error might have occured because the file system couldn't be mounted.


Initramfs is the successor of initrd. It works independently from this question. So I installed the debian-package "inintramfs-tools".
Within the folder, where my kernel-sources are (don't know, if this is nessecary), I did
Code:
update-inintramfs -c -k 2.6.20
-c says: create (a inintramfs)
-k XYZ says, for whitch Kernel the initramfs should be created.
(Note: There is an other tool named "mkinintramfs". I didn't use it, because it's recommended only for advanced users. "update-inintramfs" is recommended for people like I am.)
thank you very much.
your message was the first hit on google for lib/kernel/XXX/modules.dep not found.
and it was certainly correct in my case as well.
another satisfied customer....

rmwilliamsjr
in Tucson in the sonoran desert, SouthWest US.
march the 10th and it is supposed to be 95F today.
you just gotta love these winters and spring.!!
 
Old 03-10-2007, 03:57 AM   #6
AwesomeMachine
Senior Member
 
Registered: Jan 2005
Location: USA and Italy
Distribution: Debian jessie/sid; OpenSuSE; Fedora
Posts: 1,593

Rep: Reputation: 162Reputation: 162
Yaird works like this:

apt-get install yaird

yaird --output=/boot/initrd.img-2.6.xy.z<space>2.6.xy.z

Yaird uses the /lib/modules directory specified after <space> to build the image.
 
Old 03-07-2009, 08:24 AM   #7
sdpq
LQ Newbie
 
Registered: Mar 2009
Location: china
Distribution: debian
Posts: 1

Rep: Reputation: 0
Quote:
Originally Posted by ChristofArn View Post
I had the same error message, so I suppose, it's the same problem.

Code:
update-inintramfs -c -k 2.6.20
-c says: create (a inintramfs)
-k XYZ says, for whitch Kernel the initramfs should be created.
- and it worked.
thank you
but i must use "t" option, like this:
update-inintramfs2. -c -k 6.28.7 -t
(i compile 2.6.28.7 and use debian squeeze testing)
 
Old 10-06-2009, 07:12 AM   #8
auroches
LQ Newbie
 
Registered: Jul 2009
Distribution: Debian
Posts: 2

Rep: Reputation: 0
Thank you very much I solved 3 nigthed problem
 
Old 06-23-2010, 07:48 AM   #9
fbcyborg
LQ Newbie
 
Registered: May 2010
Posts: 17

Rep: Reputation: 0
Hello!

I had the same problem on Debian 5.04 i386, compiling a new vanilla kernel 2.6.33.5. I compiled the filesystem ext3 support as built-in, but nothing has changed. The modules.dep file cannot be read even if it is right there! How can this problem be solved?
 
Old 02-01-2011, 06:09 PM   #10
tombelcher7
Member
 
Registered: Feb 2008
Location: Surrey
Distribution: Debian
Posts: 184

Rep: Reputation: 5
Typo

I think you have a typo on the following code:

Code:
update-inintramfs -c -k 2.6.20
I think you mean:

Code:
update-initramfs -c -k 2.6.20
Quote:
Originally Posted by ChristofArn View Post
I had the same error message, so I suppose, it's the same problem.

I solved it by using initramfs instead of initrd.

I read the previous error messages, befor "modprobe: FATAL: Could not load /lib/modules". I saw, that this error might have occured because the file system couldn't be mounted.

On http://de.wikipedia.org/wiki/Initramfs (this is a german article, in the English wikipedia, this article is missing) I found, that initrd only works, if the drivers for the file system are fix compiled into the kernel. Initrd will not work, if the needed drivers are compiled as modules - and compiling as modules is the standard in most kernels, I learnt.

Initramfs is the successor of initrd. It works independently from this question. So I installed the debian-package "inintramfs-tools".
Within the folder, where my kernel-sources are (don't know, if this is nessecary), I did
Code:
update-inintramfs -c -k 2.6.20
-c says: create (a inintramfs)
-k XYZ says, for whitch Kernel the initramfs should be created.
(Note: There is an other tool named "mkinintramfs". I didn't use it, because it's recommended only for advanced users. "update-inintramfs" is recommended for people like I am.)

Then, I found a new file named "initrd.img-2.6.20" in /boot/.
I inserted
Code:
initrd        /boot/initrd.img-2.6.20
into my file /boot/grub/menu.1st

- and it worked.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
FATAL: could not load /lib/modules/2.6.1/modules.dep Fr33B33R Slackware 3 01-12-2004 06:40 AM
/etc/conf.modules is more recent than /lib/module/2.2.15-4mdk/modules.dep Derek-kun Linux - Newbie 3 09-26-2003 03:56 AM
Slack9 - no PPP (can't open dependencies file /lib/modules/2.4.18/modules.dep) bluehz Slackware 1 05-04-2003 03:32 PM
Re: modprobe: Note: /etc/modules.conf is more recent than lib/modules/2.4.9/modules.d Andy.M Linux - General 1 01-24-2002 02:50 AM
Re: modprobe: Note: /etc/modules.conf is more recent than lib/modules/2.4.9/modules.d Andy.M Linux - Newbie 2 01-24-2002 02:40 AM


All times are GMT -5. The time now is 05:29 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration