LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 12-20-2002, 02:10 AM   #1
deesto
Member
 
Registered: May 2002
Location: NY, USA
Distribution: FreeBSD, Fedora, RHEL, Ubuntu; OS X, Win; have used Slackware, Mandrake, SuSE, Xandros
Posts: 448

Rep: Reputation: 31
Enabling Slackware Configuration on Network Machines


I've enabled SSH on my Slack machine, and I've added my other network machines to the hosts and allow files. The Slack machine is a very slow, low memory machine, and I'd like to do some configuration via GUI, such as webmin and swat. I followed all the directions found for insalling and configuring these two apps out of the box, and can't get them to work via browser on the other machines: swat gives a "can't find host" error, and webmin gives "unauthorized".
However, SSH access does work on other machines, but it's ugly... have you ever tried to vi a Linux file from a Windows XP console via SSH? Not pretty.
Anyway, any experience in what I'd need to do to enable access from other machines?
 
Old 12-20-2002, 09:37 PM   #2
Excalibur
Senior Member
 
Registered: Jun 2002
Location: Northern VA, USA
Distribution: Ubuntu
Posts: 1,180

Rep: Reputation: 45
Simple fix .... trash the XP.

Sorry but I do not know about the webmin question. But in regards to SAMBA swat. It sounds like you haven't set up the /etc/inetd.conf file and the /etc/services file to enable the Slack box to startup swat on request.

The /etc/inetd.conf file should contain a line like the following:
swat stream tcp nowait.400 root /usr/sbin/swat swat
verify the path statement above.

The /etc/services file should contain a line the following:
swat 901/tcp # samba web configuration tool

They may be present but are remarked out. Then simply remove the hash from the front of the line. You need to SIGHUP the inetd daemon after the changes are made.

kill -s SIGHUP `cat /var/run/inetd.pid`

From the workstations, attempt to bring up swat using a normal browser by using the link to the Slack box IP address on port 901.

http://192.168.1.1:901 for an example.

Personally, I have never really liked swat because I thought it was too high of a security risk. But most, if not all, of my SAMBA installs are on server / gateways. I maintain the files from a console prompt using emacs, either local or remotely using ssh. I have all remote type services turned off except ssh. If your box is a gateway, then make sure the smb.conf includes the options to restrict the smb access to just the ethernet interface in use for the local network.

bind interfaces only = True
interfaces = eth1

I do not know if it will restrict swat to the inside network only since it is started via inetd. If I recall swat also requires root level login access and the password is sent clear channel. If you have problems with root login then you might check the /etc/securetty file to see if enabling anything in there might allow it.

Perhaps it will help some.
 
Old 12-21-2002, 01:56 AM   #3
figadiablo
Member
 
Registered: Feb 2002
Location: Virginia USA
Distribution: Slackware, CentOS, Fedora
Posts: 342

Rep: Reputation: 30
hi:
I don't know if you where able to solve your problems, but I though that this link might help you. Its a pretty good kind of samba mini how to. It will show you how to set it up quickly, including swat.
Hope that it helps.

Figa
 
Old 12-21-2002, 02:19 AM   #4
figadiablo
Member
 
Registered: Feb 2002
Location: Virginia USA
Distribution: Slackware, CentOS, Fedora
Posts: 342

Rep: Reputation: 30
oops wrong post

Last edited by figadiablo; 12-21-2002 at 02:38 AM.
 
Old 12-21-2002, 09:15 AM   #5
Mephisto
Member
 
Registered: Oct 2002
Location: Washington D.C, USA
Distribution: Slack 12, Etch, Gutsy
Posts: 453

Rep: Reputation: 30
vi works well for me from PuTTY on windows XP. vi does not work very well from Cygwin though. I find myself switching between the two depending on what I am doing.
 
Old 12-22-2002, 12:57 AM   #6
deesto
Member
 
Registered: May 2002
Location: NY, USA
Distribution: FreeBSD, Fedora, RHEL, Ubuntu; OS X, Win; have used Slackware, Mandrake, SuSE, Xandros
Posts: 448

Original Poster
Rep: Reputation: 31
Thanks all. Turns out that it seems the most important thing was to add "allow=" for each IP to specific config files for both webmin and swat, even if they're already in your hosts.allow file!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Slackware 10 network configuration. Problem with 8139 network card drivers ! Padmakiran Linux - Networking 8 03-27-2007 07:48 AM
slackware network configuration adsl shashank Linux - Software 2 05-31-2005 05:36 AM
enabling SMP on slackware 10 littleking Slackware 8 08-27-2004 12:30 PM
Network configuration with DHCP in Slackware 10 kernelvn Slackware 1 08-18-2004 06:52 AM
Slackware 9 PCI network card configuration Harpune Linux - Networking 2 08-26-2003 01:15 PM


All times are GMT -5. The time now is 10:48 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration