Review your favorite Linux distribution.
Go Back > Forums > Linux Forums > Linux - Software
User Name
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.


  Search this Thread
Old 05-30-2005, 05:51 AM   #1
Registered: Mar 2005
Posts: 30

Rep: Reputation: 15
slackware network configuration adsl



I have P4 845gl chipset
256mb ddram
56ksoftmodem (Internal)
Nvidia geforce fx 5200 videocard.
realtek RTL8139 family PCI fast ethernet NIC
ADSL modem broadband network connection
+standard multimedia goodies

All systems working OK with windows XP

I have installed slackware 10.1 and am trying to config my network for broadband access : Following is the diagnostic :

check 1 post install

lo Link encap:Local Loopback
inet addr: Mask:
RX packets:8 errors:0 dropped:0 overruns:0 frame:0
TX packets:8 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:680 (680.0 b) TX bytes:680 (680.0 b)

check 2 post install

root@darkstar:~# cd /sbin/route
-bash: cd: /sbin/route: Not a directory
root@darkstar:~# cd /sbin
root@darkstar:/sbin# route -n
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface U 0 0 0 lo

netconfig with static ip

ip address :
netmask :
gateway :
Name server :

probe for network card got message

Note: /etc/modules.conf is more recent than /lib/modules/2.4.29/modules.dep
/sbin/netconfig: line 473: 3915 Segmentation fault chroot . /sbin/modprobe $card 2>/dev/null
Note: /etc/modules.conf is more recent than /lib/modules/2.4.29/modules.dep

What I have done is that subsequent to installation I installed nvidia driver and oss3992d-linux-x86-v24.tar for sound system

What does this mean

Old 05-30-2005, 11:09 PM   #2
Registered: Aug 2003
Distribution: Slackware,Ubuntu
Posts: 389

Rep: Reputation: 30
what tools do you use for adsl setup?? i'm using adslsetup & it working great for me
Old 05-31-2005, 05:36 AM   #3
Registered: Mar 2005
Posts: 30

Original Poster
Rep: Reputation: 15
I use adsl setup

Another information when I use netconfig and setup static ip parameters, rtl8139too.o is recognized as the network card. when I boot normally into level 3, the system enters kernel panic error at /etc/rc.d/rc,netdevice segmenation fault line 4

What I have is an onboard ethernet card. Is this the problem?

I can successfully log into runlevel 1

Last edited by shashank; 05-31-2005 at 05:42 AM.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Slackware 10 network configuration. Problem with 8139 network card drivers ! Padmakiran Linux - Networking 8 03-27-2007 07:48 AM
Network configuration with DHCP in Slackware 10 kernelvn Slackware 1 08-18-2004 06:52 AM
ADSL configuration (Sagem f@ast 800 - Tiscali) Network driver? how do i configure? lucindatasker Linux - Software 3 04-16-2004 12:08 AM
Slackware 9 PCI network card configuration Harpune Linux - Networking 2 08-26-2003 01:15 PM
Enabling Slackware Configuration on Network Machines deesto Slackware 5 12-22-2002 12:57 AM

All times are GMT -5. The time now is 11:58 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration