LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 06-26-2013, 08:15 PM   #1
adelabarra
Member
 
Registered: May 2008
Location: Argentina
Distribution: Debian, Slackware
Posts: 49

Rep: Reputation: 3
Duplicate glib-2 and gtk


Dears Linux Questions:
I found this posted on another thread, but as nobody answered, I concluded that it was on the wrong place:

Quote:
Originally Posted by knudfl View Post
Glib-2.36.3 : Not a good idea to use "tomorrows version".
And some of your applications may not work with a version
different from the default installed.
Also searched on other places here LQ and on the WEB, but couldn't make a relevant conclusion:

I am installing pygobject, pycairo and pygtk on Slackware 10.1 - 2.6 Kernel
I've got installed two glib-2.0, one in:

/usr/lib/ (V:2.6)

and the other in:

/usr/local/glib2224 (V:2.22.4)

Tree little questions:

1) How should I export the PKG_CONFIG_PATH and the LD_LIBRARY_PATH?

2) Should them both have permanent settings?

3) May be the libraries coexist (2.6 and 2.22.4) or should them be unified? (replaced)
Regards.

Alejandro.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
GTK+ programs on Windows without having to install GTK+, GLib, etc Nylex Programming 2 02-19-2006 02:33 PM
Freerock uninstall stole GTK looking for up-to-date pango, atk, gtk, glib and xft tgz Oholiab Slackware 8 09-18-2005 12:57 PM
glib and gtk + charnel Linux - Software 3 04-13-2005 11:46 AM
Glib/gtk what is it ? i really need him ? SlackwareMan Linux - Newbie 6 07-31-2004 06:56 PM
can't install gtk 2.4.4: "Requested 'glib-2.0 >= 2.4.0' but version of GLib is 2.2.3 webazoid Linux - Software 0 07-15-2004 07:07 PM


All times are GMT -5. The time now is 02:26 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration