LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 11-05-2003, 05:10 AM   #1
Obscure
Member
 
Registered: Apr 2003
Location: Milan
Distribution: Slackware 10 / FreeBSD 5.3
Posts: 175

Rep: Reputation: 32
Dial with modem...


I've got a Wytek 56k USB Modem
The Chipset is a SGS Thompson Microelettronics 56k SoftModem as show lsusb:

Bus 003 Device 002: ID 0483:7554 SGS Thomson Microelectronics 56k SoftModem

This modem is not officialy supported...but MAYBE is possible to make it works with various drivers; one is produced by www.smlink.com for linux
I found this driver here: http://www.aztech.com/driver/modem_um9800.htm

I've installed this drivers and now I have:

#dmesg | grep modem

acm.c: v0.21:USB Abstract Control Model driver for USB modems and ISDN adapters
ttySL0: st7554 modem

I understand that a st7554 modem is founded!! The above output of lsusb shows a device with id 7554!!



My Problem now is to dial with modem to verify it it works good!!

I linked /dev/modem to /dev/ttySL0

Someone should help me to verify if my modem works??
TnxVM
 
Old 11-05-2003, 06:07 AM   #2
SADANA
LQ Newbie
 
Registered: Nov 2001
Location: Amman - Jordan
Distribution: Slackware
Posts: 25

Rep: Reputation: 15
use "minicom", you can issue AT commands to your modem that way.
just run "minicom -s" to edit the ports, save the changes then try and issue "AT" it should reply "OK" if everything is ok!
 
Old 11-05-2003, 07:38 AM   #3
Obscure
Member
 
Registered: Apr 2003
Location: Milan
Distribution: Slackware 10 / FreeBSD 5.3
Posts: 175

Original Poster
Rep: Reputation: 32
Using minicom I got after modem initialization:

AT S7=45 S0=0 L1 V1 X4 &c1 E1 Q0
OK

If I type for example:
ATZ
it answer OK
and so on...

I think that modem should working!!

Now what can I use to connect to internet with it??
pppd??
Tnx
 
Old 11-05-2003, 11:21 AM   #4
uglydot
Member
 
Registered: Mar 2003
Distribution: Gentoo
Posts: 232

Rep: Reputation: 30
I liked kppp, but obviously, you need KDE stuff installed.
 
Old 11-05-2003, 12:33 PM   #5
shepper
Member
 
Registered: Mar 2003
Location: Dry, Dusty and Conservative
Distribution: OpenBSD, Debian Wheezy/Jessie
Posts: 449

Rep: Reputation: 33
It will depend on the desktop your are using. Make sure that you selected loopback/modem under "netconfig". If not run "netconfig" as root. A generic dialer can be setup using "pppsetup" as root.. "ppp-on" will start the modem (initially this requires root permissions). Here is a thread on how to setup ppp-on for users
Thread on setting up modem for users

Last edited by shepper; 11-05-2003 at 12:34 PM.
 
Old 11-05-2003, 01:05 PM   #6
Obscure
Member
 
Registered: Apr 2003
Location: Milan
Distribution: Slackware 10 / FreeBSD 5.3
Posts: 175

Original Poster
Rep: Reputation: 32
TNX VM all!
I use Dropline Gnome...so I don't have kppp or smiliar Qt stuff

If in minicom I type:

ATDTmyISPphonenumber

I recive: NO CARRIER

I try to run pppsetup but typing ppp-on or ppp-go it says: connect script failed

I don't understand 1thing: who must compose my isp phone number ppp or minicom or who??
Tnx All
 
Old 11-05-2003, 08:35 PM   #7
shepper
Member
 
Registered: Mar 2003
Location: Dry, Dusty and Conservative
Distribution: OpenBSD, Debian Wheezy/Jessie
Posts: 449

Rep: Reputation: 33
1) Are you running ppp-on as root?
2) Do you have call waiting and did you disable it?
3) Minicom allows you to interface directly though the modem. This is useful for debugging your
modem connection. Minicom is a little to much for day to day use.
4) Did you set up your nameserver DNS in /etc/hosts?
 
Old 11-06-2003, 05:50 AM   #8
Obscure
Member
 
Registered: Apr 2003
Location: Milan
Distribution: Slackware 10 / FreeBSD 5.3
Posts: 175

Original Poster
Rep: Reputation: 32
1) Yes I'm running ppp-on as root
2) Really I don't know... I think is disabled! How can I control it??
3) I use minicom 'cause I need to test if my modem works 'cause the driver aren't the originals. I'm open to suggestion for another tool
4) No I didn't! Now yes! Does the carrier error depends from DNS?

Last edited by Obscure; 11-06-2003 at 05:54 AM.
 
Old 11-06-2003, 09:43 AM   #9
shepper
Member
 
Registered: Mar 2003
Location: Dry, Dusty and Conservative
Distribution: OpenBSD, Debian Wheezy/Jessie
Posts: 449

Rep: Reputation: 33
2) atdt*70,yourISPphone# in pppsetup. This will also fix the error I caused in /etc/hosts
-sorry
3) If you right click on a blank spot on the gnome "Applications" tool bar "Add to Panel" >
"Internet" > "Modem Lights"
4) Sorry, I had the file wrong that sets the DNS. It is /etc/resolv.conf. MY ISP (Earthlink)
needed me to place the entry
nameserver 207.127.077.83 (This # is specific to Earthlink)
It may be best to call your ISP if # 2 does not work and get the DNS number(s)
and put them in /etc/resolv.conf.
5) Had a series of posts about getting modem-lights to run as user. Search this forum for
modem-lights when you are ready

Last edited by shepper; 11-06-2003 at 09:48 AM.
 
Old 11-06-2003, 11:21 PM   #10
speck
Member
 
Registered: Nov 2001
Location: California
Distribution: Slackware 14.1
Posts: 274

Rep: Reputation: 54
These are the files you _may_ need to modify after you finish running pppsetup:

Code:
/etc/ppp/pap-secrets
/etc/ppp/pppscript
/etc/ppp/options
/etc/resolv.conf
The following is an example of what each of the files should look like.

Code:
/etc/ppp/pap-secrets:

# Username      Server      Password      IP addresses
"myusername"   *   "mypassword"
A few things to look out for in "pppscript". Make sure you put an "OK" at the end of each "AT" line. Also, modify the "ATQ0" line to match your modem.
Code:
/etc/ppp/pppscript:

TIMEOUT 60
ABORT ERROR
ABORT BUSY
ABORT "NO CARRIER"
ABORT "NO DIALTONE"
"" "AT\&F" OK
"ATQ0 V1 E1 S0=0 \&C1 \&D2 S11=55" OK
"atdt*70,5551212"
TIMEOUT 75
CONNECT
Code:
/etc/ppp/options:

lock
defaultroute
noipdefault
modem
/dev/modem
57600
crtscts
passive
asyncmap 0
name "myusername"
Enter the domain (your_isp.com) and DNS server IP's (nameserver) of your ISP.
Code:
/etc/resolv.conf:

search your_isp.com
nameserver 150.99.99.98
nameserver 150.99.99.99
Then run (as root) "/usr/sbin/ppp-on" to connect and "/usr/sbin/ppp-off" to disconnect.

Speck
 
Old 11-07-2003, 08:57 AM   #11
Obscure
Member
 
Registered: Apr 2003
Location: Milan
Distribution: Slackware 10 / FreeBSD 5.3
Posts: 175

Original Poster
Rep: Reputation: 32
Tnx again to all!!
Since I started to try to make this modem working (1 year ago) I never found a person which had a good result with it!!
This bad modem is a bad winModem too!!!
So..Go on...

All this files seems to be correct on my system:
/etc/ppp/pap-secrets
/etc/ppp/options
/etc/resolv.conf

This is my /etc/ppp/pppscript:

Code:
TIMEOUT 60
ABORT ERROR
ABORT BUSY
ABORT "NO CARRIER"
ABORT "NO DIALTONE"
"" "AT&FH0" OK 
"atdt*70,1234567890"
TIMEOUT 75
CONNECT
Connecting with Modem lights produce no effects...
Typing ppp-on says: Connect Script failed
Using minicom:
#minicom
...
AT S7=45 S0=0 L1 V1 X4 &c1 E1 Q0
OK
ATDTispphonenumber

NO DIALTONE



I think the problem is the initialization string!
I wasn't able to find one that is correct!!
I also don't if there are differencies beetween int strings for Italy and other countries...
 
Old 11-07-2003, 03:22 PM   #12
shepper
Member
 
Registered: Mar 2003
Location: Dry, Dusty and Conservative
Distribution: OpenBSD, Debian Wheezy/Jessie
Posts: 449

Rep: Reputation: 33
Modem lights can use any command you enter "ppp-on" or "ppp-go" but you have to configure it. As user the command needs the whole path "/usr/sbin/ppp-on" Right click on the modem-lights icon and select properties to configure.

I do not know if you changed your ISP's number for security reasons but if that is really your pppscript then I would suspect that you do not have the correct phone number.. Also see what kind of authentication protocol your ISP provides (chat, etc) and select that in pppsetup.
 
Old 11-07-2003, 06:09 PM   #13
minio
Member
 
Registered: Sep 2003
Location: Czech Republic - Prague
Distribution: Slackware 9.1
Posts: 61

Rep: Reputation: 15
Quote:
Originally posted by Obscure
I think the problem is the initialization string!
I wasn't able to find one that is correct!!
I also don't if there are differences between int strings for Italy and other countries...
I think you are right. I think you must use "atx3dt123456789" instead of "atdt*70,123456789" to avoid waiting for dial-tone. And if you want to use modem lights as a user you should do

chmod 6755 /usr/sbin/ppp-on
chmod 6755 /usr/sbin/ppp-stop
chmod 6755 /usr/sbin/pppd
(and maybe chmod 6755 /usr/sbin/chat)

chmod 644 /etc/ppp/options
chmod 644 /etc/ppp/pppscript

to get permissions to get ppp-on and ppp-stop scripts working for users.
 
Old 11-08-2003, 08:47 AM   #14
Obscure
Member
 
Registered: Apr 2003
Location: Milan
Distribution: Slackware 10 / FreeBSD 5.3
Posts: 175

Original Poster
Rep: Reputation: 32
Quote:
Originally posted by shepper

I do not know if you changed your ISP's number for security reasons but if that is really your pppscript then I would suspect that you do not have the correct phone number..
Yes... is an example number, not the right one


Quote:
Originally posted by shepper

Modem lights can use any command you enter "ppp-on" or "ppp-go" but you have to configure it. As user the command needs the whole path "/usr/sbin/ppp-on" Right click on the modem-lights icon and select properties to configure
I tried all the scripts...
I said "producue no effect" meaning doesn't work!
To lunch the scripts I use the shell...Modem lights do the same thing!

Quote:
Originally posted by minio

I think you are right. I think you must use "atx3dt123456789" instead of "atdt*70,123456789" to avoid waiting for dial-tone. And if you want to use modem lights as a user you should do
TNX VM, I will try it!!
I'm searching the init string used by M$windows on my pc but I don't find it...

Tnx To All 4 help!!
 
Old 11-08-2003, 12:49 PM   #15
Obscure
Member
 
Registered: Apr 2003
Location: Milan
Distribution: Slackware 10 / FreeBSD 5.3
Posts: 175

Original Poster
Rep: Reputation: 32
Finally some progress...

Well...

#minicom
...
AT S7=45 S0=0 L1 V1 X4 &c1 E1 Q0
OK

atx3dt0332951010
CONNECT 52000

Username:
Password:
~Entering PPP mode.}-}*Async interface address is unnumbered (Loopback0)}-}*Your IP address is 151.29.215.250. MR

After 10 seconds the connection falls!!
minicom.log says:
20031108 17:06:36 Gone offline (0:00:50)

Suggestions??
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Dial-In PPP dial-in server/ Cable-modem & LAN / Setting up "dannyboyOnline" dannyboy259 Linux - Networking 2 01-12-2007 12:40 AM
modem does not dial marjolaine Linux - Networking 11 07-31-2005 04:03 PM
SUSE 9.2 detect my [B]ADSL USB-Ethernet Modem-Router [/B] as a [B]Dial up modem[/B]. myprecius Linux - Hardware 0 06-27-2005 09:21 AM
Modem to Modem connection to test dial-up webcam server dazz Linux - Newbie 2 06-01-2005 04:43 AM
Dial into modem dnorseman Linux - Networking 1 06-18-2004 02:48 AM


All times are GMT -5. The time now is 07:20 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration