LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 03-24-2006, 01:07 PM   #1
erpe
Member
 
Registered: Sep 2005
Distribution: OpenSuse 10.2
Posts: 114

Rep: Reputation: 15
DHCP not working :-(


I can't get my DHCP working. I tried every thing but to no avail. Who can help me?
 
Old 03-24-2006, 01:12 PM   #2
odevans
Member
 
Registered: Nov 2005
Location: Columbus, OH, USA
Distribution: Slackware
Posts: 246

Rep: Reputation: 30
Quote:
Originally Posted by erpe
I can't get my DHCP working. I tried every thing but to no avail. Who can help me?
Could you be a little less vague please? What have you tried? Do you have the necessary dhcp packages installed?

Did you try the command "dhcpcd eth0" (if eth0 is your NIC)?

Check for the packages with "ls -l /var/log/packages | grep -i dhcp"

Check your NIC is recognised with "ifconfig -a"
 
Old 03-24-2006, 02:36 PM   #3
erpe
Member
 
Registered: Sep 2005
Distribution: OpenSuse 10.2
Posts: 114

Original Poster
Rep: Reputation: 15
dhcpcd eth0 Didn't do anything.

ls -l /var/log/packages | grep -i dhcpgives me:
-rw-r--r-- 1 root root 1809 2006-03-24 20:42 dhcp-3.0.3-i486-1
-rw-r--r-- 1 root root 1500 2006-03-24 20:42 dhcpcd-1.3.22pl4-i486-2

ifconfig -a gives me:
lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:80 errors:0 dropped:0 overruns:0 frame:0
TX packets:80 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:6952 (6.7 Kb) TX bytes:6952 (6.7 Kb)

Hope this helps!
 
Old 03-24-2006, 02:49 PM   #4
odevans
Member
 
Registered: Nov 2005
Location: Columbus, OH, USA
Distribution: Slackware
Posts: 246

Rep: Reputation: 30
What NIC do you have? It may be that the kernel module (driver) isn't loaded.
 
Old 03-24-2006, 02:55 PM   #5
dutra2418
LQ Newbie
 
Registered: Mar 2006
Distribution: Slack 10.2
Posts: 16

Rep: Reputation: 0
as root type '/etc/rc.d/rc.inet1 start' and see if that will start it up
 
Old 03-24-2006, 03:16 PM   #6
erpe
Member
 
Registered: Sep 2005
Distribution: OpenSuse 10.2
Posts: 114

Original Poster
Rep: Reputation: 15
/etc/rc.d/rc.inet1 start Doesn't work

I have a Marvel Yukon ethernetcard.
 
Old 03-24-2006, 03:28 PM   #7
odevans
Member
 
Registered: Nov 2005
Location: Columbus, OH, USA
Distribution: Slackware
Posts: 246

Rep: Reputation: 30
Have you tried Marvell's Linux driver?

http://www.marvell.com/drivers/search.do
 
Old 03-24-2006, 04:01 PM   #8
urka58
Member
 
Registered: Nov 2003
Distribution: slackware 14
Posts: 532

Rep: Reputation: 30
First make sure the driver is loaded by your system
dmesg | grep eth0
and
lsmod | grep sk98lin (the name of the driver)
should give you the necessary info.
How did you configure your network ? Did use use netconfig or are trying to configure it manually ?. The second requires you edit your /etc/rc.d/rc.inet1.conf.
Ciao
 
Old 03-24-2006, 04:09 PM   #9
odevans
Member
 
Registered: Nov 2005
Location: Columbus, OH, USA
Distribution: Slackware
Posts: 246

Rep: Reputation: 30
D'oh, forgot about sk98lin.

If it doesn't show up in lsmod, add it with "modprobe sk98lin".
 
Old 03-24-2006, 04:23 PM   #10
dunric
Member
 
Registered: Jul 2004
Distribution: Slackware
Posts: 462

Rep: Reputation: 75
Code:
ifconfig -a
would also reveal if your NIC is recognized by the kernel.
 
Old 03-24-2006, 06:03 PM   #11
erpe
Member
 
Registered: Sep 2005
Distribution: OpenSuse 10.2
Posts: 114

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by urka58
First make sure the driver is loaded by your system
dmesg | grep eth0
and
lsmod | grep sk98lin (the name of the driver)
should give you the necessary info.
How did you configure your network ? Did use use netconfig or are trying to configure it manually ?. The second requires you edit your /etc/rc.d/rc.inet1.conf.
Ciao
I used netconfig to setup my dhcp connection. What I don't understand is that slackware is as far as I know the only distro not to support my networkcard. Any thoughts on how this can be?

P.S. Thanks for all the tips!
 
Old 03-24-2006, 06:20 PM   #12
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,294

Rep: Reputation: Disabled
Quote:
ifconfig -a gives me:
lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:80 errors:0 dropped:0 overruns:0 frame:0
TX packets:80 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:6952 (6.7 Kb) TX bytes:6952 (6.7 Kb)
That clearly shows that the driver for the card is not loaded (or else you would have seen eth0 mentioned).
Have you tried running
Code:
modprobe sk98lin
followed by
Code:
ifconfig -a
to see if that gives you eth0?
Running netconfig and setting up eth0 does not mean that eth0 is thereby ready to go. Configured yes, but loading the driver is either the task of the hotplug subsystem, or you add a "modprobe" command in the file /etc/rc.d/rc.netdevice yourself if hotplug does not recognize the card for whatever reason. That file "rc.netdevice" may not yet exist by the way. If the Slackware installer had recognized your card it would have setup that file for you. So, let's do it now:
Code:
vi /etc/rc.d/rc.netdevice
Add this single line to it:
Code:
/sbin/modprobe sk98lin
And after saving the file, make it executable:
Code:
chmod +x /etc/rc.d/rc.netdevice
Now, try to reboot and see what happens.

Eric
 
Old 03-24-2006, 06:51 PM   #13
erpe
Member
 
Registered: Sep 2005
Distribution: OpenSuse 10.2
Posts: 114

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by Alien Bob
That clearly shows that the driver for the card is not loaded (or else you would have seen eth0 mentioned).
Have you tried running
Code:
modprobe sk98lin
followed by
Code:
ifconfig -a
to see if that gives you eth0?
Running netconfig and setting up eth0 does not mean that eth0 is thereby ready to go. Configured yes, but loading the driver is either the task of the hotplug subsystem, or you add a "modprobe" command in the file /etc/rc.d/rc.netdevice yourself if hotplug does not recognize the card for whatever reason. That file "rc.netdevice" may not yet exist by the way. If the Slackware installer had recognized your card it would have setup that file for you. So, let's do it now:
Code:
vi /etc/rc.d/rc.netdevice
Add this single line to it:
Code:
/sbin/modprobe sk98lin
And after saving the file, make it executable:
Code:
chmod +x /etc/rc.d/rc.netdevice
Now, try to reboot and see what happens.

Eric
I followed your instructions to the letter, and its working! (I am typing this from my fresh slackware install ) Thanks everyone who helped me, now i am going to dug a little deeper into slack
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
dhcp AGAIN... not working... ploptor1 Linux - Networking 1 03-09-2006 05:46 AM
Cant get DHCP working vMatthews Debian 3 10-07-2005 09:59 PM
DHCP just isn't working! GhostOfYoda Linux - Networking 1 08-01-2003 04:32 AM
DHCP is working but still nothing im_not_jose Linux - Networking 12 07-26-2003 06:51 AM
DHCP isn't working. 95se Linux - Networking 5 05-16-2002 05:40 PM


All times are GMT -5. The time now is 04:59 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration