LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 08-08-2012, 02:20 PM   #1
mariano
LQ Newbie
 
Registered: Feb 2011
Posts: 7

Rep: Reputation: 0
Console resolution problem


Hi all!

Im using Slackware 13.37, when the system boots, the console res. goes to 1024x768, and I need 640x480 or 800x600.

Changing the lilo.conf only change the resolution of the first part of thr boot, after some point the system always goes to 1024x768.

I was looking at rc.modules, rc.S, rc.fonts to see if one of that is changind the configuration selected by the lilo.conf.

Someone can help me with this?
 
Old 08-08-2012, 02:23 PM   #2
frieza
Senior Member
 
Registered: Feb 2002
Location: harvard, il
Distribution: Ubuntu 11.4,DD-WRT micro plus ssh,lfs-6.6,Fedora 15,Fedora 16
Posts: 3,079

Rep: Reputation: 368Reputation: 368Reputation: 368Reputation: 368
if you are using lilo, then yes, the setting would be in lilo.conf, there should be a line that has something like 'vga=791'
http://www.pendrivelinux.com/vga-boo...en-resolution/
should have more information
 
Old 08-08-2012, 02:30 PM   #3
Mike_M
Member
 
Registered: Mar 2011
Location: California
Distribution: Slackware
Posts: 116

Rep: Reputation: 50
It sounds like KMS (Kernel Mode Setting) may be causing your issue. If that is the case, it will override any changes you may make to the "vga" parameter. Try adding

Code:
append = "nomodeset"
to /etc/lilo.conf, run lilo as root, and reboot your system.

(If there is already an append line in your lilo.conf file, add the nomodeset option to that existing line.)
 
Old 08-08-2012, 03:52 PM   #4
mariano
LQ Newbie
 
Registered: Feb 2011
Posts: 7

Original Poster
Rep: Reputation: 0
Thats was exactly the problem Mike_M, thanks!
 
Old 08-08-2012, 04:09 PM   #5
kikinovak
Senior Member
 
Registered: Jun 2011
Location: Montpezat (South France)
Distribution: ElementaryOS, Ubuntu LTS, Slackware
Posts: 1,502

Rep: Reputation: 695Reputation: 695Reputation: 695Reputation: 695Reputation: 695Reputation: 695
Quote:
Originally Posted by mariano View Post
Hi all!

Im using Slackware 13.37, when the system boots, the console res. goes to 1024x768, and I need 640x480 or 800x600.
For 800x600, you need this in lilo.conf:

Code:
vga=788
 
Old 08-08-2012, 04:12 PM   #6
volkerdi
Slackware Maintainer
 
Registered: Dec 2002
Location: Minnesota
Distribution: Slackware! :-)
Posts: 858

Rep: Reputation: 1668Reputation: 1668Reputation: 1668Reputation: 1668Reputation: 1668Reputation: 1668Reputation: 1668Reputation: 1668Reputation: 1668Reputation: 1668Reputation: 1668
Disabling KMS is going to cause trouble with running X. A better solution is something like video=800x600 or video=640x480, which will increase the text size on the console without affecting X.
 
Old 08-08-2012, 04:47 PM   #7
Didier Spaier
Senior Member
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slackware{,64}-{14.1,current} on a Lenovo Thinkpad T61 6457-4XG
Posts: 4,035

Rep: Reputation: 973Reputation: 973Reputation: 973Reputation: 973Reputation: 973Reputation: 973Reputation: 973Reputation: 973
Quote:
Originally Posted by volkerdi View Post
Disabling KMS is going to cause trouble with running X.
Not here, Sir.

I just launched Slackware 13.37 with "Linux nomodeset" and after "startx" X took care of inserting the nouveau module and its dependencies, including drm_kms_helper.

This is with a nVidia GPU of course and I can't say a word for other brands and drivers.
 
Old 08-08-2012, 04:55 PM   #8
kikinovak
Senior Member
 
Registered: Jun 2011
Location: Montpezat (South France)
Distribution: ElementaryOS, Ubuntu LTS, Slackware
Posts: 1,502

Rep: Reputation: 695Reputation: 695Reputation: 695Reputation: 695Reputation: 695Reputation: 695
Quote:
Originally Posted by Didier Spaier View Post
I just launched Slackware 13.37 with "Linux nomodeset" and after "startx" X took care of inserting the nouveau module and its dependencies, including drm_kms_helper.
You sure about this? Until now, AFAIK, nouveau worked with KMS. With NVidia cards, I only specify 'nomodeset' with the proprietary driver (which I always use). Plus, I also blacklist 'nouveau', which is sort of redundant, but just to be on the safe side that there is no conflict with nouveau.

This morning I setup X on an old Panasonic Toughbook with an Intel Express card. Had to fiddle around a bit with it, since I have to edit mkinitrd.conf and specify the Intel modules explicitly like this, to be included in the initrd:

Code:
MODULES="ext4:intel_agp:i915"
Unless configured like this, with KMS, this card for example won't work properly.
 
Old 08-08-2012, 05:05 PM   #9
kikinovak
Senior Member
 
Registered: Jun 2011
Location: Montpezat (South France)
Distribution: ElementaryOS, Ubuntu LTS, Slackware
Posts: 1,502

Rep: Reputation: 695Reputation: 695Reputation: 695Reputation: 695Reputation: 695Reputation: 695
Quote:
Originally Posted by volkerdi View Post
Disabling KMS is going to cause trouble with running X. A better solution is something like video=800x600 or video=640x480, which will increase the text size on the console without affecting X.
Thanks for that one! Been trying for quite some time to enlarge those super-tiny fonts with KMS enabled, but to no avail.

Immer wenn du glaubst, es geht nicht mehr,
Kommt von irgendwo ein Lichtlein her.

 
Old 08-08-2012, 05:14 PM   #10
Didier Spaier
Senior Member
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slackware{,64}-{14.1,current} on a Lenovo Thinkpad T61 6457-4XG
Posts: 4,035

Rep: Reputation: 973Reputation: 973Reputation: 973Reputation: 973Reputation: 973Reputation: 973Reputation: 973Reputation: 973
Well, let's put it this way: I was half wrong

I mean that I have no problem launching X, but the vesa driver for X is used instead of nouveau, though the nouveau kernel module be loaded.

This is probably because KMS was disabled, as I see in X logs this error message:
Code:
(EE) [drm] failed to open device
And before somebody suggests me to RTFM, yes I did read this page. But maybe I did misread it
 
Old 08-08-2012, 05:21 PM   #11
Mike_M
Member
 
Registered: Mar 2011
Location: California
Distribution: Slackware
Posts: 116

Rep: Reputation: 50
Quote:
Originally Posted by volkerdi View Post
Disabling KMS is going to cause trouble with running X. A better solution is something like video=800x600 or video=640x480, which will increase the text size on the console without affecting X.
Are there particular drivers for which disabling KMS causes problems, or is it universal? Your statement "Disabling KMS is going to cause trouble with running X" would seem to indicate it is universal. I don't recall ever having problems with disabling it in the past, although I don't currently disable it.
 
Old 08-08-2012, 05:38 PM   #12
kikinovak
Senior Member
 
Registered: Jun 2011
Location: Montpezat (South France)
Distribution: ElementaryOS, Ubuntu LTS, Slackware
Posts: 1,502

Rep: Reputation: 695Reputation: 695Reputation: 695Reputation: 695Reputation: 695Reputation: 695
Quote:
Originally Posted by Didier Spaier View Post
Well, let's put it this way: I was half wrong
Half right is not bad either
 
Old 08-08-2012, 05:41 PM   #13
kikinovak
Senior Member
 
Registered: Jun 2011
Location: Montpezat (South France)
Distribution: ElementaryOS, Ubuntu LTS, Slackware
Posts: 1,502

Rep: Reputation: 695Reputation: 695Reputation: 695Reputation: 695Reputation: 695Reputation: 695
Quote:
Originally Posted by Mike_M View Post
Are there particular drivers for which disabling KMS causes problems, or is it universal? Your statement "Disabling KMS is going to cause trouble with running X" would seem to indicate it is universal. I don't recall ever having problems with disabling it in the past, although I don't currently disable it.
As far as my experience with various hardware goes, you need KMS...

- with NVidia cards if you intend to use the 'nouveau' driver
- with most Intel graphic cards

Correct me if I'm wrong.
 
Old 08-08-2012, 06:11 PM   #14
volkerdi
Slackware Maintainer
 
Registered: Dec 2002
Location: Minnesota
Distribution: Slackware! :-)
Posts: 858

Rep: Reputation: 1668Reputation: 1668Reputation: 1668Reputation: 1668Reputation: 1668Reputation: 1668Reputation: 1668Reputation: 1668Reputation: 1668Reputation: 1668Reputation: 1668
Quote:
Originally Posted by Mike_M View Post
Are there particular drivers for which disabling KMS causes problems, or is it universal? Your statement "Disabling KMS is going to cause trouble with running X" would seem to indicate it is universal. I don't recall ever having problems with disabling it in the past, although I don't currently disable it.
Since the OP had verified that disabling KMS fixed the console, the driver for that video chipset was clearly using KMS. And at this point, I think any driver that can use KMS requires it. It's not universal though. There are still drivers that don't use KMS.
 
Old 08-09-2012, 02:45 AM   #15
Didier Spaier
Senior Member
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slackware{,64}-{14.1,current} on a Lenovo Thinkpad T61 6457-4XG
Posts: 4,035

Rep: Reputation: 973Reputation: 973Reputation: 973Reputation: 973Reputation: 973Reputation: 973Reputation: 973Reputation: 973
For nouveau users there is also the possibility of blacklisting the nouveau kernel module, still keeping xf86-video-nouveau installed. No framebuffer will be used during startup, the nouveau kernel module will be inserted after X starts and X will use the nouveau driver. But after that the console will use the nouveau framebuffer as well, which may not be what the OP wants. Just wanted to mention that because this is my setting right now.

PS This is with vga=normal.

Last edited by Didier Spaier; 08-09-2012 at 04:21 AM. Reason: PS added
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
X and console resolution problem hsimah Slackware 3 03-27-2013 09:28 PM
KDE to console - resolution problem ejbram Slackware 12 07-26-2007 08:17 AM
console resolution problem. whansard Slackware 3 07-30-2004 09:39 AM
Console Resolution Problem After Kernel Update ShoCkwave Slackware 5 07-09-2004 10:53 AM
Console resolution problem after compiling 2.6.2 ... Cdzin Slackware 6 02-11-2004 10:32 AM


All times are GMT -5. The time now is 07:54 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration